Jump to content
Sign in to follow this  
macman1

Can i unlock after installing CM7?

Recommended Posts

Hi i just inserted a 3 sim and i don't get a prompted to insert my unlock code?

the sim dose not work however.

i have owed the phone since new so it hasent been unlocked.

PS it is a orange San Francisco

thanks for any help

Share this post


Link to post
Share on other sites
BUMP NEED HELP

guessing here, so bear with me

Often you don't need to have unlocked on eclair for your phone to accept other sims on froyo roms - presumably same on gingerbread (ie cm7)

TBH there's not much reason not to unlock your blade, since it's free

There are links to unlock code generators pinned on the front page, should you ever want to downgrade and unlock

Moving on

Do you have your orange sim?

If yes, shove it in and see if it picks up a signal

If not, shove in another one and check same

I've a dim recollection of reading of someone else having trouble with CM7 getting stuck in flight mode in the last couple of days on here (might be essentially similar to your predicament)

Good luck

ps - are you sure the 3 sim's a goer?

Share this post


Link to post
Share on other sites
guessing here, so bear with me

Often you don't need to have unlocked on eclair for your phone to accept other sims on froyo roms - presumably same on gingerbread (ie cm7)

TBH there's not much reason not to unlock your blade, since it's free

There are links to unlock code generators pinned on the front page, should you ever want to downgrade and unlock

Moving on

Do you have your orange sim?

If yes, shove it in and see if it picks up a signal

If not, shove in another one and check same

I've a dim recollection of reading of someone else having trouble with CM7 getting stuck in flight mode in the last couple of days on here (might be essentially similar to your predicament)

Good luck

ps - are you sure the 3 sim's a goer?

i have now tryed an o2 sim and it still dose not ask for my unlock code which i have should i have done it at stock? the sim wont pick up any signal.

thanks for posting :mellow:

Share this post


Link to post
Share on other sites
i have now tryed an o2 sim and it still dose not ask for my unlock code which i have should i have done it at stock? the sim wont pick up any signal.

thanks for posting :mellow:

Is this your current status?

  • Orange Sim - Working
  • O2 Sim - Working
  • 3 Sim - Not working

If so I think your 3 Sim is dead - or not been used recently - so de-activated by Three?

Share this post


Link to post
Share on other sites

i have got the same problem with some newer blade from switzerland.

i just flashed the "old" UK stock rom for TFT and unlocking went fine.

i did the the JellyFish9 TPT to get amunRA recovery and flashed then UK stock rom.

unlock and did CM7 TPT.

i recommend first to unlock then to go to CM7

Share this post


Link to post
Share on other sites
Is this your current status?
  • Orange Sim - Working
  • O2 Sim - Working
  • 3 Sim - Not working

If so I think your 3 Sim is dead - or not been used recently - so de-activated by Three?

Hi Only the orange sim works as i dont get asked for the unlock code on 3 or o2 sim cards.

Share this post


Link to post
Share on other sites
i have got the same problem with some newer blade from switzerland.

i just flashed the "old" UK stock rom for TFT and unlocking went fine.

i did the the JellyFish9 TPT to get amunRA recovery and flashed then UK stock rom.

unlock and did CM7 TPT.

i recommend first to unlock then to go to CM7

Ah i was worried about someone saying that as i dont really want to go back to stock then back to CM7. ill wait a bit longer and see if anyone else posts any more info.

Thanks

Share this post


Link to post
Share on other sites

You shouldn't need to unlock it if you're on CM7, that ignores the network lock. Half of the network locking mechanism is in the rom, the rom can just ignore it. I never unlocked this phone, put CM7 on it, then put a T-Mobile SIM in it & it all works fine. So it might be some other settings that are wrong, or even just no signal in your area.

Share this post


Link to post
Share on other sites
You shouldn't need to unlock it if you're on CM7, that ignores the network lock. Half of the network locking mechanism is in the rom, the rom can just ignore it. I never unlocked this phone, put CM7 on it, then put a T-Mobile SIM in it & it all works fine. So it might be some other settings that are wrong, or even just no signal in your area.

thanks for the info, didn't know that about CM7, after all these CM builds are full of surprises lol...i mean, the video file i was trying to play on froyo rom was giving me 15FPS in full screen when in CM7 it gives around 25+ FPS...

Share this post


Link to post
Share on other sites

I went from Orange to giffgaff and had to install a stock ROM to unlock. CM7 would see the sim as giffgaff but I couldn't make or receive calls until I unlocked the Blade

Share this post


Link to post
Share on other sites
When i went into signal with the 3 sim it went to roaming on oranges network why is that?
3 uses Orange's network for 2G coverage.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.