Jump to content
erikcas

CyanogenMod 6.1.1 for B7610 update 01-06 // I am stopping my contributions as my phone died

Recommended Posts

I've tried to reproduce the steps of VMZ but nothing is working.

Also, my phonepart isn't working (i mean that there is no operator signal,and with this i mean that it's impossible to make everything)

For erickas: Installing the i8000 android i've seen that when I go in settings and turn on wifi the wifi is actually turning on (not like in b7610 that says error when trying to do the same thing). After that the phone isn't able to find any wifi connection but this (in my opinion) it's a mac address problem and easy solvable.

So can't you please try to "extract" wifi drivers from I8000 and put on b7610 release?

Hope i can be helpful.

Thx for all the work you are doing and as allways count on me for testing.

Greetings from italy

if u want to make keys work i have found a workaround...just rename the update file as ext4.tar.gz and open autoinstaller and it will update android and then boot android with zimage(rev 98)..but still network not working for me.

and erik is working on wifi and i think he is on last step(s)....

Edited by gauravv

Share this post


Link to post
Share on other sites

Think Voyteckst compiled the FM radio in the android image. Doesn't mean it will work out of the box on B7610.

You can try to install the version. Copy modem.bin from current b7610 image to the sd dir on android ext4 and copy the init.rc and loadmod from current install to root of ext4.

Offcourse use b7610 zImage and update

Will try, but I had a SOD earlier which now prevents me from booting into Android at this moment. FM radio i will maybe test but it's not something that interest me.

Copy from current you mean beta 1? I will test it tonight also, now I need to get back to work <_<

by the way, the auto installer version posted on the dev's site works just fine on the B7610.

Hi Erikcas,

According what you said, I copied the modem.bin from CM beta 1 SD dir to the CM beta 2 SD dir, also put the init.rc and loadmod from CM beta 1 root to the root of CM beta 2 but sadly no connection. Booted into Android but no change :angry:

Any more good idea's? Normally it should ask for a phone pin but this doesn't happen.

Cheers,

Alchedin

Edited by Alchedin

Share this post


Link to post
Share on other sites

@Isascaboy89, gauravv: Yes data is working, wifi and bluetooth not. I got data immediately on the first boot, keyboard started working after the steps I previously mentioned...

Share this post


Link to post
Share on other sites

@Isascaboy89, gauravv: Yes data is working, wifi and bluetooth not. I got data immediately on the first boot, keyboard started working after the steps I previously mentioned...

And this is with CyanogenMod Beta 2 or the previous version aka CyanogenMod Beta 1? What did you do to get the phone working? Did it ask for a pin?

Cheers,

Alchedin

Share this post


Link to post
Share on other sites

Also my problem...it doesn't ask me for the pin...by the way i've downloaded last package from the developers site, then i've downloaded the zimage and ext4 from first post of this thread, replaced it in cyanogen mod and now the phone is working but there are no changes from the previous version (maybe it's the same.

Gaurav when you say that erickas is working on wifi and he's on last steps do you mean that it's possible to have a working wifi in next release?

Share this post


Link to post
Share on other sites

Also my problem...it doesn't ask me for the pin...by the way i've downloaded last package from the developers site, then i've downloaded the zimage and ext4 from first post of this thread, replaced it in cyanogen mod and now the phone is working but there are no changes from the previous version (maybe it's the same.

Gaurav when you say that erickas is working on wifi and he's on last steps do you mean that it's possible to have a working wifi in next release?

how you made phone work can u explain your steps ?

Share this post


Link to post
Share on other sites

how you made phone work can u explain your steps ?

Yes for sure.

1) I've downloaded the latest version of android by following THIS link provided by Alchedin at post #1139

2) The link redirect me to the o2droid page, in that page i've downloaded the latest package (the one dated 8th february 2012)

3) Once downloaded i've unzipped it on my desktop then copied it in my storage root

4) Meanwhile i've downloaded the latest cmbeta from THIS link from page 1, which redirected me to the erickas personal page (the page with the black and yellow world with haedphones)

5) From that page i've downloaded the CM B7610 beta1 (787)

6) Once downloaded i've unzipped it on my desktop then copied it on the root of my storage

7) I've overwritten the existing files

8) Then i've erased the useless file (the only file which must NOT BE deleted are o2 folder, haret, ext4 and zimage)

9) Then i've run installandroid from o2beta folder and now it works

By the way it seems to be the old release (the one from 9th december 2011).

Also it seems not to be rooted.

This is what i've done.

Hope it helps.

Greetings from italy

Edited by Isascaboy89

Share this post


Link to post
Share on other sites

Yes for sure.

1) I've downloaded the latest version of android by following THIS link provided by Alchedin at post #1139

2) The link redirect me to the o2droid page, in that page i've downloaded the latest package (the one dated 8th february 2012)

3) Once downloaded i've unzipped it on my desktop then copied it in my storage root

4) Meanwhile i've downloaded the latest cmbeta from THIS link from page 1, which redirected me to the erickas personal page (the page with the black and yellow world with haedphones)

5) From that page i've downloaded the CM B7610 beta1 (787)

6) Once downloaded i've unzipped it on my desktop then copied it on the root of my storage

7) I've overwritten the existing files

8) Then i've erased the useless file (the only file which must NOT BE deleted are o2 folder, haret, ext4 and zimage)

9) Then i've run installandroid from o2beta folder and now it works

By the way it seems to be the old release (the one from 9th december 2011).

Also it seems not to be rooted.

This is what i've done.

Hope it helps.

Greetings from italy

Uhm,

So you've downloaded CM Beta 2, and used the EXT4 from CM Beta 1? I think you mixed up the versions this way?:lol:Because now you are using the beta 1 install. Maybe you can verify it in settings -> about rom -> ROM. Mine said "SpicagenMod Beta 2"

Because both Beta's have a ext4.tar.gz file in it (+ installer and zimage). I've installed using only the Beta 2 install + ext4.tar.gz

Cheers,

Alchedin

Share this post


Link to post
Share on other sites

alchedin lucky u.....itz not working for me

Good, guess we are both lucky having a running android with no functionality. :rolleyes: Guess we have to wait for our "busy bee" Erikcas.

@ Erikcas, you have an idea?

Edited by Alchedin

Share this post


Link to post
Share on other sites

Uhm,

So you've downloaded CM Beta 2, and used the EXT4 from CM Beta 1? I think you mixed up the versions this way?:lol:Because now you are using the beta 1 install. Maybe you can verify it in settings -> about rom -> ROM. Mine said "SpicagenMod Beta 2"

Because both Beta's have a ext4.tar.gz file in it (+ installer and zimage). I've installed using only the Beta 2 install + ext4.tar.gz

Cheers,

Alchedin

I can't find the path you told me.

But it's probable that i'm still in beta1 :lol:

At least beta 1 works well (except for the really desired wifi and bluetooth :angry: )

Hope erickas will release a new version soon

Share this post


Link to post
Share on other sites

For erickas: Installing the i8000 android i've seen that when I go in settings and turn on wifi the wifi is actually turning on (not like in b7610 that says error when trying to do the same thing). After that the phone isn't able to find any wifi connection but this (in my opinion) it's a mac address problem and easy solvable.

So can't you please try to "extract" wifi drivers from I8000 and put on b7610 release?

Hope i can be helpful.

It will not work. It is another chip that is used on i8000 with other driver. Please read the wiki on google project page again.

Also you can check your logcats and dmesg for it. The i8000 will never load b7610 wifi.

Share this post


Link to post
Share on other sites

hey erik whr r u ? :-P

Just got home after a 16 hrs working day. Now enjoy and take care of my 4 months old daughter.

Guys, at the moment I don't have much time for android.

Tomorrow I will try to make the phonepart work for the new cm i8000 version, Sandor published the code.

But thats all for this moment

Share this post


Link to post
Share on other sites

About phone says: Omnia2Droid-2.2.2.0 and kernel..32.9

Is that correct for CM beta 2?

/VM

Share this post


Link to post
Share on other sites

Just got home after a 16 hrs working day. Now enjoy and take care of my 4 months old daughter.

Guys, at the moment I don't have much time for android.

Tomorrow I will try to make the phonepart work for the new cm i8000 version, Sandor published the code.

But thats all for this moment

That would be blast and take care of that daughter, you'll only see them grow up once ;)

Share this post


Link to post
Share on other sites

Just got home after a 16 hrs working day. Now enjoy and take care of my 4 months old daughter.

Guys, at the moment I don't have much time for android.

Tomorrow I will try to make the phonepart work for the new cm i8000 version, Sandor published the code.

But thats all for this moment

take your time...:)

Share this post


Link to post
Share on other sites

Just got home after a 16 hrs working day. Now enjoy and take care of my 4 months old daughter.

Guys, at the moment I don't have much time for android.

Tomorrow I will try to make the phonepart work for the new cm i8000 version, Sandor published the code.

But thats all for this moment

Erickas, i think i talk for all the community when i say take your time, we really want to have a functionally android on our phone but play and enjoy your litter daughter is much more important.

So take all the time you need and enjoy your daughter.

We could wait.

Greetings from italy

Share this post


Link to post
Share on other sites

hey Erik i want to share my opinion

i compared Quadrant Score of beta 1 and beta 2.....i found that beta 2 is more fast due to (what i think ) higher score in I/O i.e 525 ( 250 in beta1 ) but surprised to see beta 2 has less score in 2d 3d...like in beta 1 2d is 120 but in beta 2 its 60 around......so what i like to say is that if we could make beta 1 score high in I/O then we might get faster than beta 2.....and we should concentrate our efforts towards wifi and bluetooth.....which are more important

Regarding FM radio itz works..but if u could tell me which files are responsible we could put in beta 1

And i set vmheap to 48 and incresed swap to 500mb for test....and found that device is alot snappier ( beta 1 )....running services shows around 19 apps running ( 46 mb in 5 and 20 mb in 14)....sometimes in place of 20 mb its around 50 or so

i talked to voyteckst about low 2d 3d score he says he didn't think so drivers are different

Thanks and enjoy time with your daughter :)

Edited by gauravv

Share this post


Link to post
Share on other sites

First, thank you for making this amazing android for omnia pro!

However, I've tried this CM 6.1.1 together with the CM beta2. But it doesn't work.

Every time i start the androidinstall.exe in the o2beta in the root of my storage, it begins to creat partitions initally.

But suddenly errors occur with 'can't have the end before the start!', 'can't have overlapping partitions' signs and 'SWAP partition size:128MB End?' at the end.

I use 2 GB SD card and i've formatted the card.

What can i do?

Share this post


Link to post
Share on other sites

hey Erik i want to share my opinion

i compared Quadrant Score of beta 1 and beta 2.....i found that beta 2 is more fast due to (what i think ) higher score in I/O i.e 525 ( 250 in beta1 ) but surprised to see beta 2 has less score in 2d 3d...like in beta 1 2d is 120 but in beta 2 its 60 around......so what i like to say is that if we could make beta 1 score high in I/O then we might get faster than beta 2.....and we should concentrate our efforts towards wifi and bluetooth.....which are more important

Regarding FM radio itz works..but if u could tell me which files are responsible we could put in beta 1

And i set vmheap to 48 and incresed swap to 500mb for test....and found that device is alot snappier ( beta 1 )....running services shows around 19 apps running ( 46 mb in 5 and 20 mb in 14)....sometimes in place of 20 mb its around 50 or so

i talked to voyteckst about low 2d 3d score he says he didn't think so drivers are different

Thanks and enjoy time with your daughter :)

Drivers are the same. I use same source for it as Voyteckst does. Keep in mind, there could be a slight hardware difference between i8000 and b7610. Maybe setting is in kernel.

Share this post


Link to post
Share on other sites

Sorry for the little OT but i want to uggest you to use this program to "work" on android from the pc.

I'm using it and i'm really satisfied.

You can copy/move/tranfer file, make screenshot and lot of other functions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.