Jump to content
tilal6991

[ICS] [CM9] [4.0.4] ColdFusionX for the ZTE Blade [ROM] [UPDATED - 28/06]

Recommended Posts

First big THANKS to ElrOnDPT very helpful advice.......but another question..before I change to this ROM I made backup to my SD-card of all my applications using Titanum Backup PRO...but now I can not get in touch of my SD card to get access to my backup..I also try to download the Titanum again from Android Market, but it gives message that I already have it on my Blade.

So how to solve this?

Also Im missing the Icon which is in the form of a File and click on it shows what I have on my SD card..

THANKS IN ADVANCE...

Ah.....succed to solve this.....My frist try was to download apps using my laptop...and it gave problem as below...when I later try to do it from my Blade it works without problem...and I succed to move all my apps from my SD card to this new ROM....must say for me it works good now....

Share this post


Link to post
Share on other sites

Good job lalit! Even though I really don't see point in having three separate CM9 projects (Tom G's, burstlam's and your's). You're the only one who is released the source though. That's always appreciated. :)

I compiled a KANG yesterday from what was in your git at that point (up to this commit). Have you patched any of the CyanogenMod/Android side of code (I mean non-device specific)? It came to me as surprice that I only needed to patch external/webrtc/src/common_audio/signal_processing_library/main/interface/spl_inl.h to get it to compile. :o

Could you also tell where these binaries are from and why they're not compiled?

https://github.com/tilal6991/android_device_zte_blade/tree/ics/prebuilt/system/lib/hw

Also tested the 5.5.0.4 ClockWorkMod Recovery that came as a side product. Screen is upside down and only volume keys are working. It can be easily fixed like you have already done for Skate. I actually used those files to compile and now I have a working copy. It didn't make a backup of my sd-ext partition (couldn't mount it) but other than that it seems to be working.

Few observations from my KANG. Most of the issues reported still remain. USB mass storage works in this version but adb doesn't. I'd much rather have working adb to get logcats because random freezes/reboots happen quite often. When you select reboot option from power menu it reboots normally (or to recovery if you wish). In your release it freezes at point of unmounting sdcard and that causes a reboot. Trebuchet force-close can be sorted by unticking the two boxes from app drawer settings like someone already said. What else can I say, CM9 stability seems horrible. That's no fault of yours. ;)

I attached a logcat from freeze that happened earlier with the version from the first post. It just completely froze on lockscreen and eventually rebooted when I pulled off USB cable.

freeze.txt

  • Upvote 1

Share this post


Link to post
Share on other sites

In the next build:

Fixed YouTube - still laggy but videos play

More stable

Trebuchet doesn't crash

Webkit and Gmail work

Reduced number of reboots

This one? Cool! Thanks in advance :)

Share this post


Link to post
Share on other sites

Good job lalit! Even though I really don't see point in having three separate CM9 projects (Tom G's, burstlam's and your's). You're the only one who is released the source though. That's always appreciated. :)

I compiled a KANG yesterday from what was in your git at that point (up to this commit). Have you patched any of the CyanogenMod/Android side of code (I mean non-device specific)? It came to me as surprice that I only needed to patch external/webrtc/src/common_audio/signal_processing_library/main/interface/spl_inl.h to get it to compile. :o

Could you also tell where these binaries are from and why they're not compiled?

https://github.com/t...t/system/lib/hw

Also tested the 5.5.0.4 ClockWorkMod Recovery that came as a side product. Screen is upside down and only volume keys are working. It can be easily fixed like you have already done for Skate. I actually used those files to compile and now I have a working copy. It didn't make a backup of my sd-ext partition (couldn't mount it) but other than that it seems to be working.

Few observations from my KANG. Most of the issues reported still remain. USB mass storage works in this version but adb doesn't. I'd much rather have working adb to get logcats because random freezes/reboots happen quite often. When you select reboot option from power menu it reboots normally (or to recovery if you wish). In your release it freezes at point of unmounting sdcard and that causes a reboot. Trebuchet force-close can be sorted by unticking the two boxes from app drawer settings like someone already said. What else can I say, CM9 stability seems horrible. That's no fault of yours. ;)

I attached a logcat from freeze that happened earlier with the version from the first post. It just completely froze on lockscreen and eventually rebooted when I pulled off USB cable.

Hey KonstaT! Good to see you. I would love to work with burstlam/TomG but burstlam seems to be building AOKP rather than CM9 and TomG is really busy.

The prebuilt libs are from TomG's build. They are they only ones that seem to not boot loop the device (apart from the audio ones - they are the only ones which work).

The fixes to the reported issues were pushed after the commit you compiled for - that's why the issues are still present. Logcat seems to indicate that the memory has run out so the PowerManager has been killed - not good. The heapsize fix I push after should fix that.

Share this post


Link to post
Share on other sites

How odd, I am in the process of trying to fix a graphics corruption issue on a White Orange SanFran (Colours in 8-bit, at least, that's what it looks like), but bar that the device is a fully functional TFT Blade. So, for a laugh, I flashed Cold Fusion onto it.

The Home button works, it crashed once when I tried to use Rom-Manager, Gapps work perfectly, brilliantly smooth, no problems.

So I re-downloaded the files and flashed them onto my own Black SanFran (OLED), it has the same partition layout (at least I think it does O.o), no home button, terribly unstable, GApps won't flash...

I'll keep monitoring the situation and hang back until the next release (or the release after).

Still coming along nicely, good job.

Also, if anyone else has experienced the "8-bit colour" issue on a White TFT SanFran before, let me know if you got it fixed, this is driving me insane...

Share this post


Link to post
Share on other sites

Its a nice rom i can get it booted but i cannot install gapps. Also how do you know what your system partition is?

Share this post


Link to post
Share on other sites

whenever i click on the menu it gives an error close ....... ne solution for this ??? please reply

Yeah i just flashed the ROM and am having that problem, i'm going to try using nova launcher instead, i think someone said that would help further back in the thread

EDIT: or what meler said, haha!

Edited by matt4321

Share this post


Link to post
Share on other sites

How odd, I am in the process of trying to fix a graphics corruption issue on a White Orange SanFran (Colours in 8-bit, at least, that's what it looks like), but bar that the device is a fully functional TFT Blade. So, for a laugh, I flashed Cold Fusion onto it.

The Home button works, it crashed once when I tried to use Rom-Manager, Gapps work perfectly, brilliantly smooth, no problems.

So I re-downloaded the files and flashed them onto my own Black SanFran (OLED), it has the same partition layout (at least I think it does O.o), no home button, terribly unstable, GApps won't flash...

I'll keep monitoring the situation and hang back until the next release (or the release after).

Still coming along nicely, good job.

Also, if anyone else has experienced the "8-bit colour" issue on a White TFT SanFran before, let me know if you got it fixed, this is driving me insane...

Well I have an OLED san fran, it rebooted twice and ive been using it throughout the day, market force closes, sometimes it freezes, but unfreezes if you wait like 10 seconds, telephone and sms works perfectly. As a phone it works perfectly but not as a smartphone. Battery life seems good also. Thank u tilal

Share this post


Link to post
Share on other sites

Yeah i just flashed the ROM and am having that problem, i'm going to try using nova launcher instead, i think someone said that would help further back in the thread

EDIT: or what meler said, haha!

Yup, I think that Nova Launcher is the one to go with for ICS anyway for now, but fixing FCs for Trebuchet makes it far less pain in the ass to get Nova at all (as the flashable zip doesn't seem to work, and you've got to get to the .apk to install Nova somehow)

I briefly tried out first release yesterday on my OLED OSF (custom TPTed to Gen2 210MB /System, 2MB /Cache) , with ordinary Gapps (20120212 version), got loads of FCs and reboots, so I went back to CM7 for the time being. But it was really smooth otherwise, far better than fixed AOSP Alpha 5 (so-called 5.2) which I had even used as a daily driver for a few weeks.

I will definitely try the new build when it's released.

Edited by k0nrad

Share this post


Link to post
Share on other sites

Yup, I think that Nova Launcher is the one to go with for ICS anyway for now, but fixing FCs for Trebuchet makes it far less pain in the ass to get Nova at all (as the flashable zip doesn't seem to work, and you've got to get to the .apk to install Nova somehow)

I just replaced trebuchet.apk with novalauncher.apk in /system/app before flashing, that's the best way to go around it, seemed pretty smooth earlier but like you I have just switched back to CM7 for the time being

Share this post


Link to post
Share on other sites

I must say this is the smoothest ICS ROM I have used yet. It's even smoother than some well known GingerBread ROMs out there! Of course it has been quite unstable for me, but that is to be expected, of course. Anyway, this would definitely be my daily ROM if that gets fixed! Great work, tilal, and thank you very much!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.