Jump to content
tilal6991

[ICS] [CM9] [4.0.4] ColdFusionX for the ZTE Blade [ROM] [UPDATED - 28/06]

Recommended Posts

Guest

I cannot see how info in link you provided is related to airplane mode. This deals with bluetooth sleep. I had the same problem on skate some time ago. I managed to fix it. I suppose tilal used my fix on Blade, too, but I am not sure.

Here it is: https://github.com/C3C0/android_device_zte_skate/commit/af416a8a09360b076fb7cbfe69757a7bb60c25a8

Thanks for your reply!

Actually the relation with airplane mode is that the wakelock only appears after you first come back from airplane mode.

Tilal, did you already implement the proposed solution? Any chance you do it?

Thanks again

Edited by Guest

Share this post


Link to post
Share on other sites

Also...

End of the world 21-12-2012

I think 15-05 is slower and drains more battery? Am I the only one?

It is slower, i've noticed that too. Not sure about the battery, it seems, more or less the same

Share this post


Link to post
Share on other sites

Am I one who can't disable speaker sound when headsets are attached? Please tell me how can I do it

Share this post


Link to post
Share on other sites

how can i make my system partition bigger cause all the other tpts are gen to gen2 and im already gen 2 so shall just flash one of them?

Share this post


Link to post
Share on other sites

hi all,

often bluetooth doesn't work and i don't know why...

sometimes it starts perfectly, sometimes it doesn't start. why???

other problem is music that crashes: is there an alternative app?

tnx

db

Share this post


Link to post
Share on other sites

Then what is the right way to format?

I have applications and data on ext working as well by the way.

You have to format an Ext partition before you install the ROM ... that worked for me :-)

Share this post


Link to post
Share on other sites

The screen remains off when someone calls, any fix for this?

Share this post


Link to post
Share on other sites

hi all,

often bluetooth doesn't work and i don't know why...

sometimes it starts perfectly, sometimes it doesn't start. why???

other problem is music that crashes: is there an alternative app?

tnx

db

Bluetooth works fine for me. Music as in music player? There are lots of apps on the market for that, including winamp.

Share this post


Link to post
Share on other sites

Bluetooth works fine for me. Music as in music player? There are lots of apps on the market for that, including winamp.

it's very strange.

on aokp remix 6.5, bluetooth works perfeclty. with this i've this problem...

i've zte blade china unicom (chinese).

i've just seen it:

if i reboot phone, after that, bluetooth starts work properly when i want it.....

but when it stops to works (and i don't know why or when), then, it is impossible to restart bluetooth, if i don't reboot the phone...

strange, very strange.

db

Edited by d_borghi

Share this post


Link to post
Share on other sites

Fantastic work on this rom - thank you so much tilal6991 and all the devs involved!!

ive found a solution to apps like facebook / gmail appearing with white screens

(originally my cache was set to 2mb and system 220)

the apps would "whitescreen" on me, when i pulled the screen down or pulled up a menu the text would appear, on release the screen would go white again.

i increased the cache to 32mb and left system, at 220... same thing happened.. this is odd i thought

Then i found (from when i was using CM7.xx that i had "App Cache Cleaner" - INFOLIFE LLC as a titanium backup...

so i restored it and ran it, cleared the cache and now the nasty white screens have gone! (no need to keep re-booting) - it loks at the datapartition )of which mine is set to 206mb)

hope this helps the dev...

if someone can show me or point me to the direction of getting a logcat.. i'll happily log it and supply the info (also for any other bugs i find)

i find that titanium backup complains that "something is wrong... with su etc..". but on a reboot.. the issue goes away

Edited by Jesta99

Share this post


Link to post
Share on other sites

Fantastic work on this rom - thank you so much tilal6991 and all the devs involved!!

ive found a solution to apps like facebook / gmail appearing with white screens

(originally my cache was set to 2mb and system 220)

the apps would "whitescreen" on me, when i pulled the screen down or pulled up a menu the text would appear, on release the screen would go white again.

i increased the cache to 32mb and left system, at 220... same thing happened.. this is odd i thought

Then i found (from when i was using CM7.xx that i had "App Cache Cleaner" - INFOLIFE LLC as a titanium backup...

so i restored it and ran it, cleared the cache and now the nasty white screens have gone! (no need to keep re-booting) - it loks at the datapartition )of which mine is set to 206mb)

hope this helps the dev...

if someone can show me or point me to the direction of getting a logcat.. i'll happily log it and supply the info (also for any other bugs i find)

i find that titanium backup complains that "something is wrong... with su etc..". but on a reboot.. the issue goes away

just plug your phone to your pc, open the terminal and put "adb logcat" (no quotes) and you're good to go :)

Share this post


Link to post
Share on other sites

whats about ur system partition ?

this is the first thing i must ask from now and on everyone :P

Thanks man :) I have a 160MB system partition which worked on prior releases because I could remove the crap after installing the rom, so I could flash the mini gapps. But on this one I had to remove it with winrar before flashing.

Share this post


Link to post
Share on other sites

Bluetooth works fine for me. Music as in music player? There are lots of apps on the market for that, including winamp.

I get serious system slowdown while using bt-headset which leads to reboot eventually.

If I listen to inet-radio (e.g it's wifi+bt) - reboot comes much sooner.

Share this post


Link to post
Share on other sites

I have problems with mms messages, phone won´t send any mms messages, tried also with handcent sms app but it didn´t help. Does anybody else have same problems?

Share this post


Link to post
Share on other sites

just plug your phone to your pc, open the terminal and put "adb logcat" (no quotes) and you're good to go :)

thanks man, will do!

btw the white screen issue came back (and this time app cleaner didnt fix the issue) so i had to reboot

Edited by Jesta99

Share this post


Link to post
Share on other sites

Because this website is currently completely broken I can't search to see if this is reported yet or not! But disabling airplane mode causes the phone to not sleep.

Share this post


Link to post
Share on other sites
Guest

Because this website is currently completely broken I can't search to see if this is reported yet or not! But disabling airplane mode causes the phone to not sleep.

Good to see I'm not the one with this bug ;)

I actually mentioned it multiple times in this thread, but hardly anyone answered.

It seems to be an upstream issue, as all CM9-based roms I tried showed it (burstlam's AOKP, CFX, AOKP-X).

The first time airplane mode is switched off, some wakelock is triggered, that is then only active when radio is on.

I posted in this thread the solution of a gui with some HTC device, which related the issue to some bluetooth config value wrongly being set to active when some devices could not handle it properly. Ah, here is the link.

C3C0 no later than yesterday proposed an alternate solution also linked to bluetooth, which he applied on his skate build. Here's the post.

I don't have the time and knowledge to test this, so again if any knowledgeable dev would give them a shot... :)

Edited by Guest

Share this post


Link to post
Share on other sites

What did you do you (tilal or the devs from CM9 :-)) with the battery ... OMG its like an 50% win ...

With all the previous builds I could use the phone only for about 10 hours (70% wifi drain :-)) ... but with this build I can use it for like 2 days

- wifi

- 2G

- Brightness to full

- couple of phone calls

Excellent job on this one ...congrats

Edited by Freakn

Share this post


Link to post
Share on other sites

After 34 hours of using phone in normal way (about 1 hour of phone calls, some wifi, internet, browsing gallery) I have still 55% of battery with latest CFX. So, where is battery drain?

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.