Jump to content
dr.flo

[Dev/Experimental][ROM] Ideos X3 gingerbread rom runs on Pulse

Recommended Posts

after changing 15ril+qxmud radio is working...bluetooth is working and when replacing libril.so with libril.so from cm7.2 scan is working and you can manually choose network...

I think I've opened Pandora Box with Huawei's .32 kernel ported to pulse :)

What other msm7225 have we not ported yet :) :)

u8150, ascend, um840, now u8500

  • Upvote 1

Share this post


Link to post
Share on other sites

edit:neocore test give 03.8fps

not much is it?

enable hardware acceleration in egl.cfg - look in any our roms ("0 1 qcom" should be there.)

Share this post


Link to post
Share on other sites

not much is it?

enable hardware acceleration in egl.cfg - look in any our roms ("0 1 qcom" should be there.)

replacing egl.cfg from cm7.2 is giving 29.7 fps at neocore but the city has disappeared only flash....

if replacing egl.cfg(from cm7.2) + libegl.so(cm7.2) it scores 25.7 fps but the city is back...

Edited by desalesouche
  • Upvote 1

Share this post


Link to post
Share on other sites

replacing egl.cfg from cm7.2 is giving 29.7 fps at neocore but the city has disappeared only flash....

if replacing egl.cfg(from cm7.2) + libegl.so(cm7.2) it scores 25.7 fps but the city is back...

It is all as it should be,

Consistent with other rooms.

Share this post


Link to post
Share on other sites

wifi and camera is missing...will try the usual camera trick:but i am sure of nothing :) ...i will let you do the wifi.i know you're a specialist pier11

no no - this time we are training you as a monster rom porter :)

you've done wonderful progress already with this rom

Edited by pier11

Share this post


Link to post
Share on other sites

i could get camera working...adding/replacing from cm7.2:camera.so/libcamera.so/libcamera_client.so/libcameraservice.so/libjpeg.so/

libmmcamera.so/libmm-omxcore.so...can take pic.can switch to video camera but after recording it is bugging...same problem than in this topic http://android.modac...54#entry1888554

if i remember well it can be resolved by replacing kwerty.kl from cm7.2 in system/usr/keylayout...

edit:this rom seem to be a little instable... may be because i set to 24 instead 32...

Edited by desalesouche

Share this post


Link to post
Share on other sites

if i remember well it can be resolved by replacing kwerty.kl from cm7.2 in system/usr/keylayout...

qwerty.* is responsible only for hardware keys mapping/waking device.

24/32mb if you speak of dalvik vm heap size, should not affect stability much.

but you are cool that made camera to take pictures already.

Share this post


Link to post
Share on other sites

qwerty.* is responsible only for hardware keys mapping/waking device.

24/32mb if you speak of dalvik vm heap size, should not affect stability much.

but you are cool that made camera to take pictures already.

here's the link of what i could do for that rom...radio is working and able to scan for network and manually choose/bluetooth is working/camera is working but not fine/

http://www.mediafire...10oyao51dybddvu

good nite all hope somebody can do something for cm9 :)

Edited by desalesouche

Share this post


Link to post
Share on other sites

@ dr.flo and pier11:do you think it is possible to flash kernel32_for_cm6.zip on that CM7-Android 2.3.5-u85OO-cam.zip rom?

edit: i tried to port wifi...i have a message like this: E:can't chown/mod/system/xbin/nano

E:failure at line 24:set_perm 0 0 04755 SYSTEM:xbin/nano

installation aborted

Edited by desalesouche

Share this post


Link to post
Share on other sites

@ dr.flo and pier11:do you think it is possible to flash kernel32_for_cm6.zip on that CM7-Android 2.3.5-u85OO-cam.zip rom?

edit: i tried to port wifi...i have a message like this: E:can't chown/mod/system/xbin/nano

E:failure at line 24:set_perm 0 0 04755 SYSTEM:xbin/nano

installation aborted

your system partition is full. Delete some stuff from the rom, e.g. ringtones or tts folder...

cm6 will most likely not work.

you can try using from our nomal cm72 (but then you need to take that boot.img from there also)

system/wifi

system/bin/wpa_supplicant

wpa_supplicant.conf (don't know right now where that resides)

system/lib/libhardware_legacy.so

Share this post


Link to post
Share on other sites

your system partition is full. Delete some stuff from the rom, e.g. ringtones or tts folder...

cm6 will most likely not work.

you can try using from our nomal cm72 (but then you need to take that boot.img from there also)

system/wifi

system/bin/wpa_supplicant

wpa_supplicant.conf (don't know right now where that resides)

system/lib/libhardware_legacy.so

ok :) i manage to port wifi thx to your advice...i just delete the launcher that i replace with adwlauncher....booting without probleme...will upload it

edit: http://www.mediafire...3b30r39zvxxz93p videoplayback is working fine and smooth with non hq video on youtube... camera/video is not working fine but you can take picture if i remember well if somebody can give a hand for resolving camera problem thx

edit bis: after the change i have done to port wifi i can see i lost usb tethering...somebody can confirm....?

Edited by desalesouche

Share this post


Link to post
Share on other sites

Congratulations! You'll get a "rom porter" certificate - you now know all that's needed normally :D

The rom I played with always freezes after reboot - touch doesn't work anymore. Do you have such issues....?

Share this post


Link to post
Share on other sites

Congratulations! You'll get a "rom porter" certificate - you now know all that's needed normally :D

The rom I played with always freezes after reboot - touch doesn't work anymore. Do you have such issues....?

i have no freeze after reboot or i didn't notice anything...the only thing i saw is that i am asked twice or three times to enter pincode.and touch seem to be working for me

edit:i have some freeze too while booting...

Edited by desalesouche

Share this post


Link to post
Share on other sites

edit bis: after the change i have done to port wifi i can see i lost usb tethering...somebody can confirm....?

the kernel in cm72 does not support this, but you need its ramdisk for wifi to work. you could google for split_bootimg.pl, a perl script (will run in linux out of the box usually) that can split boot.img into these components.

Then take kernel from a boot.img where usb thethering works (e.g. um840) and ramdisk from cm72 bootimg.

then use mkbootimg to re-combine both

like outlined here in the section "Alternative method", but there the link to split_bootimg.pl is broken...

Edited by dr.flo

Share this post


Link to post
Share on other sites

the kernel in cm72 does not support this, but you need its ramdisk for wifi to work. you could google for split_bootimg.pl, a perl script (will run in linux out of the box usually) that can split boot.img into these components.

Then take kernel from a boot.img where usb thethering works (e.g. um840) and ramdisk from cm72 bootimg.

then use mkbootimg to re-combine both

like outlined here in the section "Alternative method", but there the link to split_bootimg.pl is broken...

i notice also that i could only make wifi work once...after that couldn't reproduce it....:(

but it might be also for the same reason than for tethering....

will try to follow your advice but it is a new challenge for me :) ...so if somebody has some time to do it it would be nice...will try anyway for my knowledge.

Share this post


Link to post
Share on other sites

Maybe this weekend I have a chance to try getting wifi on your rom, but I can't promise.

Regarding the original pulse-x3 rom: Has anyone every tried if using libril.so from cm72 helps with the phone call issue? Also in call settings there is an option "Proxymity sensor" enabled by default - I don't know if the pulse has such... it might help to disable that option and see if it makes any difference....

Share this post


Link to post
Share on other sites

qxmud is a file? If yes that

where is?

pier11 and dr.flo look - code.google.com/p/huawei-u8500-rom-list/downloads/detail?name=update-cm-7.2-RC8-20120224-U8500.zip&can=2&q= it can it is

useful

Share this post


Link to post
Share on other sites

qxmud is a file? If yes that

where is?

pier11 and dr.flo look - code.google.com/p/huawei-u8500-rom-list/downloads/detail?name=update-cm-7.2-RC8-20120224-U8500.zip&can=2&q= it can it is

useful

this file is in system/bin

i have already made some port with this...you can upload it http://www.mediafire.com/?3b30r39zvxxz93p

there is still work to do you can see last post from dr.flo above....

thx for the good idea you had.

Edited by desalesouche

Share this post


Link to post
Share on other sites

In system/bin isn't present, is

qemud is it?

On u8500 there is still port

MIUI, and still idea if to take

settings.apk from ours cm7 and

to change on cm7 from u8500

Edited by skykilla

Share this post


Link to post
Share on other sites

In system/bin isn't present, is

qemud is it?

On u8500 there is still port

MIUI, and still idea if to take

settings.apk from ours cm7 and

to change on cm7 from u8500

system/bin/qmuxd

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.