Jump to content
thepasto

[CM9] Cyanogenmod 9 for LiquidA1/LiquidE

Recommended Posts

Hello thepasto,

Today I had a picnic with my girlfriend, and we took a lot of photo. A big problem I just found out about this CM9 b3 ROM is that, when I press the thumbnail of the camera app to review the photo, then press the Gallery icon on the preview screen to go to the Gallery, after exit the Gallery, the Camera app shows up a message "Cannot connect to camera". The only way to restart it is to long-press the Back button, to kill the Camera apps. Then it would be ok.

But after I go to Gallery for some times (3-4 times, I cant remember), it suddenly reboot the phone itself. It kept happening this way during my trip, so at the middle of the picnic, in order to take more photos, I had to re-flash the CM7.2 ROM (Luckily I always have that ROM on my SD Card).

This ROM is very great, thepasto, but I think there is a long way ahead for it to become a daily ROM. I'm very appreciate your hard working. This is just a bug-reporting so that you can manage to handle the errors.

Looking forward to seeing a new ROM from dev team.

PS: Browser app uses a lot of RAM I think, since if I open 1 webpage, then navigate inside the site (only 1 tab opening), after 4-5 pages, the browser automatically exits. Then I press the Browser icon to start it again, it's loading the Google homepage. A big problem with me since I have to use phone to test my products.

By the way I think the ADB bug on Windows need to be solved for all device. It could be that your device is Liquid E so it's a bit different from A1. Im looking forward to seeing and flashing your new version.

Share this post


Link to post
Share on other sites

My "Missed call" flashes instead of the mail led o_O anyone experiencing this, too? I made the led settings mentioned in the first post.

  • Upvote 1

Share this post


Link to post
Share on other sites
My "Missed call" flashes instead of the mail led o_O anyone experiencing this, too? I made the led settings mentioned in the first post.

Me too. I've tried a lot of color options but still only missed call led flashes

  • Upvote 1

Share this post


Link to post
Share on other sites

Maybe install gapps and use google play is the right way to install what you need

Of course if you have a data connection available!

Unfortunately, today I came back to MIUI Final by Youpy666.

Beta 3 is an excellent work but too slow with A1.

Share this post


Link to post
Share on other sites

What is xdata? it does not stack after reboot.

I have a sd class 10 with 20Mb/s tested with sdtools it is usable with a+d2sd while dalvic on sd just kills the phone.

Share this post


Link to post
Share on other sites

Little trick for A1: download ram manager free from market and apply balance option and launcher persistent in memory. I also install nova launcher (trebuchet is a bit bugged).

Now my liquid A1 is more usable with ICS

  • Upvote 1

Share this post


Link to post
Share on other sites

cm9 beta 3 rom is one of the best roms i've installed on my phone, after acer deceived us by not releasing official 2.3 rom, so far i'm not experiencing any issue with except for the camera and mail led but its still a very good rom

Share this post


Link to post
Share on other sites

This beta is running great, almost no issues at all. I've had 1 soft boot so far with use since install on day of release. Great work to all involved.

Share this post


Link to post
Share on other sites

Hey Guys,

Hoping for a little reciprecation here... ;)

For those that are having an issue with slight lag, keyboard not preforming as quickly as it should, not being able to install your apps directly to your SDCARD. There are a few differenet steps to achive Narnia....

I'm using an A1...For the sdcard partition to work properly to allow you to use it for app storage, there are two things i did to make this work like butter.

1st -Open your app drawer and select LiquidParts

-Select the A2SD Tab, turn on A2SD, AD2SD & Dc2SD

- once you have selected these options and REBOOTED your device you should notice it takes awhile to transfer programs and Davlik to the sdcard, this is good. IF this does not work there is a work around involving changing the default install location using ADB, easily found in the forums. After this complete i completely regained all my internal storage (200mb) AWESOME!

2nd - Open up Settings and select Preformance...

- Select processor and change governor to SmartAss2 or which ever you prefer

- Check the box for Set on boot

- Set mininum to 128 and Max to about 998 (seems to work well for me)

- back out to the main Performance settings menu, now select Memory Management..

- Select zRAM and select 26%

- Check Allow purging of assets & Kernel samepage merging

- Back to main performance and uncheck Surface dithering

- Check 16bit transparency

May ask you to reboot after these options have been selected, if not go ahead and do so anyway, can't hurt right?

3rd Go back to settings...

- Go into Developer options

- Scroll down to Force GPU rendering and put a check in the box

Remeber Guys, the base of the ROM was taken from a much Beefy phone then our poor old little A1's. Playing around with these settings i've mentioned i can report a much snappier faster acting A1 with CM9 Beta 3 installed over a fresh install with the base settings intact.

Now, All I ask... is can someone please fix the Notifications LED for msg's (currently coming up with missed call) and if someone wanted to be really cool....I'm using SMS Pop Up, have fro the last 1yr or so, but now with this ROM installed i can't access the programs notification settings with out the program crashing, i wanted to see if using this program might help out with the whole missed call LED issue

Thanks Guys!

Matty K

BTW - Great Job to the Guys who have spent the time on this ROM! Lovin It!

PS - Another recomendation I have if your going to use this as an everyday ROM like I plan to, I've been using Juice Defender and it seems to help keep me going strong, available in the Market

Share this post


Link to post
Share on other sites

Another issue to report...

Anyone else get a reboot when chosing to TEST the notification color they've selected?

After I chose a color, and then select TEST, the pop up comes up and i hit the power switch on the phone like it tells me, then i get the CM9 start up screen.

Seems to me this only started to happen recently. After I first installed the ROM and followed the suggestions at the begining of the post with the red/blue it worked fine. Now something has changed and I'm not sure what.

Share this post


Link to post
Share on other sites

Me too. I've tried a lot of color options but still only missed call led flashes

Umm...think I found something....

Turned off Notification lights along with Automatic backlight "Light sensor filter" & "Allow light decrease"

Sent myself a msg and no light, which is what was to be expected...

Then only turned on Light Notifications and left it on it's default setting, no custom value...

Sent another msg and the MSG light worked properly.

Give it a try, let me know if it works for you....

Not sure if it has anything to do with it but i also use SMS PopUp which might now be sending it's own notification

Let me Know

Thanks,

Matt

Share this post


Link to post
Share on other sites

Hi guys, if i use the swap partition how to additional ram, it need only to read or to write also? Because if swap need only to read i buy a sandisk mobile ultra with 30MB/s in read, but if swap need to write i buy a samsung plus class 10, that is faster in write than sandisk. It's true?

Sorry for my bad english

Share this post


Link to post
Share on other sites

Thank you very much, then i understand that for swap is better samsung plus because sandisk mobile ultra is slow in write ;)

Share this post


Link to post
Share on other sites
Guest

2 stupid questions: to install the cwm recovery i need to have adb installed? And I have to install the new usb drivers before doing it?

Share this post


Link to post
Share on other sites

2 stupid questions: to install the cwm recovery i need to have adb installed? And I have to install the new usb drivers before doing it?

Your phone must be detected and pc installed with correct drivers for adb to work.

And you must have working adb to install recovery. So yes to both questions. Same like installing Malez recovery actually.

Share this post


Link to post
Share on other sites

Umm...think I found something....

Turned off Notification lights along with Automatic backlight "Light sensor filter" & "Allow light decrease"

Sent myself a msg and no light, which is what was to be expected...

Then only turned on Light Notifications and left it on it's default setting, no custom value...

Sent another msg and the MSG light worked properly.

Give it a try, let me know if it works for you....

Not sure if it has anything to do with it but i also use SMS PopUp which might now be sending it's own notification

Let me Know

Thanks,

Matt

Nope. Doesn't work for me. Even tried with SMS POPUP but still no.

Share this post


Link to post
Share on other sites

LED works fine for me (Liquid E). I added apps like whatsapp manually to the list. I did notice the rebootscreen when clicking 'test', though. Also sometimes when I receive a message, the phone shows LED but when i press the standby key, nothing happens and LED keeps flashing...

dunno if it has to do with the LED or its just coincidence

Share this post


Link to post
Share on other sites

Guys, but if i make a swap partition only, without ext partition, how can i do? in the cwm options, before to make swap, i must create the ext partition and there isn't possibility to choose 0.

Share this post


Link to post
Share on other sites

Ok i buy samsung plus class 10, installed cwm recovery and cm9 rom, and it works..but adb not. I reinstall android sdk, unistall old driver and install new from first post, but nothing. In recovery, after "List of devices attached" i have ? and don't work. In OS mode i have nothing in "List of devices attached" and in the device management (in windows 7 64bit) adb interface not appear. Why???

Share this post


Link to post
Share on other sites

Guys, but if i make a swap partition only, without ext partition, how can i do? in the cwm options, before to make swap, i must create the ext partition and there isn't possibility to choose 0.

It's not possible. Even if you manage to create a swap partition without ext (which is possible with Malez Recovery), Android won't recognize that a swap partition exists. So make simply the smallest possible ext partition and don't use it.

Share this post


Link to post
Share on other sites

Nice release, but, as always, uber-slow on A1. 256 megs are no-go for ICS...

Share this post


Link to post
Share on other sites

i tried this rom, it work great, less probem, but still it run kinda slow and waste lot of ram ><

hope to see more update from u :D i love how this rom look, very nice

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.