Jump to content
Sign in to follow this  
didije

Yet another cm7.2 rom

Recommended Posts

Hello everyone.

I reassembled cm7.2 rom based on $anek001's cm for u8500. It is very nice, and so far very stable. I'll upload it in a while. It is very smooth, in fact there is no need to turn off animations, they will not slow down your phone. There are two issues I am unable to resolve. Minor one is: wifi and signal icons in status bar don't turn green when connected to net. Big one is very strange: I cannot take pictures. Video is recording just fine, and that is the strange part. I would appreciate any help with this one.. It's uploading. Will post links soon.

Send feedback, and please, feel free to improve it in any way possible.

Rom link: https://www.dropbox....x80fq/cm_72.zip

Minimalistic gapps - just play store: https://www.dropbox....nimal_gapps.zip

DTapps2sd: https://www.dropbox....8/dtapps2sd.zip

Cheers.

For curious minds. LeWa Rom: https://www.dropbox....5s/lewa_rom.zip

Edited by didije
  • Upvote 2

Share this post


Link to post
Share on other sites

interesting!

By compiling did you mean from source or re-assembling u8500 rom for our device? Just curious :)

Share this post


Link to post
Share on other sites

interesting!

By compiling did you mean from source or re-assembling u8500 rom for our device? Just curious :)

Just reassembling. I'm not yet at enough high level to compile it from source. I bet there are a lot of unnecessary files in it, but I don't know which ones. I'm still learning, and have a lot to learn. Upload is very slow.. You will need at least 110 system partition to flash it.

Edited by didije

Share this post


Link to post
Share on other sites

what do formal graphics performance tests say - Fps2D and Neocore?..

Edited by pier11

Share this post


Link to post
Share on other sites

what do formal graphics performance tests say - Fps2D and Neocore?..

I never do those tests so I really don't know. I'm uploading from my phone and I cannot do it right now. I didn't enable hw acceleration in egl. I forgot, but maybe there is no need for that.. I'll leave that part to be a choice, and others recommendation, from more experienced devs. I just don't know how to fix camera issue. Video is recording just fine :blink:

Share this post


Link to post
Share on other sites

did you try to replace Camera.apk from our roms? May be they used some sort of customized version...

our roms didn't have such issue...

Share this post


Link to post
Share on other sites

Uploaded rom. Will add soon gapps. Tried our camera.apk, didn't work. Didn't try third party apps though. I'll try that later, need some sleep now..

Share this post


Link to post
Share on other sites

did you try to replace Camera.apk from our roms? May be they used some sort of customized version...

our roms didn't have such issue...

I would guess libmmjpeg.so needs to be replaced for taking pictures. At least this was needed for u8150 & co...

Video recording works without crashing....? In HQ? That would be the first working gingerbread environment....

Edited by dr.flo

Share this post


Link to post
Share on other sites

I would guess libmmjpeg.so needs to be replaced for taking pictures. At least this was needed for u8150 & co...

Video recording works without crashing....? In HQ? That would be the first working gingerbread environment....

Yes, HQ without issues. I already tried libmmjpeg. No luck. I also assembled Rom called LeWa Rom from the same phone. There camera works. It is based on cm7.2 as well. But interface is very different and I don't like it. I will upload it for curious minds. Didn't test it much, but everything seems to be working.

Share this post


Link to post
Share on other sites

... I also assembled Rom called LeWa Rom from the same phone...

rom explosion is what is going on :)

It's hard to remember already what was ported just recently :)

  • Upvote 1

Share this post


Link to post
Share on other sites

rom explosion is what is going on :)

It's hard to remember already what was ported just recently :)

Yes it is :) Kernel .32 opened up many possibilities. Still dealing with this camera issue. I just don't understand why it will not take pictures..

Share this post


Link to post
Share on other sites

rom explosion is what is going on :)

It's hard to remember already what was ported just recently :)

agree :D

you (and all the developers/contributors) really gave new life to this phone :D

Share this post


Link to post
Share on other sites

Hello everyone.

I reassembled cm7.2 rom based on $anek001's cm for u8500. It is very nice, and so far very stable. I'll upload it in a while. It is very smooth, in fact there is no need to turn off animations, they will not slow down your phone. There are two issues I am unable to resolve. Minor one is: wifi and signal icons in status bar don't turn green when connected to net. Big one is very strange: I cannot take pictures. Video is recording just fine, and that is the strange part. I would appreciate any help with this one.. It's uploading. Will post links soon.

Send feedback, and please, feel free to improve it in any way possible.

Rom link: http://db.tt/be61AJMy

Minimalistic gapps - just play store: http://db.tt/vCk9nJSS

DTapps2sd: http://db.tt/wgMgqVZm

Cheers.

For curious minds. LeWa Rom: http://db.tt/xSyw6Qs8

The good fellow has created a

theme with my idea

Continuation of this theme : android.modaco.com/topic/351723-devexperimentalrom-ideos-x3-gingerbread-rom-runs-on-pulse/page__st__140

Share this post


Link to post
Share on other sites

The good fellow has created a

theme with my idea

Continuation of this theme : android.modaco.com/topic/351723-devexperimentalrom-ideos-x3-gingerbread-rom-runs-on-pulse/page__st__140

Sorry if I misunderstood you, but what you are saying sounds like I stole your idea, and that this thread should be closed.. I just tried different roms from other phones and liked this one so I wanted to share it with others. What's the harm in that?

Share this post


Link to post
Share on other sites

Sorry if I misunderstood you, but what you are saying sounds like I stole your idea, and that this thread should be closed.. I just tried different roms from other phones and liked this one so I wanted to share it with others. What's the harm in that?

it sometimes occurs that 2 people have the same idea in the same time...ideas are in ideosphere...i can remenber that a music was made in us in the end 18th century and same song made in the same time in france....:)

i can obesrv that in system/etc firmware there is file like:fv_bcm4319.bin/fv_bcm4319_apsta.bin/nvram

is that the original wifi stuff for u8500 rom?

Edited by desalesouche

Share this post


Link to post
Share on other sites

Sorry if I misunderstood you, but what you are saying sounds like I stole your idea, and that this thread should be closed.. I just tried different roms from other phones and liked this one so I wanted to share it with others. What's the harm in that?

All is normal! Itself wanted, but

from phone somehow not so I

communicate with the help of

the translator

  • Upvote 1

Share this post


Link to post
Share on other sites

it sometimes occurs that 2 people have the same idea in the same time...ideas are in ideosphere...i can remenber that a music was made in us in the end 18th century and same song made in the same time in france....:)

i can obesrv that in system/etc firmware there is file like:fv_bcm4319.bin/fv_bcm4319_apsta.bin/nvram

is that the original wifi stuff for u8500 rom?

I really don't know what are those files. They were there and I didn't remove then, since I didn't want to mess sth up.

All is normal! Itself wanted, but

from phone somehow not so I

communicate with the help of

the translator

It's cool my friend. I just want to contribute to the community, like you and everyone else. Original mod that I took as a base was the latest from $anek001, from yesterday. I tried many more but this one is not freezing and is working quite well on our device. And if you and others have any ideas how to improve it, I would like to hear them. Regards

Share this post


Link to post
Share on other sites

i can observe that in system/etc firmware there is file like:fv_bcm4319.bin/fv_bcm4319_apsta.bin/nvram

is that the original wifi stuff for u8500 rom?

bcm = broadcom (alternative wifi chipset, we use different - atheros)

So no need for that files.

Keep cool, people :) Our device need all of your contributions! More activity is better than less.

EDIT: To your porting knowledge:

most msm7225 devices, like um840, Ascend, u8150, u8500 use Broadcom wifi chip.

Only devices that share our wifi chip - Atheros ar6000 - are u8100/u8110/u8120 from Huawei. Also Zte Blade have it.

Edited by pier11
  • Upvote 2

Share this post


Link to post
Share on other sites

can notice that in that rom there is in system/lib: libqcamera.so

this file is not in cm7.2-pier11.is it because of that one that there'is possibility to make high definition video recorded?

Share this post


Link to post
Share on other sites

can notice that in that rom there is in system/lib: libqcamera.so

this file is not in cm7.2-pier11.is it because of that one that there'is possibility to make high definition video recorded?

Nope, video is working just fine without that file. I deleted it this morning. Still no clue about that, and it's annoying. Video working great, but cannot take picture :blink: Crazy, right?

Share this post


Link to post
Share on other sites

test fps2d out of box 29 stedv 11.57

neocore test out of box rendering city not smooth score=4.35 fps

after replacing egl.cfg and libEGL.so from cm7.2 pier11:neocore rendering city/test smooth and fast. score=26.1 fps

after some reboot strange things occured i have been asked like in cm9 to enter pin about: "sim network unlock pin" i did reboot once again but couldn't reproduce it...

Edited by desalesouche
  • Upvote 1

Share this post


Link to post
Share on other sites

what happens if you try to take a picture?

any hints in logcat?

When I press a button to take pic, fokus square shows up and app buttons are not responding even though there is a preview going on.

Here is logcat: http://db.tt/jPP2CHaQ

Share this post


Link to post
Share on other sites

test fps2d out of box 29 stedv 11.57

neocore test out of box rendering city not smooth score=4.35 fps

after replacing egl.cfg and libEGL.so from cm7.2 pier11:neocore rendering city/test smooth and fast. score=26.1 fps

after some reboot strange things occured i have been asked like in cm9 to enter pin about: "sim network unlock pin" i did reboot once again but couldn't reproduce it...

That is strange. I haven't experienced it yet..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.