Jump to content
Dazzozo

[ICS] [CM9] [4.0.4] CyanogenMod 9 for the ZTE Crescent [ROM] [Last updated: 13/07]

Recommended Posts

I think you did :P

Who said I was a student? ;)

-Ninjeh.

Busted. ;)

Share this post


Link to post
Share on other sites

@Ninja Dude nothing but good input, you're more than welcome :) what's the project you're working on btw??

It's a secret :P But my original plan for it failed so I'm going through it and re-trying, hopefully won't take long :)

-Ninjeh.

Share this post


Link to post
Share on other sites

Hi everyone. Firstly, thanks to everyone who has been working on this ROM, clearly you have put in a lot of effort & it is greatly appreciated. Secondly a special thanks to Dazzozo, your responses on this forum have been many & frequent - I have been reading a lot of threads on this forum & some of your comments / advice have been incredibly helpful.

Firstly a little info on my phone:

- Vivacity (Partitioned to 200MB, 200MB & 40MB - as advised)

- I unlocked & rooted this back in February

- I've always had issues with the capacitive buttons, CWM has never worked with them & I need to use the 'back button enabled' method with the power button

I've installed this ROM onto my Vivacity & everything seems to be working OK. I have noticed 2 things however, and I haven't managed to find an answer to them on the 57 pages of this thread....

- The search button on my Vivacity doesn't work

- There doesn't seem to be a Wifi tethering option (Only USB option)

These are just minimal to be honest, as I should be able to get a free Wifi tethering app from the Play Store. I'll need to test with my iPad to make sure it's functioning however. The search button is handy for certain apps (SabSheep etc) but again this is extremely minimal.

Any pointers would be great, even if they're just 'My search button disnae work either' !! I just want to make sure it's nothing specific to the hardware variant of my phone.

Edited by TommyBuRnZ

Share this post


Link to post
Share on other sites

Hi everyone. Firstly, thanks to everyone who has been working on this ROM, clearly you have put in a lot of effort & it is greatly appreciated. Secondly a special thanks to Dazzozo, you responses on this forum have been many & frequent - I have been reading a lot of threads on this forum & some of your comments / advice have been incredibly helpful.

Firstly a little info on my phone:

- Vivacity (Partitioned to 200MB, 200MB & 40MB - as advised)

- I unlocked & rooted this back in February

- I've always had issues with the capacitive buttons, CWM has never worked with them & I need to use the 'back button enabled' method with the power button

I've installed this ROM onto my Vivacity & everything seems to be working OK. I have noticed 2 things however, and I haven't managed to find an answer to them on the 57 pages of this thread....

- The search button on my Vivacity doesn't work

- There doesn't seem to be a Wifi tethering option (Only USB option)

These are just minimal to be honest, as I should be able to get a free Wifi tethering app from the Play Store. I'll need to test with my iPad to make sure it's functioning however. The search button is handy for certain apps (SabSheep etc) but again this is extremely minimal.

Any pointers would be great, even if they're just 'My search button disnae work either' !! I just want to make sure it's nothing specific to the hardware variant of my phone.

1. My search button works

2.

I think tethering in general needs a bit of love before it's going to work. Networking-wise I want to remove Bluetooth's dependency on Wi-Fi next.

Share this post


Link to post
Share on other sites

What should the search button do in ICS? I just presumed it didn't do anything as there are only 3 virtual buttons on the screen for phones without hardware buttons. Should it actually do something?

Share this post


Link to post
Share on other sites

Hi Daz,

Thanks for your great work!

I installed CM9 yesterday on my TMV and everything works as described :)

So far I only noticed that not all of my contacts were synchronized.

Is this a known issue with CM9?

Share this post


Link to post
Share on other sites

Thanks for the reply Titas, I have found that my wife's VivaCity behaves differently to mine (capacitive buttons work in CWM) so I'd assume there is a hardware difference between our phones somewhere (as I used the same unlock / root method for both phones). That may explain why your button works & mine doesn't.

What should the search button do in ICS? I just presumed it didn't do anything as there are only 3 virtual buttons on the screen for phones without hardware buttons. Should it actually do something?

I would have expected the search button to act in a similiar fashion to how it did in GingerBread (2.3). If pressed on the main screen it opens a search in Google, if pressed within an app it would open a search dialog specific to that app (if applicable). Perhaps I have misunderstood however....

Share this post


Link to post
Share on other sites

Thanks for the reply Titas, I have found that my wife's VivaCity behaves differently to mine (capacitive buttons work in CWM) so I'd assume there is a hardware difference between our phones somewhere (as I used the same unlock / root method for both phones). That may explain why your button works & mine doesn't.

I would have expected the search button to act in a similiar fashion to how it did in GingerBread (2.3). If pressed on the main screen it opens a search in Google, if pressed within an app it would open a search dialog specific to that app (if applicable). Perhaps I have misunderstood however....

That's right & btw it can be used to launch an app as well. I'm not sure why you're capacitive buttons don't work in Recovery...... they do on mine just like your wife's

Share this post


Link to post
Share on other sites
Hi Daz,

Thanks for your great work!

I installed CM9 yesterday on my TMV and everything works as described :)

So far I only noticed that not all of my contacts were synchronized.

Is this a known issue with CM9?

Yes, it's known and possibly even intentional. They seem to kind of half sync - try searching a number in the dialer that hasn't synced. If it's like me they'll show up, just not in the People app. You have to convert them to a Google contact for that, I believe.

My converted ones have synced down on every build now but Google have this inability to sync photos property and as a result you have to reset the contact photo (if you use them) on every new build.

Edit: they're low quality otherwise.

Edited by Dazzozo

Share this post


Link to post
Share on other sites

Titas, what screen do you have?

I fixed an issue that I guessed would exist with the search button last night on one of the screens. Not built with the change yet but I'm guessing you have the screen that works in the current build.

Share this post


Link to post
Share on other sites

My search button brings up google search as it should. What version of CWM are you using TommyBuRnz? I'm guessing your problem phone has a Synaptics display controller?

Share this post


Link to post
Share on other sites
My search button brings up google search as it should. What version of CWM are you using TommyBuRnz? I'm guessing your problem phone has a Synaptics display controller?

Synaptics search button also happens to be the one I fixed last night. :P

Share this post


Link to post
Share on other sites

The only version of CWM I could get to work was v5.0.2.7, and this had to be installed through adb. If I flash a new partition structure (TPT) CWM does not allow me to select anything on my phone, even if I try to enable the 'back menu button'. I have to reflash CWM v5.0.2.7 over adb. I can tell when it's been successful as the bottom buttons light up. Then it's a case of multiple down (or up) presses to enable 'back menu button', and the power button to select.

I've tried to identify my display controller by typing *983*24474636#, this keeps just overwriting with the last character (#) so I can't access the hardware summary screen. I haven't noticed much difference between the response of my phone or my wife's so it's difficult to tell if one is an Atmel & the other Synaptics. Frustrating stuff....

Carlsberg don't make VivaCity smart phones, but if they did, they wouldn't base it on mine...

Share this post


Link to post
Share on other sites

The only version of CWM I could get to work was v5.0.2.7, and this had to be installed through adb. If I flash a new partition structure (TPT) CWM does not allow me to select anything on my phone, even if I try to enable the 'back menu button'. I have to reflash CWM v5.0.2.7 over adb. I can tell when it's been successful as the bottom buttons light up. Then it's a case of multiple down (or up) presses to enable 'back menu button', and the power button to select.

I've tried to identify my display controller by typing *983*24474636#, this keeps just overwriting with the last character (#) so I can't access the hardware summary screen. I haven't noticed much difference between the response of my phone or my wife's so it's difficult to tell if one is an Atmel & the other Synaptics. Frustrating stuff....

Carlsberg don't make VivaCity smart phones, but if they did, they wouldn't base it on mine...

I would say you have a Synaptics controller as mine is and I have the exact same issue with CWM where you have to enable the secret power button menu to be able to select anything. This was one of the things that frustrated me right at the beginning as I didn't even have that capability and couldn't flash anything at all!

My search button also does nothing in that case then. Not sure what version of the CM9 rom I am using but it is the version before I dumped my logcat for Dazzozo and the first vivacity home button patch was released. If the search button is fixed in the latest/next release I will be a happy chappy, although up to this point I didn't even know it was a problem!

Share this post


Link to post
Share on other sites

Carlsberg don't make VivaCity smart phones, but if they did, they wouldn't base it on mine...

Haha! Awesome :D

I run CWM 4. I just wondered if it could be that.

Share this post


Link to post
Share on other sites

I now have the LCD Info from my phones. One is Synaptics and the other is Atmel. The Synaptics is indeed the problematic phone, but what I did notice is that this code to bring up the 'ChiperTest' doesn't work on the CM9 ROM.

I didn't have any joy with CWM 4, so moved onto CWM 5. Certainly none of the default ones worked with my phone, so I had to update CWM via adb. If anyone knows why this is I would be interested in the explanation :-)

Edited by TommyBuRnZ

Share this post


Link to post
Share on other sites

Does anyone know of a way to figure out the exact specs, or even know the specs, for the Vivacity & San Fran2, without having to change ROMs?

I mean things like processor and camera model, rather than just the screen specs/

-Ninjeh.

EDIT: I have found some info on here, but it's missing things such as camera model and other detailed things. Can anyone enlighten?

Edited by NinjehKitteh

Share this post


Link to post
Share on other sites

Does anyone know of a way to figure out the exact specs, or even know the specs, for the Vivacity & San Fran2, without having to change ROMs?

I mean things like processor and camera model, rather than just the screen specs/

-Ninjeh.

The cameras and processor are the same for all devices. OVM7690, OV5640, MSM7227T CPU.

Share this post


Link to post
Share on other sites

OVM7690, OV5640

What are these two? I get that they're cameras but is the first front and the second back?

-Ninjeh.

Share this post


Link to post
Share on other sites

What are these two? I get that they're cameras but is the first front and the second back?

-Ninjeh.

Front = OVM7690

Back = OV5640

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.