Jump to content
PaulOBrien

MCR - MoDaCo.one for the HTC One X Tegra 3 (Sense + Vanilla) - NEW: more Vanilla, TeamViewer QS + more

Recommended Posts

i just wanted to bake a rom with mostly vanilla apps, but the problem is, that i can't select aosp lockscreen even though the htc lockscreen is not checked!

Just deselect the HTC lock screen and the stock One is automatically used.

P

Share this post


Link to post
Share on other sites

Wondering really whether to file this as a bug...

If you do have a lock pattern in use and someone calls you using the vanilla rom you have to first unlock the phone, then enter you pattern, then you can see who is calling and press a button.

Takes a little while sometimes, and can miss a call because it is quite a procedure. Surely you should be able to just swipe and answer the call in one go, no?

Share this post


Link to post
Share on other sites
Wondering really whether to file this as a bug...

If you do have a lock pattern in use and someone calls you using the vanilla rom you have to first unlock the phone, then enter you pattern, then you can see who is calling and press a button.

Takes a little while sometimes, and can miss a call because it is quite a procedure. Surely you should be able to just swipe and answer the call in one go, no?

Is that a custom bake Vanilla? For now I include the HTC lockscreen with vanilla for this reason, due to using the HTC phone app!

P

Share this post


Link to post
Share on other sites

Yes, its a custom. Will bake it with the HTC lockscreen now, that works!

Share this post


Link to post
Share on other sites

Yes, its a custom. Will bake it with the HTC lockscreen now, that works!

Its a bit of a slippery slope! Add the HTC lockscreen to fix the calling issue, then add the HTC clock app so you get alarm notifications on the lock screen, then add the HTC weather because without that the clock app crashes. After all that you realise that you might as well have the HTC launcher as well so that you get the four shortcuts on the lock screen.

Not so vanilla anymore :)

Share this post


Link to post
Share on other sites

Seen a 4.0.4 test rom has been released. Will mcr be debased on test rom or wait for official release?

Share this post


Link to post
Share on other sites
Seen a 4.0.4 test rom has been released. Will mcr be debased on test rom or wait for official release?

I'll update to official 4.0.4 when it drops I think.

P

Share this post


Link to post
Share on other sites

1. It's in /system/customize/resources iirc - it's not called bootanimation.zip though, so you'll need to double check.

2. That's strange, did it work OK on stock? I didn't change anything in that regard. I'll set up an account and test.

3. D'oh, that's rubbish - i'll check into that too.

P

Right then - on point 2) of this - I'm still playing around to find out what's going on, but today I got a phone call from someone asking if I'd gotten their email. I check the account through my phone and said I hadn't, but then when checking the webmail account, it turned out I had!

Currently, I've got five emails from the last two days sat in my mailbox that I can see and read through webmail no problem, but NONE of which are showing up through the Mail app on my phone. The settings for the account are all correct (right server, username, SSL etc.) and the download options are set to pull down 'All' mail, but the phone is claiming that there is no new mail. At all.

Anyone got any thoughts?

Share this post


Link to post
Share on other sites

Could you check logcat for errors when you're doing the send / receive?

P

Yeah, I can, but it'll be tomorrow before I can do it. I'm at work at the mo and our machines are locked down so can't get ADB working. Will post it as soon as I can.

*** EDIT ***

Actually, I lie. Used aLogcat from Play Store, which has worked like a charm.

Cleared the logs in aLogcat, closed it, opened the mail app, forced a sync, closed the mail app, went back to aLogcat, and filtered the output by 'mail'. The results are attached.

Important note: I'd replied to one of the emails I'd gotten in the past day or so that wasn't previously showing up through the webmail interface. Once I'd replied, the Mail app picked up my response no problem.

alogcat.2012-06-20-15-42-23+0100.txt

Edited by carthesis

Share this post


Link to post
Share on other sites

Yeah, I can, but it'll be tomorrow before I can do it. I'm at work at the mo and our machines are locked down so can't get ADB working. Will post it as soon as I can.

*** EDIT ***

Actually, I lie. Used aLogcat from Play Store, which has worked like a charm.

Cleared the logs in aLogcat, closed it, opened the mail app, forced a sync, closed the mail app, went back to aLogcat, and filtered the output by 'mail'. The results are attached.

Important note: I'd replied to one of the emails I'd gotten in the past day or so that wasn't previously showing up through the webmail interface. Once I'd replied, the Mail app picked up my response no problem.

No clues in there at all! Hmmm...

P

Share this post


Link to post
Share on other sites

Hey folks,

anyone missing the menu button within google play? Don't have a hardware button, so it is impossible for me to jump to my apps...

And if I removed the HTC Lockscreen, how am I able to put additionals apps on the Standard Lock Screen?

Thanks in advance

Edited by kkempe

Share this post


Link to post
Share on other sites

You should only be missing the button if you selected Menu Mod, in which case the task switch button activates the menu...

P

Share this post


Link to post
Share on other sites

I added a new kitchen option for 'system optimisations', the first of which is improved MinFree values. I've been running them with good success, if feedback is positive i'll update the prebake over the weekend to include it!

I also added a no-boot-up-sound option.

P

Share this post


Link to post
Share on other sites

Thanks, already found out.

But another issue came up. Since running MCR i can't use mp3. While trying to hear a song or setting up an mp3 as ringtone, the device freezes and restarts shortly afterwards. The glow ball demo from nvidia is also crashing the phone and causes a reboot.

Any tips on that?

Share this post


Link to post
Share on other sites
Thanks, already found out.

But another issue came up. Since running MCR i can't use mp3. While trying to hear a song or setting up an mp3 as ringtone, the device freezes and restarts shortly afterwards. The glow ball demo from nvidia is also crashing the phone and causes a reboot.

Any tips on that?

Did you flash the boot image?

Share this post


Link to post
Share on other sites

Thanks, already found out.

But another issue came up. Since running MCR i can't use mp3. While trying to hear a song or setting up an mp3 as ringtone, the device freezes and restarts shortly afterwards. The glow ball demo from nvidia is also crashing the phone and causes a reboot.

Any tips on that?

I had this exact issue coming from the 'standard' O2 build when the phone was first released (think it was 1.26) on both MCR and ARHD. Easily fixed - I went back to stock and did an update check, and there were several updates which took me up to 1.29. Reflashing MCR after this, and it works perfectly (not strictly true - there are a few minor issues, but i think they're more based off the HTC source than anything Paul has done).

I suspect Paul is correct, and that flashing the new boot.img should work. If not, try going back to stock and checking for updates.

Share this post


Link to post
Share on other sites

Changelog

29th June (changes to kitchen in preperation for updated prebake)

  • Updated Google apps to latest releases after I/O
  • Added Google Currents (latest version, new icon)
  • Added Google Ears music recognition widget
  • Added Play Store Magazines (region dependent).

Share this post


Link to post
Share on other sites

Changelog

2nd July

  • Updated various installed apps / libraries in line with latest Market releases

Share this post


Link to post
Share on other sites

I updated to Ir2 on Sunday, and I've since noticed that my phone is absolutely hammering it's battery - I had to charge it four times yesterday. The battery stats suggest that Google Services had used 81% of the battery time.

I'm going to try a fresh flash of Ir2 - I had previously simply re-flashed over the top of Ir1 - and will report back.

Share this post


Link to post
Share on other sites

Go into Settings -> Accounts and Sync -> your Google account and see if anything isn't syncing properly...

P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.