Jump to content
Dazzozo

[JB] [CM10] [4.1.1] CyanogenMod 10 for the ZTE Crescent [ROM] [Last updated: 01/09]

Recommended Posts

I know it is not my phone it was just a report of an issue and hopefully with some useful info to fix it. Love this CM10 Rom some great work by Dazzozo and all the others who help bring it to our phones

Unfortunatly, I Dont think its some that Dazzozo can Fix :)

Share this post


Link to post
Share on other sites

ah well never mind, have reverted to the earlier release which runs well for me. I don't know how he manages to get all these Roms and fixes out. i tried to port a rom a week or so ago took me ages just ot actually get it to boot but the wifi still will not work for love nor money :)

Share this post


Link to post
Share on other sites

Has anyone figured out why it won't let you install apps you've paid for? Seems fine with free apps but the bought ones bring up the sdcard error even if you enabled the sdcard security setting (could this new thing be something to do with it?)

...some time later...

After a bit of Google Fu I found the following, could it be a similar fix for us?

So I checked out logcat to see why some of my apps were not restoring correctly through TiBu. I found out that we were indeed missing make_ext4s and setup_fs in /system/bin.

After more checks, the problem was the exact same for paid apps through the market.

http://forum.xda-dev...3&postcount=279

I attached the zip file he attached to his post. Just gonna do a CWM backup and then try flashing it, can't hurt :)

...some more time later...

Well that didn't help but maybe the same fix?

I looked at the updater-script, this was inside...

ui_print(" Mounting /system...");

run_program("/sbin/busybox", "mount", "/system");

show_progress(1, 15);

ui_print(" Copying stuff...");

package_extract_dir("system", "/system");

ui_print(" Setting permissions...");

set_perm(0, 0, 0755, "/system/bin/make_ext4fs");

set_perm(0, 0, 0755, "/system/bin/setup_fs");

ui_print(" Unmounting /system");

run_program("/sbin/busybox", "umount", "/system");

ui_print("Done. You can reboot now.");

This post also mentions a similar fix being added...

http://forum.xda-developers.com/showthread.php?t=1781970

Included setup_fs and make_ext4fs

market-sdcard.zip

Edited by PsYcHoKiLLa

Share this post


Link to post
Share on other sites

Am I the only one getting bootloops after flashing and after attempts to troubleshoot, it automatically getting fixed ?

Must be something I missed to do before compiling. But what I can't understand is how it gets corrected

Also at the time of these bootloops, i'm not able to remount /system rw. permission issue.

Is it normal to have this is the boot log

W/SurfaceFlinger(  112): hwcomposer module not found[/CODE]

Edited by MadEye Moody

Share this post


Link to post
Share on other sites

Daz, great to see again the latest android version for the crescent!! Thanks so much.is there any idea if or when the front camera will be working for any of the cm roms?

Share this post


Link to post
Share on other sites

just flashed the latest build of this.. f##kin amazing man... smooth,fast,sweet.. only prob i got, got my gps turmed off and every now and again i get a gps symbol in top left of notification bar sayin searching for gps,have deleted maps in the hope that it was that which was accessing gps and it still happening, any ideas? ps sorry been away a while,have been busy. great work though Daz seriously

Share this post


Link to post
Share on other sites

Hey guys :)

I'm on CM9 right now and would love to try out this rom, what TPT should be used for this one? I haven't found any info about it in the OP. I'm still on stock partitions...

Share this post


Link to post
Share on other sites

Hey guys :)

I'm on CM9 right now and would love to try out this rom, what TPT should be used for this one? I haven't found any info about it in the OP. I'm still on stock partitions...

Probably Stock, as that as the most ROM Memory

Share this post


Link to post
Share on other sites

Unfortunatly, I Dont think its some that Dazzozo can Fix :)

I actually think I broke it...

Am I the only one getting bootloops after flashing and after attempts to troubleshoot, it automatically getting fixed ?

Must be something I missed to do before compiling. But what I can't understand is how it gets corrected

Also at the time of these bootloops, i'm not able to remount /system rw. permission issue.

Is it normal to have this is the boot log

W/SurfaceFlinger(  112): hwcomposer module not found[/CODE]

I am merging a lot of gerrit patches before I build - some are in the qcom display area. That might be the problem for you.

Edit: yeah I have some libcopybit patches and that's enabled in the BoardConfig, but you don't have them locally.

This is one: http://review.cyanogenmod.com/#/c/19700/

Daz, great to see again the latest android version for the crescent!! Thanks so much.is there any idea if or when the front camera will be working for any of the cm roms?

No idea, sorry, bigger priorities at the moment. I'm not talking about any bugs or broken hardware until we get everything working acceleration wise.

just flashed the latest build of this.. f##kin amazing man... smooth,fast,sweet.. only prob i got, got my gps turmed off and every now and again i get a gps symbol in top left of notification bar sayin searching for gps,have deleted maps in the hope that it was that which was accessing gps and it still happening, any ideas? ps sorry been away a while,have been busy. great work though Daz seriously

Cheers! :D

Share this post


Link to post
Share on other sites

Ah Oki!.keep up the good work! Such a shame about the qualicom drivers, and unfair to be penalised just because the crescent has an older architecture cpu!

Share this post


Link to post
Share on other sites

Sorry, did you see my post about the paid apps?

It's fixed internally but there's no build yet.

Share this post


Link to post
Share on other sites

It's fixed internally but there's no build yet.

:) :) Sync and compile

eh... and pull the new changes which are waiting to pass review, then compile

Share this post


Link to post
Share on other sites

Was it the same problem? I tried the zip file they had attached, didn't seem to fix it and had a look at the files inside, there didn't seem to be any device specific stuff.

Share this post


Link to post
Share on other sites

@Daz

Is the telephony patch required now?

No, it got merged on gerrit.

Share this post


Link to post
Share on other sites

They're not merged in to blade2 but this little "group" we have for the ZTE msm7x27 devices has solved them.

Share this post


Link to post
Share on other sites

firstly i must say that you are a complete legend for doing this and secondly, how would i be able to update the rom without having to do a wipe cache install??

Share this post


Link to post
Share on other sites

Wiping cache is a placebo anyway. Android automatically detects when caches are outdated because it signature checks the apks. If you're wiping cache that's a redundant step, not to mention that a data wipe formats every partition where any cache can be stored.

If you mean without wiping data, you can try it but if you start having weird problems you're going to have to wipe data.

Share this post


Link to post
Share on other sites

How do I manage CM9 and CM10 source directory together?

Presently, I have

~/android/source/cm9

and

~/android/source/cm10

From what I understand, these are 2 branches in the same/similar collection of projects, so there should be a way to have just 1 directory for both and checkout the branch as needed.

Share this post


Link to post
Share on other sites

I may be able to setup a cronjob to sync, apply display patch, compile and upload zip to some server if anyone has a server. Or i could just use dropbox if anyone is interested.

Share this post


Link to post
Share on other sites

You should really use Google Drive to be honest, Dropbox isn't really good with people mass sharing files but Google is pretty much fine with it. That would be wicked if you could do that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.