Jump to content
Dazzozo

[DEV] [JB] [CM10] [4.1.1] CyanogenMod 10 for the Huawei Ascend G300 [ROM] [Last updated: 26/08]

Recommended Posts

Dont really know much at all about andriod / rom's, but the following is my expierence after loading the Dev rom this morning on a spare g300, hopefully it maybe of some assistance

My expierence with freezing was when i turned on wifi, it froze, removed and replaced battery, switched on and it froze again on the CyanogenMod logo about halfway through the launch, went back to cwm reinstalled rom again and all went ok and wifi worked, installed my apps, did an antutu check and scored about 2750, then went and re-booted and im back to frozen screen on CyanogenMod again, left it in that state for about 10 to 15mins then the Huawei logo came up followed by the rotating Cyan logo and froze again..........

Update:-

Tried various things to cure the freezing on my phone, wiped cache, wiped dalvik cache, wiped data factory reset, all with varying degrees of success and then failure.

I appeared to have cured the freezing problem on my phone whether wifi is selected or not by going to “mounts and storage” then “format data”, no further freezing in half a dozen reboots, this may make sense to the people who know……..

Share this post


Link to post
Share on other sites

What we really need is a way to reproduce it, guaranteed, from a fresh flash of a ROM w/ custom kernel.

A data wipe fixing it doesn't sound too ridiculous, the Wi-Fi subsystem does store a fair few things on data.

Share this post


Link to post
Share on other sites

You don't need CM to track that bug.

Yeah, for example he can enable logcat in his stock GB, or ICS, and wait for error to happen ... No need for JB :P

Share this post


Link to post
Share on other sites

It's likely you have the mt9p sensor as that is the one we've had to substitute a driver for, and is the only one with the potential to be different to Huawei's code.

I have the mt9p sensor, So really I should be using the stock kernel to get the best pictures instead of Geno's?

Share this post


Link to post
Share on other sites

So, uh, why did all the Qcom devices fail to build for their CM nightlies last night? http://jenkins.cyano...om/job/android/ More importantly, why can't we build?

http://review.cyanog....com/#/c/24802/

lol

Daz, is there any chance of including the Sony Mobile Bravia Engine in this ROM?

Hyperrunner included it in his ROM for the Nexus 7 over at XDA.

Here's a link: http://forum.xda-developers.com/showthread.php?t=1796668

Share this post


Link to post
Share on other sites

I've just got a note 2, but I'm keeping the g300 as a spare, so if you need anything testing or want to give me instructions to try and replicate the wifi crash then let me know.

Share this post


Link to post
Share on other sites

Well I don't really understand this, but at the bottom of the page it says:

confirm fixed compiling on msm7x27 devices

for Patch Set 1? Does that means it's being fixed?

Edited by fuzzyy

Share this post


Link to post
Share on other sites

Just a quick comment, I get the wifi crash EVERY time i install a new ROM and turn wifi on for the 1st time.....phone hangs and eventually reboots, and then toggling wifi on and off works fine.

Again thanks for all your hard work :)

Share this post


Link to post
Share on other sites

We might have found a fix for the deadlock :) I just merged in the U8860 kernel drop -- Huawei seem to use a unified kernel for a fair few devices.

...and yep, an issue with the mt9p sensor seems to have cleared up for me with this too :D

  • Upvote 5

Share this post


Link to post
Share on other sites

Has there been a problem in waking the screen when it goes to sleep, using the power button it just switches the 3 touch switch lights on and off at each push, after several attempts the screen comes on, tried changing to the vol up/down buttons and the same happens.........

Edit:- Solved...........

Just for info...... Wiped everything and went back to scratch, followed Dazzozo instructions to the full this time, did not do the bold bit below first time .

NB for CWM: I advise you reboot recovery here, CWM seems a bit broken with flashes after wipes, at least for me.

Then wiped… data/factory reset, cache partition, dalvik cache, format data, re install rom, reinstall gapps, reinstall apps, overclocked to 1.229ghz all working fine this time..

Edited by bryfly

Share this post


Link to post
Share on other sites

We might have found a fix for the deadlock :) I just merged in the U8860 kernel drop -- Huawei seem to use a unified kernel for a fair few devices.

...and yep, an issue with the mt9p sensor seems to have cleared up for me with this too :D

One of these days we're gonna run out of bugs to be fixed and... what will you do then? :P

Edited by jsevi83

Share this post


Link to post
Share on other sites

One of these days we're gonna run out of bugs to be fixed and... what will you do then?

i guess we will cross that bridge when we get to it...

Edited by mack_

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

By using this site, you agree to our Terms of Use.