Jump to content
Sign in to follow this  

Dead Acer Liquid E

Recommended Posts

Hello, I have an Acer Liquid E Ferrari Special Edition.

Android Eclair.

I wanted to upgrade it to Froyo. I downloaded it from the acer website. It was OS_Acer_4.005.04.AAP.G2F_A22F_LiquidE Ferrari. Used the Acer Liquid Tool Setup Wizard. The upgrade stopped after sometime and asked me to "Remove the battery for 10 seconds. Turn on your Acer and connect it to a PC". I followed but the upgrade again stopped after 50% with the same instruction.

Now my phone is completely blank. When I press the power button it vibrates once and nothing happens. I tried Power + Vol. Down + Camera, it vibrates 3 times then released these 3 buttons and again Power + Camera. But still nothing happens.

I cannot get into Recovery.

I tried to flash it with Acer A1 DL Tool. It starts to flash but a pop up comes out "connect to pc"

My phone is not rooted.

Please find a way out !!..

Please help me.

Share this post

Link to post
Share on other sites

if your problem is not solved then may be i can give you another acer download tool, which is a new version of acer A1 download tool.

And you can try that, it may be the problem of rom you downloaded.

Edited by Diljeet

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.