Jump to content

Huawei Ascend G500 Pro / U8836D

Recommended Posts


I've got hold of a Huawei Ascend G500 Pro otherwise known as the U8836D.

I'm kind of a dual sim fan and have tried the HTC Desire V /T328W which would be great if it wasn't so slow!

I kind of liked the idea as it is a dual core, front camera and larger battery than the Acer Liquid Gallant Duo, although it lacks the compass.

Of course it was released in China - but has a almost stock version of ICS 4.04 with English as standard, but no Google framework/apps/play store although it is on the Google play list of devices.

I have tried the Bin4ry root method - which appears to work - but when I run root explorer it says it does not have superuser rights!

Has anyone else got one or any tips/ideas for getting root? I would like to try putting the Google framework stuff on to it

I know a certain supplier in China will eventually develop a ROM and root etc but I would like to add the google stuff to the pretty much stock rom.

Although I've used android for a while and used to IT I'm pretty new to modding so treat me gently!!

Share this post

Link to post
Share on other sites

Just to be sure - do you have Superuser or SuperSU installed

Edited by phlum

Share this post

Link to post
Share on other sites

Hi, Thanks for the reply.

I tried the Bin4ry v2 and v8 versions and they installed the Superuser app.

I've just noticed and tried Bin4ry's v10 version and that has updated su versions and SuperSU and I now have root!

Yeah! - so now I'm off to look at a complete backup then to install the Google services and Apps (especially sync (contacts calendar) gmail and play store.

Again any tips welcome - feeling my way slowly!

The handset is very similar I think to the Acer Gallant Duo/Solo as it uses the dual core Mediatek chip. I'd imagine the Mediatek flashing tool will work just fine - but obviously we need a scatter file for the G500. Anyone have any tips on how to create one - can it be done by reading the device with the flashing tool? Can I backup the entire device with the flashing tool?

The drivers with the mediatek flashing tools for the Acer Gallant seem to work just fine with the G500.

I might do a mini review as well if anyone is interested - would be better if I got the google stuff on first. I'm not so sure there will be that much interest and warrant it's own forum so I'll just update this thread for the moment.

Share this post

Link to post
Share on other sites


So I've got an adb shell to my G500 and was thinking of following this guide to create a scatter file http://bm-smartphone-reviews.blogspot.co.uk/2012/04/creating-rom-dump-of-your-mt65x3-device.html?m=1

However when I do a cat /proc/mnt I do not get any mount points at all! I get the first line:

cat /proc/mtd

dev: size erasesize name

[email protected]:/ $

Has anyone got any ideas where the mount points may be on my device?

Share this post

Link to post
Share on other sites

Hmm - seems that the G500 /proc/mtd is not used but /proc/emmc is used instead. It doesn't seem to list the same areas of storage as the /proc/mtd and is similar to the Lenovo A750. On another forum someone mentions this and I think they just waited for an official/leaked update to get a scatter file.

As it looks like this option might be out - is there another good way of getting a conmplete image/backup of everything?? Maybe using dd in an adb shell?

Share this post

Link to post
Share on other sites

Found a bit more if anyone is interested.

The Mediatek engineers mode can be entered by typing this in the dialler * # * # 3646633 # * # *

WARNING! Enter this menu at your own risk. I do not recommend changing anything in the menus.

Under the "Memory" section you can see the partition list that seems to contain the info that might be useful in creating a scatter file, mine is as follows:

Part_Name Size StartAddr Type MapTo

preloader 0x0000000000040000 0x0000000000000000 2 /dev/misc-sd

dsp_bl 0x00000000005c0000 0x0000000000040000 2 /dev/misc-sd

mbr 0x0000000000004000 0x0000000000000000 2 /dev/block/mmcblk0

ebr1 0x0000000000004000 0x0000000000004000 2 /dev/block/mmcblk0p1

pmt 0x0000000000400000 0x0000000000008000 2 /dev/block/mmcblk0

nvram 0x0000000000500000 0x0000000000408000 2 /dev/block/mmcblk0

seccfg 0x0000000000200000 0x0000000000908000 2 /dev/block/mmcblk0

uboot 0x0000000000060000 0x0000000000928000 2 /dev/block/mmcblk0

bootimg 0x0000000000600000 0x0000000000988000 2 /dev/block/mmcblk0

recovery 0x0000000000600000 0x0000000000f88000 2 /dev/block/mmcblk0

sec_ro 0x0000000000600000 0x0000000001588000 2 /dev/block/mmcblk0p2

misc 0x0000000000060000 0x0000000001b88000 2 /dev/block/mmcblk0

logo 0x0000000000300000 0x0000000001be8000 2 /dev/block/mmcblk0

expdb 0x0000000000200000 0x0000000001ee8000 2 /dev/block/mmcblk0

android 0x0000000018100000 0x00000000020e8000 2 /dev/block/mmcblk0p3

cache 0x000000001ae00000 0x000000001a1e8000 2 /dev/block/mmcblk0p4

usrdata 0x0000000032000000 0x0000000034fe8000 2 /dev/block/mmcblk0p5

fat 0x00000000808f8000 0x0000000066fe8000 2 /dev/block/mmcblk0p6

bmtpool 0x0000000001500000 0x00000000ff9f00a8 2 /dev/block/mmcblk0

Part_Name:Partition name you should open;

Size:size of partition


Start Address of partition;

Type:Type of partition(MTD=1,EMMC=2)

MapTo:actual device you operate

Hopefully this is a good step towards the scatter file - will look into it more when I have time.

Share this post

Link to post
Share on other sites

hi, just come across from google.

just want to give a little help.

i have different MT6577 device with working scatter file.

you can read my scatter file and my memory info screenshots.

i've read your memory info, it is different starting from "android" partition up to end.

if i understand correctly, you must add "600000" to "starting address" using Hex calculator to android partition up to end and edit my scatter file accordingly.

and you may need SP flash tool and vcom usb driver here (but dont flash my boot.img) http://www.mediafire...qk7513ghfzlnaax





Share this post

Link to post
Share on other sites

Thanks Paul and tri_zet for your help. I've managed to make a scatter file and dump the entire ROM for safe keeping, and added gapps.

Yes the addresses are straight absolute addresses in the emmc not relative to the partitions. When I have a few mins I'll post the file and a few links/instructions for anyone interested.

neveceral - so yes I have a dump of the rom and will post links instructions for you to make a dump - or ask me if you need any partitions already! I guess at some point someone may get hold of the official factory ROM.

I notice a dev with quite a bit of experience in MediaTek phones has got one and produced a CWM recovery, and is likely to post a ROM shortly - over on XDA and I'm sure a quick Google will get you there!

Share this post

Link to post
Share on other sites

I purchased a Huawei 510 from ebay and after spending a day on trying to install Google Play on it I have been told that its actually a Mediatek devie.

  1. I have no Google Play Store
  2. I cannot install it with an .apk
  3. I cannot put the phone in fastboot mode
  4. I cannot find the windows drivers for it, I have searched, googled and tried a whole bunch of 65** drivers but these are the errors I get!


I downloaded the exe files and it extracted to C:\Program Files\Handset WinDriver

Gave the path for updated drivers and it says that best driver is already installed


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.