Jump to content
Sign in to follow this  

Missing apps after ROM installation?

Recommended Posts

What does it mean when you install a ROM and some apps that are supposed to be included in that ROM are not there on booting?

For example, I've been using VegaCream RC2 for a while now, have flashed it onto several Advent Vegas and usually there are 25 apps included.

However, on one tablet I noticed that some are missing because I went to use Shuttle Tools and the icon was at the end of the second line instead of the beginning of the third. After comparing it to another Vega, it turns out it's missing OI File Manager and Terminal Emulator.

This reminded me that I had a faulty Vega a while back which loads incredibly slowly, if at all, and at some point I installed the P10 image (P10_image_20110411_v1.10.4_std_dev) on it to recalibrated the touchscreen. Looking at other Vegas, this ROM normally installs with 24 apps, but on this 'slow' tablet there are always only 17 - it's missing DevTools, EC Tool, Neocore, Recalibration Tool, Shuttle Test Program for Android, Spare Parts and Speech Recorder.

Needless to say, in both cases I'm using the same P10 and VCRC2 .exe files to install on these tablets, so it's not a broken download or corrupt .exe, and I've made multiple installation attempts in each case.

So what could be the problem, and is there any way to fix it?

Share this post

Link to post
Share on other sites

Here's the deal... if you open the CWR zip file, you'll notice that those .APK are inside /data/app. Terminal emulator cannot be inside /system/app, that's for sure.

So, they're not there. First thing, navigate to the given dir using a root explorer or even terminal emulator downloader from playstore. If the APKs are there, then you MIGHT have bad blocks which corrupted something.

You can try running dmesg | grep and see what you get. If the APKs are not there... you have a bad flash. Bad sectors can be the cause here also...

Share this post

Link to post
Share on other sites

I've installed a root explorer (Root Browser Lite) and when I look in /data/app there are .apks for Apex Launcher, Play Store, YouTube and Super Users (all of which were installed with the ROM), but not the file manager or Terminal.

I doubt a bad flash is the cause, as I have tried installing the ROM several times, and have wiped cache, etc. in between flashes, and have also tried going back to stock ROM and using modded stock v2 before going back to VegaCream, but those two apps are always missing.

Does that suggest bad sectors? How can I check for bad sectors and is there any way to repair them or mark them as bad and ensure they're not used?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.