Jump to content
Sign in to follow this  

Official ICS rom -- no service?

Recommended Posts

Hi there!

I managed to mess up my phone completely yesterday, much because of my own stupidity and a faulty USB cable. I have never used any custom roms before, and had not intended too, since I've always found it a bit scary. But after trusting LG PC Suite and said faulty USB cable to update to ICS, my phone stopped working at all, which kind of forced my hand.

So I found this official ICS 4.0.4 rom, and managed to install it on my phone: http://www.modaco.co...e-for-download/

It seems to work great, and I really love my new phone, but I never get a signal anymore. In Norwegian, it says "Ingen dekning", which I guess translates to "No service", and the signal bars in the upper right corner are empty, and has a red cross on them. Any ideas on what I can do about this?

As some additional information, this is exactly what I did yesterday:

  • Started out with a fully working, but laggy 2.3.
  • Crashed it completely when trying to update to ICS using LG PC Suite.
  • Installed official 2.3 rom again, in an attempt to let LG PC Suite try again. Phone worked just as before, with service.
  • LG PC Suite refused to update, just kept telling me that I had the newest version.
  • I then found and installed the above mentioned official ICS rom. Loved it, but soon discovered that I had no service.
  • Attempted to reinstall the official 2.3 rom to get a usable phone, but now I had no service on this one either.
  • Since I had no service anyway, I decided I might as well have no service with ICS, so I installed the ICS rom once again. Still no service.

So bottom line, I think it was something that happened when I installed ICS, since it worked in 2.3 before, but not after.

I tried swapping sim card with a friend -- my card worked in his phone, but his card in my phone still got no service.

EDIT: Oh, yeah, and I have checked the APN settings. They are correct.

Huge thanks to anybody who can help me sort this out!

Edited by Hugeflis

Share this post

Link to post
Share on other sites

Hi there!

Thanks for the suggestion, but that is actually the exact rom I installed when the official update failed, so yes, I have tried SmartFlash. :P

I used both the files mentioned in that thread, which I believe includes the baseband, so I think I did that part right. I also tried using the very fancy method described here, which I believe should give me exactly the same rom as the official update, but I still can't get a signal. Everything else works, though.

Any other ideas? :)

EDIT: Actually, I have now tried SmartFlash, NVFlash, and the above mentioned approach, and while all of them work splendidly in most aspects, I can't get a signal in any of them anymore. Note that the last time I had a signal was with the NVFlashed 2.3 rom, but even when going back to that now, I can't get a signal.

Edited by Hugeflis

Share this post

Link to post
Share on other sites

Stage one - reallllllly check the APN, etc. to make sure you aren't doing something silly.

Stage two - check that the baseband and RIL elements match and are the right ones

Stage three - try different BB & RIL combos

Share this post

Link to post
Share on other sites

Thanks for the suggestions, sane!

I double and triple checked the APN, and it is correct. To further confirm this, I put the sim card in another phone, and it works there (if I have understood correctly, the APN settings are stored on the sim card, so this should confirm the APN).

I installed GetRIL, and it confirms that the RIL/Baseband is matching. The information it gives me is as follows:

  • RIL: V30a (EU)
  • md5sum: d7f7ff314a77b87d645c9e4c7ebb38bc

    And I have confirmed this with another Optimus 2X user with a Norwegian model. He has the exact same information both in GetRIL, and in the phone settings:

    • Android version: 4.0.4
    • Baseband version: 1035.21_20121130
    • Kernel version:
    • Version number: IMM76L.LG-P990-P99030a.1211302332
    • Software version: P99030a

    So apparently, my phone has the exact same rom versions, baseband and RIL as another 2X phone from Norway. What else can possibly be wrong?

Edited by Hugeflis

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.