Jump to content
H3ROS

[ROM][ZTE Skate] H3 Holo (Dolby Audio + Linaro optimized kernel + frandom + ROW I/O scheduler)

Recommended Posts

Maybe they could just recalibrate the battery. Just wipe the battery stats after you charged your phone to 100%

Edited by honigfisch

Share this post


Link to post
Share on other sites

There isn't, but you can change fonts easily via an app.

 

https://play.google.com/store/apps/details?id=com.jrummy.font.installer

 

You could also install the Gingerbread version of Xposed and one of it's addons (I think it's XposedAppSettings) and then you can have per-app DPI.

 

http://forum.xda-developers.com/showpost.php?p=44034334&postcount=2315

 

I know that currently theres some DPI issues to be worked out, but with the ROM using it's default settings it's perfect.

 

 

@ honigfisch

As the stock keyboard was replaced I can't seem to make it accept the original keyboard. Even if I drop in the apk and add the lib, it simply won't list it as an option (you can try youself by taking the apk from H3 Blues). So the best thing I can do there is switch to the ICS keyboard, which is better than a themed GB keyboard anyway.

Edited by H3ROS

Share this post


Link to post
Share on other sites

That patch is working fine for me.

 

The ROM patch that fixed bluetooth? It should do, and with that all major issues are fixed :)

Share this post


Link to post
Share on other sites

After a few days of testing I again returned to the factory rom. On a stock rom after 46 hours battery is at 64%, on H3Holo after 12h of standby battery drop down by 1%, but when i start to use the phone battery start to drop down every 5 sec by 1%. Think that only I have this issue.Otherwise rom looks great, but I now need a reliable battery and solid camera, stock rom and ics camera do the work

Edited by Paun21

Share this post


Link to post
Share on other sites

H3 Blues and H3 Holo are similar on battery tweaks, but H3 Holo does more in that area. It uses ARM power magement, it undervolts the Wi-Fi and theres a bunch of performance tweaks that have been made so that it gets things done quicker, which in turn means it's going to use less CPU and save battery.

 

I've been benchmarking the battery the last few days and have found that so far everythings fine. Theres no unexpected wakelocks and the CPU idles at 122MHz when nothings going on. On average I can have it last 3 days from the one charge, and thats with Wi-Fi turned on, about 50 or more texts and 20 minutes of YouTube.

 

I would like to try some settings that you feel helps your device, but it can take a while to test each setting as you need to charge your battery from 1-5% to 100% and then recalibrate your battery after each change. At a push I guess I could remove "chunks" of things I've changed, like 10 build.prop changes and then another 10 depending on the result. If you're willing to try that then I'd put something together.

Edited by H3ROS

Share this post


Link to post
Share on other sites

Thank you for your answer,

 

@ cyberke

 

It should be okay as long as you wiped everything. The first boot can take a few minutes while it builds caches and sets up data. I'd say about 5 minutes max.

 

Also make sure you've got everything done like in this post: http://www.modaco.com/topic/366117-romzte-skate-h3-holo-dolby-audio-linaro-optimized-kernel-frandom-row-io-scheduler/page-4#entry2169801

 

I did de prerequisite steps, I will try again and wait a bit longer .... hope it works, the zip is ok i did an MD5 check

 

The Android H3 HOLO boot screen comes up after +- 30 seconds screen comes black an then the Android H3 Holo logo continues antimated ... this goes on and on ... your previous rom fashed with no problems ( blue )

 

GOOD NEWS: i had the idea of booting it once without SDCARD after flashing now the rom boots correctly.

 

Tonight i will backup my SDCARD and reformat it hope i can use it then again.

Edited by cyberke

Share this post


Link to post
Share on other sites

@ cyberke

Format your SD-EXT partition if you've got one. Also the SD card itself should be FAT32.

 

 

@ sezox

It's for a different device. It has a different hardware key layout and display driver.

 

 

@ radashin

Cycle though the network modes. Sometimes it needs that to clear what your previous ROM had it set as.

Share this post


Link to post
Share on other sites

@ cyberke

Format your SD-EXT partition if you've got one. Also the SD card itself should be FAT32.

 

 

@ sezox

It's for a different device. It has a different hardware key layout and display driver.

 

 

@ radashin

Cycle though the network modes. Sometimes it needs that to clear what your previous ROM had it set as.

 

Thank you formating SD-EXT did the trick everything boots now

Share this post


Link to post
Share on other sites

I'm glad the suggestions worked for both of you.

 

I'm currently in the process of trying different tweaks, both at the system level and kernel to see if I can improve battery. In general after switching from a different ROM people should recalibrate their battery and do a full charge, but not via USB.

 

If anyone thinks their battery is draining a little quick then backup your ROM and try using C3C0's S2 kernel. If that helps then at least I'd know where to look, since battery doesn't seem to be a problem for me.

 

S2 kernel: http://tinyw.in/j4Bn

Share this post


Link to post
Share on other sites

This is a general issue with all roms for me:

If i take a picture directly with whatsapp(there is an option - where whatsapp changes to the camera) - the picture is sharp for one moment after i took the picture but in the whatsapp preview where i can choose if i want to send it or took another picture - it is blurred

And if i send it - it is sending the blurred picture

Do you have any ideas what could be the problem H3ROS?

Share this post


Link to post
Share on other sites

It could be that the app is doing something with it (compressing it or resizing it) or could be that it's to do with the Skates camera. So what happens if you lower the picture size before taking the picture?

Share this post


Link to post
Share on other sites

If i take the picture with 5MP it gets less blurred than with 3MP or 1MP Edit: LED isnt working - and if i take a picture there is always a black point if you check the images clearly

Edited by honigfisch

Share this post


Link to post
Share on other sites

I dont know - it could also be the camera itself because i dropped it sometimes If i take the picture with the normal camera they are clear and if i send them they are clear too - the only problem is if i send it through whatsapp directly And if i remember this didnt happen with the Stock Rom - only with Custom Roms but with H3 Holo it gets less blurred than with any other Rom Anyway thanks

Edited by honigfisch

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.