Jump to content

Recommended Posts

Replace bootanimation.zip or download ROM toolbox for change boot animation.

I'm not trying to change bootanimation, i'm trying to change splash screen, that image that comes before bootanimation, usually is a Huawei static logo...

Share this post


Link to post
Share on other sites

I allready tried it, with genotools, my phone does all the steps, everything goes nicelly but when i reboot the device the splash screen stays the same...bootanimation is very easy, but this...

Edited by Koplinjp

Share this post


Link to post
Share on other sites

Can I brick with changing bootanimation?

You must have your phone rooted. And if you get a 480x800 bootanimation (google it to find tons of bootanimations) you should not have any problems...

Share this post


Link to post
Share on other sites

I discover a hidden menu using *#*#2846579#*#*... There is a qualcomm background open setting option in one of the submenus bit asks for a password... I tried 0 and 0000 (for some huawei models that is the pass, but not this model)... This gets me to a solution to change splash screen? Does anyone knows the pass for this? I'm allmost certain that i can't change splash screen because my phone have somekind of operator block (inspite of i already unlock network block)... Any answers?

Share this post


Link to post
Share on other sites

Does anyone knows how to change boot imagem logo on a y300 with bootloader and network unlocked, and rooted also? Tanks...

That boot image is a kernel part, so, to change it you need to know how to decompile and compile a kernel and after you change that image...

Greetings!...

This guide should work...

Share this post


Link to post
Share on other sites

That boot image is a kernel part, so, to change it you need to know how to decompile and compile a kernel and after you change that image...Greetings!...This guide should work...

I tried the guide, created a new boot.img with new splash screen... no good. Tried to flash a new image, created with some tools from the guide, using fastboot but the writting in the phone is denied...

Share this post


Link to post
Share on other sites

 

I've created a oemlogo.mbn file with pain,net, copy to sdcard, put it on cust directory. Then i used genotools to replace my bootlogo file with a jpg (the same) and it worked! I gess it was because i had the file on cust directory, because i allready tried genotools and it didn't work... tanks...

Share this post


Link to post
Share on other sites

If someone needs GenoTools... it would be nice to got translation or to know what partition is changed.

The first option is for changing splashscreen, for others I do not know/read.

This is my new splashscreen for U8833 (Y300), joking, of course.

5-fallouty300.jpg.d76e24280bbf9b5ebb0deaa070e193f5.jpg

Share this post


Link to post
Share on other sites

@adeii

Hmm, I connect my phone, selected a picture, checked if ADB sees him (he did), and pressed okay. He starts something with 3 dots on the end, I guess doing something, and then pop error in which I can only understand ADB XD

Help?

Edited by Gintoki98

Share this post


Link to post
Share on other sites
On 5/25/2018 at 10:18 PM, Gintoki98 said:

 

I guess, phone is rooted and adb is on. Maybe picture is not 480x800x24bit JPG? What OS (PC and phone) you has installed?

Kill all adb.exe processes in TaskManager, GenoTools opens his hwadb.exe.

Screenshot_8.png.f4e700fc3c87c271afaf3dad24ce9193.png

更换失败,请正确安装手机驱动并确认手机开启了ADB调试,然后将手机连接电脑 后重试 = The replacement failed. Please install the phone driver correctly and confirm that the phone has ADB debugging enabled. Then connect the phone to the computer and try again.

Edited by adeii
  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for responding! :)

I have win7, and slimkat 9.1 Legacy, is rooted and has USB debugging enabled. I have minimal adb systemwide installed.  Yes, I've tried with the picture you posted up there. 

So here is the thing: when I try to just open first item on menu, it pops that issue. Only hwadb.exe is activated at the moment in TaskManager. So this doesn't seem to work as it should.

Next I typed adb devices in CMD, and my device showed up. It said something about previous adb being too old and it killed it(I guess hwadb.exe). Now, my the app obviously detects phone and opens the window in which I can select my image. I used quite short /dir route. I pressed okay, and then he pops once again that issue you posted, as if I wasn't using adb devices command. I even tried killing adb.exe midway in second scenario, but it just popped again.

Next, I tried it on other PC, which doesn't have adb installed. Same issue, it just pops that window on first press of menu item.  Quite strange...

Perhaps I miss some drivers I ought to have?

Edited by Gintoki98

Share this post


Link to post
Share on other sites

Update1: GenoTool changes splashscreen even it reports error about ADB. Partitions mmcblk5, 9 and 10 are changed after new splashscreen. I guess partition 5 (/dev/block/mmcblk0p5) is most important because its header is "oemlogo....", and so I can backup it and could flash it via recovery.

Update2: There are, another way to make splash as png, 480x800, convert it to rgb565 format, compress it to oemlogo.mbn, upload to /system/media or

make folder /data/cust/logo and put there oemlogo.mbn and execute load_oemlogo.

 

 
 
 
 

 

Update3: Let''s see GenoTools sourcecode, line 228, function changelogo(): https://github.com/genokolar/Genotools/blob/master/genotools.au3 Rooted + ADB!

- it repack jpg to rgb565 format, rename it to oemlogo.mbn, push it to /data/cust/logo.

- push load_oemlogo to /data/local/tmp and open shell (terminal on android or adb shell on pc)

chmod 0755 /data/local/tmp/load_oemlogo

- chown 0.0 /data/local/tmp/load_oemlogo

- /data/local/tmp/load_oemlogo and that's it.

Update 4: Flash this via recovery, it do the trick!

SplashScreenY300.zip

 

Edited by adeii

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.