Jump to content
menace1944

Hudl 1.3.1 Update

Recommended Posts

I believe you'll need the second and third links in the tutorial I linked you to. The second link is the stock system image and the third image is the tool to flash the image with

Share this post


Link to post
Share on other sites

Been away for a week, so not had a chance to look at this properly. I've got the update.zip, I've removed the asset checks from the updater script ... but unlike the previous 1.3 update, still no go from CWM.

 

Having seen the result of the 1.3.1 updates Touch Screen Reset on a friends unmodded Hudl, I really want the update. Guess I'll have to find some time to wipe it and start again.

 

Anybody else tried removing the asset check lines from the updater script?

Share this post


Link to post
Share on other sites

Ok, have some free time over the next couple of days, will see if I can create a windows flashing package for a stock v1.3.1 hudl ROM.  :D

 

If successful will move on to create a v1.3.1 rooted ROM with some mods, but remeber this will probably create a running Hudl that *will not* be future upgradeable via OTA updates. :excl:

 

*NOTE TO MODACO ADMINS* if we ever get some active modorators and sticky post capability by others than the forum creator, on this forum it may induce people to be a bit more pro-active in creating STUFF i.e. ROM's for the Hudl - just my thoughts! :ninja:

Edited by CaptainMidnight

Share this post


Link to post
Share on other sites

Im stuck

 

Cant update or use hudl now - did have a modified systemui but reset the hudl to factory settings before sorting that out and it keeps wanting to update automatically now on reboot but cant as it errors all the time

 

Ive reset it again to see if it allows to skip wifi set up but it doesnt allow that at all

 

Any body have some simpleton tips for me??

 

Annoying

Share this post


Link to post
Share on other sites

So Whats the first file then for. Im worried im going to bug up the hudl when flashing.

 

The first file was for the earlier system before v1.3

 

 

I have the same problem as kite.

I can't reflash the hudl as I can't enable develop tools to enable debug.

I just don't know what else to do :(

 

I don't think usb debugging is required to be able to flash the rom (though I will check in a minute on my own hudl). What have you tried so far to reflash it?

Share this post


Link to post
Share on other sites

Im stuck

 

Cant update or use hudl now - did have a modified systemui but reset the hudl to factory settings before sorting that out and it keeps wanting to update automatically now on reboot but cant as it errors all the time

 

Ive reset it again to see if it allows to skip wifi set up but it doesnt allow that at all

 

Any body have some simpleton tips for me??

 

Annoying

 

Share this post


Link to post
Share on other sites

I can't flash it.

Heres the process tell me if im wrong.

1.I turn on my hudl to the setup page

2. Plug in hudl to pc.

3. Open the windows rktools.

4. I can't do the next step as It dosn't detect the hudl.

Share this post


Link to post
Share on other sites

I can't flash it.

Heres the process tell me if im wrong.

1.I turn on my hudl to the setup page

2. Plug in hudl to pc.

3. Open the windows rktools.

4. I can't do the next step as It dosn't detect the hudl.

Share this post


Link to post
Share on other sites

Yeh same here - cant skip the update by touching the four corners

Tried connecting to wifi then switching my wifi off but again asks to connect and then its straight to downloading the update loop

Share this post


Link to post
Share on other sites

I can't flash it.

Heres the process tell me if im wrong.

1.I turn on my hudl to the setup page

2. Plug in hudl to pc.

3. Open the windows rktools.

4. I can't do the next step as It dosn't detect the hudl.

okay, next things to check:

1.) are you using the hudl's usb cable rather than a different one? (I had issues using my nexus 4's cable to flash the hudl)

2.) are you certain you're booting it to the bootloader? If you tap the power button does the charging symbol show on screen?

3.) if yes to 1. and 2. then I'd begin to suspect it's drivers - there are a few other threads on this site that mention people's driver problems and solutions

 

Yeh same here - cant skip the update by touching the four corners

Tried connecting to wifi then switching my wifi off but again asks to connect and then its straight to downloading the update loop

that's a shame, I was hoping it might have worked as an easy option

Share this post


Link to post
Share on other sites

1. Its the official hudl cabel.

2. Im not sure if its the bootloader but when you hold power button it shows the hudl star then goes to my custom animation and then asks for wifi then which after that it asks update, as kiteboys said its not working for me either.

3. I can't install the drivers because it only detects the storeage.

2+. I was able to open the android recovery mode but formatting with that didn't work.

Share this post


Link to post
Share on other sites

1. Its the official hudl cabel.

2. Im not sure if its the bootloader but when you hold power button it shows the hudl star then goes to my custom animation and then asks for wifi then which after that it asks update, as kiteboys said its not working for me either.

3. I can't install the drivers because it only detects the storeage.

2+. I was able to open the android recovery mode but formatting with that didn't work.

 

hokay, 2.) is your problem - to get to the bootloader to flash you don't boot normally; if you see the hudl star and boot animation then it's booting normally. To boot to the bootloader you need to:

 

- shut the hudl down

- connect to the computer via usb

- hold the volume up key

- press the reset button (the hole in the top left corner on the back of the hudl)

- release the volume up key

 

the screen shouldn't show anything, but it should boot to the bootloader, which rktools for windows should then see. If the hudl star, boot animation or charging symbol appears on screen then it's not booted to the bootloader. Hope this helps!

Share this post


Link to post
Share on other sites

Ok, have some free time over the next couple of days, will see if I can create a windows flashing package for a stock v1.3.1 hudl ROM.  :D

 

If successful will move on to create a v1.3.1 rooted ROM with some mods, but remeber this will probably create a running Hudl that *will not* be future upgradeable via OTA updates. :excl:

 

*NOTE TO MODACO ADMINS* if we ever get some active modorators and sticky post capability by others than the forum creator, on this forum it may induce people to be a bit more pro-active in creating STUFF i.e. ROM's for the Hudl - just my thoughts! :ninja:

 

 

Great news :)

 

If you have the time could you explain to me how to make one of these "IMG files for windows" from the Backup files I created in Linux?

I posted these backups in post #56 of this thread.

 

Cheers

Share this post


Link to post
Share on other sites

Great news :)

 

If you have the time could you explain to me how to make one of these "IMG files for windows" from the Backup files I created in Linux?

I posted these backups in post #56 of this thread.

 

Cheers

 

likewise, I'd be interested to know how

Share this post


Link to post
Share on other sites

Ill try flashing it in the bootloader in 20 mins I hope it helps :D

 

if it completes successfully you should have an absolute stock v1.3 install, which you can then update v1.3.1 successfully. Once the v1.3.1 update is complete you can then re-root using kingo

 

fingers crossed for you!

  • Upvote 1

Share this post


Link to post
Share on other sites

Everytime i try it brings up hudlstar and thenbattary

 

are you sure you're pressing the reset button not the mic hole? The mic hole is next to the headphone socket on the long edge, the reset hole is on the back.

 

you don't need to press the power button to get to the bootloader - just follow the steps on the previous page

Share this post


Link to post
Share on other sites

1.I turned hudl off

2.I plugged it into pc

3.I held volume

4.Push it in quickly and then my pc makes these noices which I think a device is connected and then when I let go it does it again and then opens up battery level.

Share this post


Link to post
Share on other sites

Exactly - for anyone who gets stuck upgrading to v1.3.1 AND has backups of their stuff (if you don't - well what have you not been doing then - answer making backups of your stuff) there are a couple of simple'ish options: -

 

1. Use this link and blow away your hudl back to stock v1.3 using the windows RKBatchTool.exe

 

2. Visit Freaktab.com and download Blinky's ROM, he's even got a thread in this forum - that'll completely flash you back to a rooted v1.3 using the windows RKandroidtool.exe

 

The above option threads also include masses of info on how to do either option i.e. troubleshooting.

 

Either of the above actions when completed successfully will end up with a working hudl, using option 1 you're good to go for the OTA update again, option 2 is just listed to give you an alternative windows tool for flashing.

 

The hudl is a RK3188 cpu powered tablet, it's extremely rare to be able to completely brick the tablet IMHO. If you find your hudl is not working - take a step back, take some deep slow breaths, get a cup of tea / coffee and start reading / searching this forum for more info on 'retaled' stuff.

 

What I'm trying to say in the least offensive way possible is with the hudl, you have a cracking tablet that'll withstandard a lot of abuse via software upgrades/flashing etc BUT the onus is on you the person between your hudl and your seat to research and understand what you are doing AS WELL AS having a basic knowledge of how to 'google'. Issues/problems related to how-to and putting the hudl in bootloader mode as well as driver issues etc have been covered in these and other forums before.  :ninja:

Edited by CaptainMidnight

Share this post


Link to post
Share on other sites

1.I turned hudl off

2.I plugged it into pc

3.I held volume

4.Push it in quickly and then my pc makes these noices which I think a device is connected and then when I let go it does it again and then opens up battery level.

 

hmm, that sounds right to me though it's been a while since I've done it - are you releasing the volume up key at the same time you're pressing the reset pin or after?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.