Jump to content
Sign in to follow this  

[Problem] Old Blade's Wifi won't work with new ROMs

Recommended Posts



I wanted to give my old Blade (Gen1 TPT'd to Gen2) to my mom, because her phone died.


Now I've encountered a problem. While Wifi still works fine with an old cyanogen mod (cm7.1.0-RC1) I still had lying around, all the newer roms, even other cm7 roms break the Wifi.

I've tried CM9 through 11 and the minimalist versions of CM7 and CM9.


It finds the Network, but after entering the password it just switches back and forth between Connecting... and Authentication... until it just gives up. I even switched from WPA2, to WPA, to WEP to nothing and changed the channels to make sure it wasn't a problem with the network itself - without any luck tho.


The old cyanogen mod that works has an older kernel (


I've tried searching for a solution and browsed some of the threads, but couldn't find anything unfortunately.


Does anyone have a solution for this?


Thanks in advance.

Edited by jurrasstoil

Share this post

Link to post
Share on other sites

Hi jurrasstoil,

I think it depends on the build (release) of the ZTE Blade... As I too am having this issue with sporadic rom updates... Some work, some don't after first install... It will work fine if you cancel out of the setup, boot to the OS and then connect. But you lose all the pre-setup Wizard optimizations....

This never used to happen on my older Blade (which died, Touchscreen) and it doesn't appear to be an issue for my brother who is still happily using his original OLED Blade... So therefor I don't think the ROMs are at fault, more so the hardware gen inside each Blade...

It's annoying, but can over come it....

Cheers, Lister

Share this post

Link to post
Share on other sites

Thanks for the reply.


I've always skipped the setup, because I use a 63 character wifi password and copy/paste it. Except for the old CM7 build I still have, none of the newer roms have working wifi for me (I've tried 6 or 7 by now).


It's one of the older blades, I think the generation after they stopped producing them with OLED. Mine is definitely a TFT and the number inside it says P729B.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.