Jump to content
PaulOBrien

How to root your Hudl 2

Recommended Posts

That looks worrying mbalax. That's a different error.

You did adb reboot bootloader and not the key combination bootloader method yeah?

P

Share this post


Link to post
Share on other sites

Now I'm getting this on the Hudl.....

 

E:installer device ignored

FASTBOOT INIT...

E:installer device ignored

FASTBOOT CMD WAITING...

E:installer device ignored

E:No valid installer medium found.

 

Then in Bright Blue

 

RESULT: OKAY

 

??????? :(

Share this post


Link to post
Share on other sites

Working well now with second revision, SuperSu working correctly. I have deleted:

Tesco Bank

Tesco Photo

Groceries

Child safety

Best of blinkbox

blinkbox

blinkbox music

blinkbox movies

And system is running brill. I backed up with Titanium backup but deleted apks with ES File Explorer due to Titanium backup not uninsalling for some reason.

Share this post


Link to post
Share on other sites

Hi! Downloaded the two files last night. Connected hudl2 to PC. No prompt p autherise connection just normal connection windows shows available options ice. Open folders.... At command prompt typed in adb-windows reboot bootloader. Adb returns no device connected? What am I doing wrong! Ta!

Share this post


Link to post
Share on other sites

Now I'm getting this on the Hudl.....

 

E:installer device ignored

FASTBOOT INIT...

E:installer device ignored

FASTBOOT CMD WAITING...

E:installer device ignored

E:No valid installer medium found.

 

Then in Bright Blue

 

RESULT: OKAY

 

??????? :(

 

I think Paul suggested you try a different PC/laptop.

Share this post


Link to post
Share on other sites

That looks worrying mbalax. That's a different error.

You did adb reboot bootloader and not the key combination bootloader method yeah?

P

 

Tried again after prayers to the Root Gods, and this time it worked fine!

Thanks a mill Paul for setting all this up for us . . .

Share this post


Link to post
Share on other sites

I think there may still be some permissions issues as some root apps are not working eg: Quick boot will not shutdown, reboot , bootloader ect plus the titanium problem,unless these apps have a problem under Intel Android devices. I am able to mount /system as read write now so I do not think that's the issue now.

once again thanks for your hard work.

Share this post


Link to post
Share on other sites

Now I'm getting this on the Hudl.....

 

E:installer device ignored

FASTBOOT INIT...

E:installer device ignored

FASTBOOT CMD WAITING...

E:installer device ignored

E:No valid installer medium found.

 

Then in Bright Blue

 

RESULT: OKAY

 

??????? :(

 

'Result = OKAY' means it all worked properly!

 

Hi! Downloaded the two files last night. Connected hudl2 to PC. No prompt p autherise connection just normal connection windows shows available options ice. Open folders.... At command prompt typed in adb-windows reboot bootloader. Adb returns no device connected? What am I doing wrong! Ta!

 

It could well be a driver issue, do you have an unknown device in 'Device Manager'?

 

I think there may still be some permissions issues as some root apps are not working eg: Quick boot will not shutdown, reboot , bootloader ect plus the titanium problem,unless these apps have a problem under Intel Android devices. I am able to mount /system as read write now so I do not think that's the issue now.

once again thanks for your hard work.

Even though you can remount r/w, or it appears you can, you can't change /system, so you need to freeze with Titanium and not try and delete. Quick boot not working is a problem with that specific app.

P

Share this post


Link to post
Share on other sites

Hi! Downloaded the two files last night. Connected hudl2 to PC. No prompt p autherise connection just normal connection windows shows available options ice. Open folders.... At command prompt typed in adb-windows reboot bootloader. Adb returns no device connected? What am I doing wrong! Ta!

Do you not need Intel Android drivers installed? https://software.intel.com/en-us/android/articles/intel-usb-driver-for-android-devices

Have you enabled USB debugging on the device itself?

Share this post


Link to post
Share on other sites

First to say thankyou to PaulOBrien for your work and support for this root method....

 

I sat all night nearly trying to make this work, never quite succeeding and not understanding why... The hudl reported that all was "OKAY" without actually flashing the rom and my computer reported there was an error....

 

In desperation this morning I un-installed all my previous root apps for the Asus, Nexus, MotoG and stand alone apps such as Kingo etc... I also removed all assoiated drivers for these devices and ADB drivers...

 

I then did a fresh install of the Adb drivers and run the Hudl 2 root again...... Bingo..... Flashed first time..... So I can only assume one of my previous root applications was causing a problem, maybe a driver issue...... But either way job, jobbed....

 

Thanks again PaulOBrien for all your hard work and support....

Share this post


Link to post
Share on other sites

 

Even though you can remount r/w, or it appears you can, you can't change /system, so you need to freeze with Titanium and not try and delete. Quick boot not working is a problem with that specific app.

P

 

 

Just tested r/w access to system again and i have lost permission so you are right, but I did have permission as I have deleted system apk's. Is there a way we can unlock /system permanently, we must be able to achieve this as i had access for a time. Might have been after flash on first boot.

Edited by vermillions

Share this post


Link to post
Share on other sites

Just tested r/w access to system again and i have lost permission so you are right, but I did have permission as I have deleted system apk's. Is there a way we can unlock /system permanently, we must be able to achieve this as i had access for a time. Might have been after flash on first boot.

Interesting, and the APKs haven't come back on reboot no?

P

Share this post


Link to post
Share on other sites

Interesting, and the APKs haven't come back on reboot no?

P

No they have not reinstalled, So /system must have been unprotected at some point, do you think we maybe able to unlock if we have temp access?

Share this post


Link to post
Share on other sites

No they have not reinstalled, So /system must have been unprotected at some point, do you think we maybe able to unlock if we have temp access?

I wonder if it's an error on the filesystem. I'll investigate further.

P

Share this post


Link to post
Share on other sites

hi paul thanks for the root, however Tesco has just pushed a 9mb update to my hudle which it fails to install, now its stuck in a loop

so people hold off rooting for now!!!

  • Upvote 1

Share this post


Link to post
Share on other sites

hi paul thanks for the root, however Tesco has just pushed a 9mb update to my hudle which it fails to install, now its stuck in a loop

so people hold off rooting for now!!!

Does the device boot up OK after trying to apply the OTA?

P

Share this post


Link to post
Share on other sites

Ouch! I literally just rooted my device.

Can I revert the changes somehow?

Working on that, haven't applied the OTA on mine as yet, waiting for confirm what the device is doing after applying over root...

P

Share this post


Link to post
Share on other sites

As per the first post.

I notice that there is a new droidboot image in the OTA, I wonder if Tesco are patching out flashing the system image?

P

Share this post


Link to post
Share on other sites

ok using your stock image now. Fingers crossed!

 

Amazing response time! :D ​ Bravo Tesco... Checking the stock image as well.

Edited by Catastrophe

Share this post


Link to post
Share on other sites

Note the stock image is currently untested - I don't want to do anything further with my device until we find out where we are re: the OTA.

P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.