Jump to content
KonstaT

[DEV][ROM][5.2.] LineageOS 13 (Android 6.0.1) for ZTE Open C / Kis 3

Recommended Posts

I doubt that. All that is caused by SetupWizard removal and it was fixed in opengapps a while back. Also make sure you've followed installation instructions in the third post.

I did a clean installation with open_gapps-arm-6.0-pico-20170204 gapps and those I've confirmed working myself.

 

OK, after the third Installation its now working correct.

 

I have forget, to wipe "system" in twrp.

 

Thank you for support.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks a lot! Is SU/root already included or do I need the lineage su.zip to unlock it through flashing?

One (probably less important/relevant question): Do you know if the lineage people still port security fixes to the former CM11 (now lineagsOS 11?) branch? And if so, would it be possible for me to apply your patches to their 11 branch and compile a build for the open c? I'm just asking, as cm11 was quite performant on this device.

Cheers

Share this post


Link to post
Share on other sites
13 minutes ago, drake763 said:

Thanks a lot! Is SU/root already included or do I need the lineage su.zip to unlock it through flashing?

One (probably less important/relevant question): Do you know if the lineage people still port security fixes to the former CM11 (now lineagsOS 11?) branch? And if so, would it be possible for me to apply your patches to their 11 branch and compile a build for the open c? I'm just asking, as cm11 was quite performant on this device.

Cheers

Su is included like in previous CM13 builds.

Looks like they've merged November 2016 security patch.
https://review.lineageos.org/#/q/status:merged++branch:cm-11.0+-project:^.*device.*+-project:^.*kernel.*,n,z

Yes, you should be able build the cm-11.0 branch.

Edited by KonstaT

Share this post


Link to post
Share on other sites

Thanks for the fast reply! Btw, lineageOS 13 is working great on the open c. Actually, why did this never become an officially supported device?

Share this post


Link to post
Share on other sites
On 2/20/2017 at 11:07 PM, drake763 said:

Thanks for the fast reply! Btw, lineageOS 13 is working great on the open c. Actually, why did this never become an officially supported device?

There's no technical reason. Everything is working fine enough and I'm sure there's worse official ports. There's just nothing in it for me that would justify all the extra work (writing wikis etc).

Edited by KonstaT

Share this post


Link to post
Share on other sites

Hi!

Testing LineageOS 14.1, and it works very well!!!

 

Tried LineageOS 13, and ran into problems!

When I format system and data, do I have to mount these partitions before formatting? Did that on 14.1 and all vent well.

 

Can I enable "large icons" for this rom? It does not work on my phone. It would be great for us "senior citicens"!! :-) :-)

I've tested to get USB OTG enabled. Is it possible on the Open C?

Thanks for the work you are making on this device/webbe!

Share this post


Link to post
Share on other sites
On 06/01/2017 at 11:16 PM, elbilly007 said:

hello i have a zte zmax z970 this custom rom will work in my phone?

http://www.gsmarena.com/zte_zmax-6697.php

 

4 hours ago, TripleA1 said:

Will it work with the n9518??

 

I hope someone answers… 

Guys can't you do something at urself? Even check basic compatibility between phones?

z970 has other cpu and soc, so it will not work

I can't find n9518 at gsmarena

On 03/29/2017 at 7:22 PM, webbe said:

Hi!

Testing LineageOS 14.1, and it works very well!!!

 

Tried LineageOS 13, and ran into problems!

When I format system and data, do I have to mount these partitions before formatting? Did that on 14.1 and all vent well.

 

Can I enable "large icons" for this rom? It does not work on my phone. It would be great for us "senior citicens"!! :-) :-)

I've tested to get USB OTG enabled. Is it possible on the Open C?

Thanks for the work you are making on this device/webbe!

OTG is not supported with kernel (so will not work with this rom) and probably by hardware

Share this post


Link to post
Share on other sites

Installed this and phone is pretty much useless. You can hardly even answer incoming call when it lags so much or do anything else for that matter. After a whilke it started rebooting in every 5mins or so. Probably overheating? after few resets i managed to keep it on if i don't log in to my google account. 

Tried to fall back to original Kitkat Android, but it didn't install from the bootloader. Says its corrupt, but it's not.

Share this post


Link to post
Share on other sites
12 hours ago, selectamatic said:

Installed this and phone is pretty much useless. You can hardly even answer incoming call when it lags so much or do anything else for that matter. After a whilke it started rebooting in every 5mins or so. Probably overheating? after few resets i managed to keep it on if i don't log in to my google account. 

Tried to fall back to original Kitkat Android, but it didn't install from the bootloader. Says its corrupt, but it's not.

I use it since some month without issue now. Maybe you don't factory reset the phone (and wipe data).

Share this post


Link to post
Share on other sites

Hei Konsta,i would like applause to your project LineageOS13 & LineageOS14 to this device ZTEKiss3V811w. And i'm using on LineageOS13 so long time more than 7month. Then sometimes,i get bad news :( I do not know why my IMEI phone has been lost. Network is lost too,and i'm try to get back my IMEI via TerminalEmulator on PlayStore. Now my phone can only using just WiFi connection. So tired,it can't too. The app say my IMEI not found when i'm trying to enter some steps to this app. Please help me Konsta or you guys. Very stuck on it,ASAP your answer is your mine. Thx before

IMG_20171007_120455.jpg

Edited by Junior Anwar
Add images

Share this post


Link to post
Share on other sites

First of all, thank you for your great work porting CM/LineageOS to the OpenC!
I've been using your builds for more than a year now, and I managed to compile a new version, with latest LineageOS upstream code. As far as I tested, everything is working fine. Can I post a download link here?

Share this post


Link to post
Share on other sites

Hi, am97, Konsta as far as I am aware no longer replies to posts on these forums from a posting I saw of his a couple of months ago on this forum. You can contact him ethier on Konstakang.com (Click on above post above yours by duttyend to take you to his new website or contact him via his Twitter account, if he is ok for you post a download link here. Although it would be easier to create a new thread here on the zte forums and post your download here. It would be great if you can share your latest version you have created here on these forums as I still have this phone. Hope this helps.

Regards Alchess

 

Share this post


Link to post
Share on other sites

I contacted him and he said no problem, so here is my last tested build! (20180218)
https://cloud.utc.fr/index.php/s/esCfNqYPBoFaZ1F
md5: 00b3f67f16d5f87622e02f8855b0f19d

You can flash it on top of KonstaT's build, but I recommend to erase all and do a clean install, and don't forget to make a backup!

I did not made any modifications, I just built it using a fresh Ubuntu 16.04 installation. If you want to build it yourself, I made a compilation from various guides with the exact commands that I used: https://gitlab.utc.fr/amaldona/lineageos13-openC-build-guide/wikis/home

I'll post a new build every month or so, keep tuned!

  • Upvote 1

Share this post


Link to post
Share on other sites

Great news ! Will you be able to look at Android Go edition (8.1) ? It's a special taste for low cost mobile. Thanks.

Share this post


Link to post
Share on other sites
On 20.2.2018 at 1:05 AM, am97 said:

I contacted him and he said no problem, so here is my last tested build! (20180218)
https://cloud.utc.fr/index.php/s/esCfNqYPBoFaZ1F
md5: 00b3f67f16d5f87622e02f8855b0f19d

You can flash it on top of KonstaT's build, but I recommend to erase all and do a clean install, and don't forget to make a backup!

I did not made any modifications, I just built it using a fresh Ubuntu 16.04 installation. If you want to build it yourself, I made a compilation from various guides with the exact commands that I used: https://gitlab.utc.fr/amaldona/lineageos13-openC-build-guide/wikis/home

I'll post a new build every month or so, keep tuned!

Working so far pretty well

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.