Jump to content
wojtek3798

Coolpad f1 bricked miui

Recommended Posts

Hello everyone,

So I tried to flash my Coolpad f1 with some miui rom. After the installation my phone is bricked.

I have black screen and cant turn it on. I tried to bring it back to live so I did a tutorial and install all drivers on my pc.
In my system Coolpad is seen as MTK USB PRELOADER and DA VCOM.

Yesterday I flashed it with sp flash tools and it showed me green bar so it should be working but it does not.
Phone is not turning on and I'm out of ideas. 

I can attach every screenshots you need I just need your ideas what to do with it.

Any help will be appreciated
Cheers 

Share this post


Link to post
Share on other sites

Strange choice to flash stock rom with SP flash tool???

Why don't you use YGDP or CDA - official Coolpad flashing tools.

 

Share this post


Link to post
Share on other sites

I have just tried flash it with YGDP and that's what i got:

Any ideas?

21:39:49  CELL0: Software Version:  Assembly - <V3.83Beta_140509_12>

21:39:49  CELL0: Cell 0 USB address is: com10

21:39:49  CELL0: Start Download.

21:39:49  CELL0: Download Started...

21:39:49  CELL0: Downloading CPB:

21:39:49  CELL0: Init Connect Arg.

21:39:49  CELL0: Downlaod DA Start.

21:39:53  CELL0: Downlaod DA Success.

21:39:53  CELL0: This CPB for the Phone don't support Check CID.

21:39:53  CELL0: Verify is Partition be Changed.

21:39:53  CELL0: Partition is not Changed.

21:39:53  CELL0: Get Usb Status Success.

21:39:53  CELL0: Init Backup YLParames Failed.

21:39:53  CELL0: ERROR:1037

21:39:53  CELL0: DisConnect.

21:40:13  CELL0: Total download time elapsed: 0 min : 24 sec

21:40:13  CELL0: Downloading CPB: Failed!



Share this post


Link to post
Share on other sites

I have identical issue. I've tried 2 different rom with scatter file on SP Tool (it ends ok but phone can't be on) and 2 different rom in .cpb on YGDP (it goes to 50% in 1 second and give the same error like above in wojtek3798 post) Could someone help?

P.S. Maybe someone has link to original chineese rom for Coolpad F1 8297W?

 

Share this post


Link to post
Share on other sites

Unfortunately my phone is still dead :(
I tried many different roms and many different version on SP Flash Tool and still the same. Flashing ends with succes (green mark) but phone still didnt turn on.

 

Share this post


Link to post
Share on other sites

I also tried everything i have found. Only SP flashtools can instal rom (i tried many roms) it ends by green circle on the and, but still phone don't turn on and don't charge (when i connect to charger, usb current tester showing couple of minutes current 0,25A and after that it is 0,00A).

Share this post


Link to post
Share on other sites

I lost faith to be honest. I read that the problem was sd formatted in a different format (when miui was being installed) and now it wont boot becaus of that but im not sure..

Share this post


Link to post
Share on other sites

Did you guys try this instruction:

I will check this today and post results

 

So try first with:

1. Installing ADB client on PC & ADB drivers (you can find many instructions for that), then:

Quote

adb shell

Next commands in recovery shell (inside connected ADB shell):

Quote

ls -l /[email protected]

to ensure that it's symlink to /dev/block/mmcblk0p9.

You should get output like:

Quote

[email protected]:/ # ls -l/[email protected]
lrwxrwxrwx root     root              1970-01-01 01:00 [email protected] -> /dev/block/mmcblk0p9

(prompt can differ, depends on recovery which you'll use)

Next try to recreate EXT4 filesystem on it with bad blocks check:

Quote

mke2fs -cc -t ext4 /dev/block/mmcblk0p9

If you'll get no errors then you can try to mount it:

Quote

mount -t ext4 /[email protected] /cache

If still no problems then, unmount it, sync & reboot phone:

Quote

umount /cache

sync

reboot

You should have now working /cache partition.

& next time reflashing ROMs you should try to avoid formating /cache (erase its content instead) as most likely next formating of this partition via recovery might use also bad blocks.

 

It's just quick & dirty instruction written ad-hoc, based on my general UNIX & embedded devices experience, tried to be as simple as it could and I haven't checked if it works on any recoveries on F1.

At least going carefully through these steps it shouldn't break anything as in yours case  /cache is already corrupted and needs to be cleaned anyway, just ensure that symlink above is correct & don't make any typo.

 

Other things that you may try if above wont help:

1. Make current filesystem check & repair:

Quote

e2fsck -y -c -f -v /dev/block/mmcblk0p9

This should do automated check forcing all answers for "yes" for any fix proposals, with bad blocks check, forcing even if fs is marked as clean & higher verbosity of log output.

2. (as alternative) Erase all /cache partition area and try to format it again via recovery option:

Quote

dd if=/dev/zero bs=4096 of=/dev/block/mmcblk0p9

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.