Jump to content
Sign in to follow this  
xzyk

Double tap to wake..

Recommended Posts

I've been enjoying my 5c but really miss the double tap to wake function (plus it probably doesn't help the longevity of the power button), so looking for some solution I found this on xda http://forum.xda-developers.com/mate-8/general/enable-double-tap-to-wake-t3312676 ,

It's for a Huawei Mate8 but I've checked the relevant build.prop and xml file and the entries are both there but disabled. Problem I have now is I don't want to root device for the time being, is there anyway I can get temp root, without BL unlock, of perhaps do this via adb and usb debuggin 'on' ?  The changes are pretty easy and minor so if someone has root on their 5c perhaps they can try it and report back. Appreciate this may also be locked/missing in the kernel but we won't know until we try, right ?

Hoping someone can reply so we can make this a better device.

I've reprodued the procedure below in case URL link doesn't work.

1) Go into system/build.prop and open it in your favorite text editor. Find the line that says ro.config.hw_easywakeup=false and change the false to true then save your changes.
2) Go to system/emui/base/xml and open up the hw_easywakeupmotion_config.xml in your favorite text editor. Find the line that says <EasyWakeupMotion name="Double_Touch" support="1" value="0" flag="0" keycode="131" /> and change the value=0 to value=1 then save your changes.
3) Restart your phone
4) Go into Settings/Smart Assistance/Motion Control and at the bottom you will now see Double Touch. Turn it on.
5) Restart your phone and you will have Double Tap to Wake enabled and working.

Share this post


Link to post
Share on other sites

Hi zyyzk

I have Modaco R1 Rom installed, bootunlocked, twrp rooted Honor 5C.

I edited the 2 files you mentioned successfully, restarted,but it doesn't active Double Tap to Wake on my 5C.

Share this post


Link to post
Share on other sites

Hey

Yeah same here. on the Chinese model nem-ul10. changed the lines and have the option in setting, but it fails to wake

Paul

 

Share this post


Link to post
Share on other sites

Thanks for trying guys, guess kernel doesn't support it..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.