Jump to content
KonstaT

[DEV][ROM][28.1.] CyanogenMod 12.1 (Android 5.1.1) for Chuwi Vi10 Plus, Hi10 Plus, Hi10 Pro, Hibook, Hibook Pro & Hi12

Recommended Posts

22 minutes ago, KonstaT said:

Hibook Pro uses the stock kernel (no kernel source available) so there's not going to be any difference to stock.

 You said that Jide gave you the link for the kernel source but it wasn't there. Did they finally post it?

Share this post


Link to post
Share on other sites
15 minutes ago, benkores said:

 You said that Jide gave you the link for the kernel source but it wasn't there. Did they finally post it?

No. Pester Chuwi or Jide about this matter - not me.

Edited by KonstaT

Share this post


Link to post
Share on other sites

@KonstaT

All right thanks. Sorry if I was pestering you by the way :)  I'll try emailing Jide myself since Chuwi is definitely not going to reply. But regardless great work on this ROM! Really appreciate it.

Edited by benkores
  • Upvote 1

Share this post


Link to post
Share on other sites
44 minutes ago, KonstaT said:

Wow, I'm not sure if that's stupid or genius. :P Well done!

I've heard people building CM on Atom netbooks and build time is well over 24h. I'm surprised it was anything less than that. Even my setup with (rather old) core i5 and 8gb of RAM struggles with building recent Android versions (clean build takes hour or two mostly depending on CCACHE hits).

Poky toolchain I've included in the manifest is exactly the same as linked in the kernel build env. Don't know what could be the problem with that. What error did you get?

Well it was the first I used the tablet for anything useful really:) The impressive thing was that the tablet got only slightly warm, heat is much worse after 5 minutes of 3d gaming. A 1.5W charger was enough to keep it charged comfortably so I don't think I wasted much energy:). My 7200 rpm USB hdd was powered externally.

Poky: the error was something like "file not found" when launching g++ although it was there. But I will check again.

Share this post


Link to post
Share on other sites
7 hours ago, zltnngy said:

Well it was the first I used the tablet for anything useful really:) The impressive thing was that the tablet got only slightly warm, heat is much worse after 5 minutes of 3d gaming. A 1.5W charger was enough to keep it charged comfortably so I don't think I wasted much energy:). My 7200 rpm USB hdd was powered externally.

Poky: the error was something like "file not found" when launching g++ although it was there. But I will check again.

Poky:

Ldd gives different output for the two versions....

 

Screenshot_2017-01-11-23-51-27.png

  • Upvote 1

Share this post


Link to post
Share on other sites
15 hours ago, zltnngy said:

Poky:

Ldd gives different output for the two versions....

Well, that explains it as it links to my home directory where I had installed poky (/home/tuomas/android/poky/1.8/). Fun times.

Edited by KonstaT

Share this post


Link to post
Share on other sites

Does anyone else have problems with Skype and Viber. Both of them are not connecting. I tried few different WiFi networks from different providers, changed my DNS and few other things but skype keeps saying "No internet connection". Can someone please help me figure what is going on. Thanks.

Share this post


Link to post
Share on other sites
40 minutes ago, slavov82 said:

Does anyone else have problems with Skype and Viber. Both of them are not connecting. I tried few different WiFi networks from different providers, changed my DNS and few other things but skype keeps saying "No internet connection". Can someone please help me figure what is going on. Thanks.

Why are you not using CM 13?

Share this post


Link to post
Share on other sites
7 hours ago, slavov82 said:

Does anyone else have problems with Skype and Viber. Both of them are not connecting. I tried few different WiFi networks from different providers, changed my DNS and few other things but skype keeps saying "No internet connection". Can someone please help me figure what is going on. Thanks.

Skype wouldn't let me sign in with Outlook account but signed in OK with Skype name. It does say no internet connection at bottom so messaging was disabled but VOIP is working when I make a voice call. I think it's just Skype app expecting a 3g mobile device. 

Share this post


Link to post
Share on other sites

For me it is similar. I connected with Skype name. VoIP is working but it displays "no internet connection". Chat is working too but it was not possible to receive pictures as jpg.

Edited by Migual12

Share this post


Link to post
Share on other sites
6 hours ago, tipo0011 said:

When will audio through HDMI bug be fixed? This Rom could be the best alternative to stock Rom if it had been fixed.

KonstaT doesn't own a bluetooth speaker. If you donate one I'm sure this problem could be fixed quickly. Eg. this one (http://www.gearbest.com/speakers/pp_240958.html?wid=21). Doesn't cost a fortune ($6.99/ €6.33). 

 

Share this post


Link to post
Share on other sites
9 hours ago, tipo0011 said:

When will audio through HDMI bug be fixed? This Rom could be the best alternative to stock Rom if it had been fixed.

Everything posted here is open source. Feel free to fix it anytime you want.

No ETAs as always!

2 hours ago, PalmTrees said:

KonstaT doesn't own a bluetooth speaker. If you donate one I'm sure this problem could be fixed quickly. Eg. this one (http://www.gearbest.com/speakers/pp_240958.html?wid=21). Doesn't cost a fortune ($6.99/ €6.33). 

HDMI != bluetooth ;)

Edited by KonstaT

Share this post


Link to post
Share on other sites
8 minutes ago, KonstaT said:

Everything posted here is open source. Feel free to fix it anytime you want.

No ETAs as always!

HDMI != bluetooth ;)

Haha, my bad. It was early in the morning when I wrote that :D

Share this post


Link to post
Share on other sites

Bluetooth audio is perfect with my Ausdom M05 headphones. Also casting video with Chromecast is fine. I haven't tried a direct cable as I don't have one with a micro HDMI.

Share this post


Link to post
Share on other sites
1 hour ago, KonstaT said:

Everything posted here is open source. Feel free to fix it anytime you want.

No ETAs as always!

HDMI != bluetooth ;)

Thanks, only hope that will be fixed in the future, because I'm not a programmer and I don't know how to fix that.

Share this post


Link to post
Share on other sites
16 hours ago, Chuwi Hi12 said:

 

Edited by Migual12
deleted

Share this post


Link to post
Share on other sites
On 13/1/2017 at 8:25 PM, Migual12 said:

For me it is similar. I connected with Skype name. VoIP is working but it displays "no internet connection". Chat is working too but it was not possible to receive pictures as jpg.

Try downloading an older .apk of Skype. Then update via Play Store. This has worked before for apps not working. 

  • Upvote 1

Share this post


Link to post
Share on other sites
26 minutes ago, rodrimx4 said:

Help, how can i fix this problem when i try to install

Why are you flashing CM 12.1 instead of 13.1? 

Share this post


Link to post
Share on other sites
Why are you flashing CM 12.1 instead of 13.1? 

I had installed without problem several times but today o dont now what happened (Cm12.1) I read that it is a bug with the updater script but I do not understand why other times it did not happen

Share this post


Link to post
Share on other sites
3 hours ago, rodrimx4 said:

Help, how can i fix this problem when i try to install

Most likely a corrupted file. There's md5 checksums for a reason.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.