Jump to content
KonstaT

[DEV][ROM][28.1.] CyanogenMod 12.1 (Android 5.1.1) for Chuwi Vi10 Plus, Hi10 Plus, Hi10 Pro, Hibook, Hibook Pro & Hi12

Recommended Posts

sd card reader has become a problem - system starts slowing down and freezes time to time. In the end becomes card is unreadable in tablet - constantly checking errors - but in PC ok . For two months it worked ok but now it corrups every card I put in to it. I've asked chuwi service to send new bios but no aswers yet (Z8350 version). SD-card doesn't show-up in windows side at all - device manager error.

 

Share this post


Link to post
Share on other sites
On 10.1.2017 at 10:16 PM, rodrimx4 said:

Thanks for the links ! I try in hi10 pro emoji106.png

Does it work on hi10? On Hi 12 without problems 

Share this post


Link to post
Share on other sites

Kon- I went to use my hi10 pro and am only able to boot into the bios.  In don't see this as a known issue. Any ideas on how to fix it or if my emmc drive may have died?

 

Any suggestions would be great.

 

Thanks

Rich

Share this post


Link to post
Share on other sites
17 hours ago, Richtj999 said:

Kon- I went to use my hi10 pro and am only able to boot into the bios.  In don't see this as a known issue. Any ideas on how to fix it or if my emmc drive may have died?

 

Any suggestions would be great.

 

Thanks

Rich

I actually had the same thing to the Hi10 Pro I had for a while, but was able to get Amazon to let me return it even though it was outside of their 30 day return window. After careful consideration, and a lack of options for a similar setup under a different brand, I got the Hi10 Plus. It's been over three months, I think, and the internal storage is still working, but the SD card reader has been wacky. It'll read the card, but only after removing and reinserting it, sometimes only after several attempts. I get an error in Windows in the card reader properties, and have never been able to get the card to work while on that side, but I don't really have a need for the card there anyway. I was able to find an app that disables deep sleep while in Android, so at least the card will stay mounted there, plus if you're booting from Windows into Android, it the card automatically loads like it's supposed to. The only downside to the app is it does drain your battery a little faster, but not by much, I think. I mentioned the app a few posts back, but it's called Wake Lock - Power Manager. Depending on the battery app you use, you'll see different use statistics, such as in GSam Battery Monitor shows 25.2% battery is being used, but the built-in battery monitor in Android only shows 2%. In either case, it's worth it, at least for me. If you want to use the app, I would recommend turning off Wi-Fi, Bluetooth, and Location if you're not going to be using the tablet for a while to make the battery last longer. You can also install another app called SD Card Monitor, it gives you all kinds of information on your card such as when it was mounted, unmounted, force unmounted, and many other little bits of info. Oh, and I did try flashing the recommended BIOS from Chuwi in the hopes of resolving the issue, but it didn't do squat (no big surprise there). Since I got my Hi10 Plus from Amazon, and chatted up a rep there about my problem with the reader, they said I could still return the device even though it was outside the normal return window, but that was a few weeks ago, so I'm not sure if I can still do it if I wanted to. If I could find another tablet with the same features, I'd be all over it, assuming I could get it for about the same price.

Share this post


Link to post
Share on other sites

Thank you for the advice - I also bought from Amazon & they are letting me return it (7 months old) - I did buy with an Amex so I have a 1 year "amex" warranty but figured I would start with Amazon.

 

Only question I would have is if my data is actually gone.  I put a Windows 7 USB install stick which boots on all other PC's & this unit just boot loops back into bios no matter what setting i use.  When booting to EFI mode it says not found - something is off.  

 

Any ideas if the Hi10 Plus will work with the Hi10 Pro keyboard?  I also wish there was something else with the 10" form factor.  I do IT work for a living so this little guy is great for troubleshooting (windows side) with a usb nic, then playing in android in other times.  Wish it had a SSD though.  

 

Share this post


Link to post
Share on other sites
19 hours ago, Richtj999 said:

Thank you for the advice - I also bought from Amazon & they are letting me return it (7 months old) - I did buy with an Amex so I have a 1 year "amex" warranty but figured I would start with Amazon.

 

Only question I would have is if my data is actually gone.  I put a Windows 7 USB install stick which boots on all other PC's & this unit just boot loops back into bios no matter what setting i use.  When booting to EFI mode it says not found - something is off.  

 

Any ideas if the Hi10 Plus will work with the Hi10 Pro keyboard?  I also wish there was something else with the 10" form factor.  I do IT work for a living so this little guy is great for troubleshooting (windows side) with a usb nic, then playing in android in other times.  Wish it had a SSD though.  

 

I think there are other options out there, but not on Amazon. If Windows and Android aren't showing as available boot options in BIOS, then I'm afraid the data you had on those partitions is gone (believe me, I tried like crazy to get mine to work again. As for the keyboard, it'll only work for the Hi10 Pro.

Share this post


Link to post
Share on other sites
9 hours ago, Android4Life said:

I think there are other options out there, but not on Amazon. If Windows and Android aren't showing as available boot options in BIOS, then I'm afraid the data you had on those partitions is gone (believe me, I tried like crazy to get mine to work again. As for the keyboard, it'll only work for the Hi10 Pro.

I think I found a nice alternative to the Chuwi Hi10 Plus/Pro. It's the Cube iwork10 Ultimate. It's laid pretty much just like the Hi10 Pro with the same amount of RAM, storage, and dual boot setup, plus it comes with the keyboard at the same price as the Hi10 Plus on Amazon for $199, or $179 if you don't want the keyboard. Unlike the Hi10 Plus or Pro, it doesn't have USB type C, but it does have a full size USB 3, micro USB 2, micro HDMI, and it can support SD cards up 128 megs. Other differences are the res is the same as the Hi10 Pro, and both speakers are on the right side of the tablet. The body is mostly, if not all, plastic, so it may not dissipate heat as efficiently as the Chuwi. Since I don't really need my SD card in Windows, and I do like the fact the speakers on my current Hi10 Plus are on opposite sides, I may not try to return the tablet after all, especially since I have that Wake Lock app installed. On the bright side, we at least have another option, if you don't mind having both speakers on the same side, that is.

I almost forgot to include the link for where you can get the Cube iwork10 Ultimate on Amazon: https://www.amazon.com/ALLDOCUBE-iwork10-Ultimate-Convertible-Android/dp/B06XD9DPP2/ref=pd_sbs_147_7?_encoding=UTF8&pd_rd_i=B06XD9DPP2&pd_rd_r=DQ81KHT4D2KP60K50AYR&pd_rd_w=8NxxK&pd_rd_wg=Il858&psc=1&refRID=DQ81KHT4D2KP60K50AYR

Edited by Android4Life

Share this post


Link to post
Share on other sites

As of today, I am no longer the owner of a Chuwi Hi10 Plus tablet. I decided to cut it loose and returned it earlier today after buying an AllDoCube iwork10 Ultimate 2-in-1 on Amazon yesterday. Same configuration as the Hi10 Plus, but with a 10.1" screen and both speakers on the right side of the device. It comes with the keyboard for $199, and so far the reviews for it are looking pretty decent. There're only four so far, but it's just shy of a full five stars. One buyer said the speakers are a little on the quiet side, and another said they sound pretty good, so I guess I'll find out when I get it tomorrow, the anticipation of which is killing me, by the way. Anyway, I just couldn't take the the SD card thing anymore, even though I installed an app that prevents deep sleep. I know it's a long shot, but if anyone here knows of any good forums for the tablet I bought, it'd be appreciated. Thanks in advance.

Share this post


Link to post
Share on other sites
On 5/2/2017 at 9:17 PM, Tizoreol said:

hey KonstaT i am very satisfied with this rom but i have only one question i would like to know if it's possible to make the ethernet through usb adaptator to work cause it's working on windows and not on android thank you again for your great contribution!! 

On 5/2/2017 at 10:48 PM, KonstaT said:

I'll check if I can get one cheap from eBay/China.

It shouldn't make any difference which USB port you're using.

Received my adapter a while back but didn't test it until today. Seems it 'just works™'. Tested it with CM13 but I don't see any reason why it wouldn't work with CM12.1 as well.

[495540.657501] usb 1-2: new full-speed USB device number 5 using xhci_hcd
[495540.825339] usb 1-2: device v0fe6 p9700 is not supported
[495540.831451] usb 1-2: New USB device found, idVendor=0fe6, idProduct=9700
[495540.831473] usb 1-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[495540.831491] usb 1-2: Product: USB 2.0 10/100M Ethernet Adaptor
[495540.856213] dm9601 1-2:1.0 eth0: register 'dm9601' at usb-0000:00:14.0-2, Davicom DM96xx USB 10/100 Ethernet, 00:e0:4c:53:44:58
[495540.856346] xhci_hcd 0000:00:14.0: udev[1-2]: Check if need unblock ssic runtime, portnum[2] ssic_runtime_blocked[0]
[495540.922785] dm9601 1-2:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xFFFF
[495540.982264] init: Starting service 'dhcpcd_eth0'...
[495541.382044] chn:SYSTEMP0 adc val:2c0
[495541.383552] chn:SYSTEMP0 conv adc val:2c0
[495541.401016] chn:SYSTEMP0 adc val:2c0
[495541.402534] chn:SYSTEMP0 conv adc val:2c0
[495541.656689] iTCO_wdt: iTCO_wdt_ping
[495542.640240] dm9601 1-2:1.0 eth0: kevent 4 may have been dropped
[495542.650667] dm9601 1-2:1.0 eth0: kevent 4 may have been dropped
[495542.658333] dm9601 1-2:1.0 eth0: kevent 4 may have been dropped
[495542.669230] dm9601 1-2:1.0 eth0: kevent 4 may have been dropped
[495542.700502] dm9601 1-2:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xFFFF
[495542.796177] dm9601 1-2:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xFFFF
07-07 11:27:36.161  2877  3011 D UsbHostManager: Added device UsbDevice[mName=/dev/bus/usb/001/006,mVendorId=4070,mProductId=38656,mClass=0,mSubclass=0,mProtocol=0,mManufacturerName=null,mProductName=USB 2.0 10/100M Ethernet Adaptor,mVersion=1.16,mSerialNumber=null,mConfigurations=[
07-07 11:27:36.161  2877  3011 D UsbHostManager: UsbConfiguration[mId=1,mName=null,mAttributes=160,mMaxPower=60,mInterfaces=[
07-07 11:27:36.161  2877  3011 D UsbHostManager: UsbInterface[mId=0,mAlternateSetting=0,mName=null,mClass=0,mSubclass=0,mProtocol=0,mEndpoints=[
07-07 11:27:36.161  2877  3011 D UsbHostManager: UsbEndpoint[mAddress=129,mAttributes=2,mMaxPacketSize=64,mInterval=0]
07-07 11:27:36.161  2877  3011 D UsbHostManager: UsbEndpoint[mAddress=2,mAttributes=2,mMaxPacketSize=64,mInterval=0]
07-07 11:27:36.161  2877  3011 D UsbHostManager: UsbEndpoint[mAddress=131,mAttributes=3,mMaxPacketSize=8,mInterval=1]]]]
07-07 11:27:36.187  2877  2893 D EthernetNetworkFactory: Started tracking interface eth0
07-07 11:27:36.193  2576  2875 D CommandListener: Setting iface cfg
07-07 11:27:36.193  2576  2875 D CommandListener: Trying to bring up eth0
07-07 11:27:36.307  2877  2893 D EthernetNetworkFactory: updateInterface: eth0 link down
07-07 11:27:36.308  2877  2893 D EthernetNetworkFactory: updateInterface: eth0 link up
07-07 11:27:36.311  2877  2893 D EthernetNetworkFactory: updateInterface: eth0 link down
07-07 11:27:36.313  2877  5261 I EthernetNetworkFactory: dhcpThread(eth0): mNetworkInfo=[type: Ethernet[], state: DISCONNECTED/DISCONNECTED, reason: (unspecified), extra: 00:e0:4c:53:44:58, roaming: false, failover: false, isAvailable: false]
07-07 11:27:36.338  5262  5262 E dhcpcd  : fopen `/system/etc/dhcpcd/dhcpcd.conf': No such file or directory
07-07 11:27:36.339  5262  5262 I dhcpcd  : version 5.5.6 starting
07-07 11:27:36.341  5262  5262 E dhcpcd  : fopen `/system/etc/dhcpcd/dhcpcd.conf': No such file or directory
07-07 11:27:36.342  5262  5262 E dhcpcd  : get_duid: Read-only file system
07-07 11:27:36.370  5262  5262 I dhcpcd  : eth0: rebinding lease of 192.168.0.103
07-07 11:27:38.009  2877  2893 D EthernetNetworkFactory: updateInterface: eth0 link up
07-07 11:27:38.010  2877  5283 I EthernetNetworkFactory: dhcpThread(eth0): mNetworkInfo=[type: Ethernet[], state: CONNECTING/OBTAINING_IPADDR, reason: (unspecified), extra: 00:e0:4c:53:44:58, roaming: false, failover: false, isAvailable: true]
07-07 11:27:39.683  5262  5262 I dhcpcd  : eth0: acknowledged 192.168.0.103 from 192.168.0.1
07-07 11:27:39.699  5262  5262 I dhcpcd  : eth0: leased 192.168.0.103 for 7200 seconds
07-07 11:27:39.924  2877  5261 D ConnectivityService: registerNetworkAgent NetworkAgentInfo{ ni{[type: Ethernet[], state: CONNECTED/CONNECTED, reason: (unspecified), extra: 00:e0:4c:53:44:58, roaming: false, failover: false, isAvailable: true]}  network{111}  lp{{InterfaceName: eth0 LinkAddresses: [192.168.0.103/24,]  Routes: [192.168.0.0/24 -> 0.0.0.0 eth0,0.0.0.0/0 -> 192.168.0.1 eth0,] DnsAddresses: [192.168.0.1,] Domains:  MTU: 0 TcpBufferSizes: 524288,1048576,3145728,524288,1048576,2097152}}  nc{[ Transports: ETHERNET Capabilities: INTERNET&NOT_RESTRICTED&TRUSTED&NOT_VPN LinkUpBandwidth>=100000Kbps LinkDnBandwidth>=100000Kbps]}  Score{30}  everValidated{false}  lastValidated{false}  created{false} lingering{false} explicitlySelected{false} acceptUnvalidated{false} everCaptivePortalDetected{false} lastCaptivePortalDetected{false} }
07-07 11:27:39.925  2877  2973 D ConnectivityService: NetworkAgentInfo [Ethernet () - 111] EVENT_NETWORK_INFO_CHANGED, going from null to CONNECTED
07-07 11:27:39.925  2877  2973 D ConnectivityService: Adding iface eth0 to network 111
07-07 11:27:39.944  2877  2973 E ConnectivityService: Unexpected mtu value: 0, eth0
07-07 11:27:39.944  2877  2973 D ConnectivityService: Adding Route [192.168.0.0/24 -> 0.0.0.0 eth0] to network 111
07-07 11:27:39.945  2877  2973 D ConnectivityService: Adding Route [0.0.0.0/0 -> 192.168.0.1 eth0] to network 111
07-07 11:27:39.946  2877  2973 D ConnectivityService: Setting Dns servers for network 111 to [/192.168.0.1]
07-07 11:27:39.954  2877  2973 D ConnectivityService: notifyType IP_CHANGED for NetworkAgentInfo [Ethernet () - 111]
07-07 11:27:39.959  2877  2973 D ConnectivityService: scheduleUnvalidatedPrompt 111
07-07 11:27:39.959  2877  2973 D ConnectivityService: updateSignalStrengthThresholds: CONNECT, sending [] to NetworkAgentInfo [Ethernet () - 111]
07-07 11:27:39.960  2877  2973 D ConnectivityService: rematch for NetworkAgentInfo [Ethernet () - 111]
07-07 11:27:39.960  2877  2973 D ConnectivityService:    accepting network in place of null
07-07 11:27:39.960  2877  2973 D ConnectivityService: Switching to new default network: NetworkAgentInfo{ ni{[type: Ethernet[], state: CONNECTED/CONNECTED, reason: (unspecified), extra: 00:e0:4c:53:44:58, roaming: false, failover: false, isAvailable: true]}  network{111}  lp{{InterfaceName: eth0 LinkAddresses: [192.168.0.103/24,]  Routes: [192.168.0.0/24 -> 0.0.0.0 eth0,0.0.0.0/0 -> 192.168.0.1 eth0,] DnsAddresses: [192.168.0.1,] Domains:  MTU: 0 TcpBufferSizes: 524288,1048576,3145728,524288,1048576,2097152}}  nc{[ Transports: ETHERNET Capabilities: INTERNET&NOT_RESTRICTED&TRUSTED&NOT_VPN LinkUpBandwidth>=100000Kbps LinkDnBandwidth>=100000Kbps]}  Score{30}  everValidated{false}  lastValidated{false}  created{true} lingering{false} explicitlySelected{false} acceptUnvalidated{false} everCaptivePortalDetected{false} lastCaptivePortalDetected{false} }
07-07 11:27:39.968  2877  2973 D CSLegacyTypeTracker: Sending CONNECTED broadcast for type 9 NetworkAgentInfo [Ethernet () - 111] isDefaultNetwork=true
07-07 11:27:39.968  2877  2973 D ConnectivityService: sendStickyBroadcast: action=android.net.conn.CONNECTIVITY_CHANGE
07-07 11:27:39.969  2877  2973 D ConnectivityService: notifyType PRECHECK for NetworkAgentInfo [Ethernet () - 111]
07-07 11:27:39.969  2877  2895 D Tethering: MasterInitialState.processMessage what=3
07-07 11:27:39.974 17591 17591 D NetworkChangeNotifierAutoDetect: Network connectivity changed, type is: 1
07-07 11:27:39.981 17325 17325 D NetworkChangeNotifierAutoDetect: Network connectivity changed, type is: 1
07-07 11:27:39.987 17325 17325 D NetworkChangeNotifierAutoDetect: Network connectivity changed, type is: 1
07-07 11:27:40.014  2877  5283 E EthernetNetworkFactory: Already have a NetworkAgent - aborting new request
07-07 11:27:40.030  4266  4266 D WeatherUpdateService: onCreate
07-07 11:27:40.033  4266  4266 D WeatherUpdateService: Service started, but shouldn't update ... stopping
07-07 11:27:40.043  4266  4266 D WeatherUpdateService: onDestroy
07-07 11:27:40.049  4167  4167 I iu.Environment: update connectivity state; isNetworkMetered? false, isRoaming? false, isBackgroundDataAllowed? true*
07-07 11:27:40.054  2877  5306 D NetworkMonitor/NetworkAgentInfo [Ethernet () - 111]: Checking http://connectivitycheck.gstatic.com/generate_204 on 00:e0:4c:53:44:58, connectivitycheck.gstatic.com=172.217.22.163,2a00:1450:400f:804::2003
07-07 11:27:40.056  4167  4265 I iu.UploadsManager: num queued entries: 0
07-07 11:27:40.057  2877  5306 W System  : ClassLoader referenced unknown path: /system/framework/tcmclient.jar
07-07 11:27:40.057  4167  4265 I iu.UploadsManager: num updated entries: 0
07-07 11:27:40.059  4167  4265 I iu.SyncManager: NEXT; no task
07-07 11:27:40.173  2877  5306 D NetworkMonitor/NetworkAgentInfo [Ethernet () - 111]: isCaptivePortal: ret=204 headers={null=[HTTP/1.1 204 No Content], Content-Length=[0], Date=[Fri, 07 Jul 2017 08:27:40 GMT], X-Android-Received-Millis=[1499416060172], X-Android-Response-Source=[NETWORK 204], X-Android-Selected-Protocol=[http/1.1], X-Android-Sent-Millis=[1499416060122]}
07-07 11:27:40.173  2877  2973 D ConnectivityService: setProvNotificationVisibleIntent null visible=false networkType=MOBILE extraInfo=null highPriority=false
07-07 11:27:40.173  2877  2973 D ConnectivityService: NetworkAgentInfo [Ethernet () - 111] validation  passed
07-07 11:27:40.173  2877  2973 D ConnectivityService: notifyType CAP_CHANGED for NetworkAgentInfo [Ethernet () - 111]
07-07 11:27:40.183  2877  2973 D ConnectivityService: sendStickyBroadcast: action=android.net.conn.INET_CONDITION_ACTION
07-07 11:27:40.409  3854  5317 I GCM     : Ack for not saved message 111
07-07 11:27:40.409  3854  5317 I GCM     : Ack for not saved message 112
07-07 11:27:40.409  3854  5317 I GCM     : Ack for not saved message 113
07-07 11:27:40.963  2877  2973 D ConnectivityService: NetTransition Wakelock (NetworkAgentInfo [Ethernet () - 110] cleared because we found a replacement network

 

Share this post


Link to post
Share on other sites
8 hours ago, Hi12Guy said:

Hi is it possible that you can Port Bliss ROM X86 to Chuwi Hi 12 (https://forum.xda-developers.com/android/software/x86-bliss-x86-pc-s-t3534657)

- Keyboard Working

- Touchscreen working

- Setup forcecloses so can't check sound

Greets

Anything Android-x86 based will never work properly so it's not worth any effort.

Edited by KonstaT

Share this post


Link to post
Share on other sites
2 hours ago, KonstaT said:

Anything Android-x86 based will never work properly so it's not worth any effort.

Was about to ask you about Bliss rom as well. Mainly due to this https://forum.xda-developers.com/showpost.php?p=72946005&postcount=576 

What are the obstacles to get it to work properly? (Sorry for always asking novice questions) :) 

Share this post


Link to post
Share on other sites
2 hours ago, PalmTrees said:

Was about to ask you about Bliss rom as well. Mainly due to this https://forum.xda-developers.com/showpost.php?p=72946005&postcount=576 

What are the obstacles to get it to work properly? (Sorry for always asking novice questions) :) 

It's already been discussed. Android-x86 is completely different animal and it targets completely different devices (PC's that don't have same performance/power limitations as mobile devices).

Intel provides hardware reference design and software BSP (board support package) for Cherry Trail tablets. BSP includes kernel, hardware binary drivers (https://github.com/CM-CHT/proprietary_vendor_intel), HALs, and other hw specific changes to Android framework. Intel has since killed Cherry Trail platform and doesn't provide BSP for Nougat. Android-x86 does't use any proprietary drivers and it e.g. uses open source MESA display driver. It's always going to lack full hardware support because of this.

Edited by KonstaT

Share this post


Link to post
Share on other sites

Has anyone read about any custom ROMs being created for the Cube iwork10 Ultimate? I know this isn't the right forum for it, but I've tried like crazy to find one dedicated to the Cube, and the best I could find so far was on xda-developers.com. The only ones there are modified versions of the stock ROM, and nothing else, except a MIUI custom that I'm not to interested in trying out. There's also a forum for it on teclast.com, but the only thing being worked on there is a Remix 2.0 port that hasn't been updated for a week. I realize this may be a crazy question, but what would the chances be on creating a port of either the CM 12.1 or Lineage 13 ROMs? The specs for the Cube iwork10 Ultimate are exactly the same as the Chuwi Hi10 Pro, aside from both speakers being on the right side of the tablet. Again, I know this may be a long shot, but I'm kind of starting to miss Lineage. Sorry if I put this in the wrong place.

Share this post


Link to post
Share on other sites
14 hours ago, Android4Life said:

Has anyone read about any custom ROMs being created for the Cube iwork10 Ultimate? I know this isn't the right forum for it, but I've tried like crazy to find one dedicated to the Cube, and the best I could find so far was on xda-developers.com. The only ones there are modified versions of the stock ROM, and nothing else, except a MIUI custom that I'm not to interested in trying out. There's also a forum for it on teclast.com, but the only thing being worked on there is a Remix 2.0 port that hasn't been updated for a week. I realize this may be a crazy question, but what would the chances be on creating a port of either the CM 12.1 or Lineage 13 ROMs? The specs for the Cube iwork10 Ultimate are exactly the same as the Chuwi Hi10 Pro, aside from both speakers being on the right side of the tablet. Again, I know this may be a long shot, but I'm kind of starting to miss Lineage. Sorry if I put this in the wrong place.

Yes, it's possible to build CM12.1 to practically any Cherry Trail device (CM13 needs kernel source to work properly). You just need to get the device to the hands of the right people...

Share this post


Link to post
Share on other sites
On 7/12/2017 at 7:55 PM, Android4Life said:

Has anyone read about any custom ROMs being created for the Cube iwork10 Ultimate? I know this isn't the right forum for it, but I've tried like crazy to find one dedicated to the Cube, and the best I could find so far was on xda-developers.com. The only ones there are modified versions of the stock ROM, and nothing else, except a MIUI custom that I'm not to interested in trying out. There's also a forum for it on teclast.com, but the only thing being worked on there is a Remix 2.0 port that hasn't been updated for a week. I realize this may be a crazy question, but what would the chances be on creating a port of either the CM 12.1 or Lineage 13 ROMs? The specs for the Cube iwork10 Ultimate are exactly the same as the Chuwi Hi10 Pro, aside from both speakers being on the right side of the tablet. Again, I know this may be a long shot, but I'm kind of starting to miss Lineage. Sorry if I put this in the wrong place.

I dug this up 3 weeks ago ;) 

On 6/25/2017 at 7:36 PM, PalmTrees said:

I don't know if this can help you in any way, but someone posted a Lineage OS 13 build for the iWork10 (http://bbs.51cube.com/forum.php?mod=viewthread&tid=308541&extra=page%3D1) and a Remix OS build as well (http://bbs.51cube.com/forum.php?mod=viewthread&tid=307920&extra=page%3D1). 

 

 

Share this post


Link to post
Share on other sites
8 hours ago, PalmTrees said:

I dug this up 3 weeks ago ;) 

 

Thanks for the links, but it's all in Chinese. I was able to translate using Chrome, but when trying to install the download client for the CM 13 build (since it's over 300 megs, the site makes you use a download manager provided by them), it is also in Chinese (obviously). I currently don't have a way to translate the text, but at least the scanners on my computer didn't find anything harmful, so I may look into it more if I can find a way to translate the text in the installer. I know I can just look up the translations, but I don't feel like putting to much effort into it right now. If you find any English sites for similar ROMs, feel free to post. Thanks again.

Share this post


Link to post
Share on other sites

Does any of the rom will work on Hi10 dual boot? I don't see it in the list but just in case, because it has identical hardware with hibook. Can anyone confirm this so I can flash my Hi10 dual boot?

THanks

Share this post


Link to post
Share on other sites
12 hours ago, nuu said:

Does any of the rom will work on Hi10 dual boot? I don't see it in the list but just in case, because it has identical hardware with hibook. Can anyone confirm this so I can flash my Hi10 dual boot?

THanks

This is not meant for Chuwi Hi10. It's a different device with different hardware.

Edited by KonstaT

Share this post


Link to post
Share on other sites

Still loving this tablet! Don't use it very often, but I photographed a wedding recently (10 hours and 64GB photos :o) and it was really great to transfer pictures my from my Fuji cameras wirelessly to the tab. I forgot how great the screen is and the bride and groom were very pleased to see some of their photos by the evening :)

Anyway, super job with this ROM, it works great!

Now...I've just accidentally ordered an Onda Xiaoma 21 laptop...oops! Was cheap though, and the 12.5" screen sounds great :)

Share this post


Link to post
Share on other sites

Yep, Remix is OK but I prefer normal Android - I just know where everything is!! CM13 ran fine apart from the slow wake from sleep issue which drove me a bit mad :D

  • Upvote 1

Share this post


Link to post
Share on other sites

First of all I totally erased the drive of my Hibook Pro to test Ubuntu but there are too many problems to fix so I decided to flash Android and I did it using the Intel Platform Flash Tool Lite for OSX

After my Chuwi went in recovery using double volume press I tried to flash the Remix OS and it goes well at the first time, my questions is, if you take a look at the attached pic you'll see the bootloader looks unlocked

Do you think I can use the same procedure to directly flash the Lineage ROM provided by  KonstaT?

Thank you very much in advance

boot.jpg

Share this post


Link to post
Share on other sites

So everything works except Navigation (tethered GPS) Maps works then when you start your navigation it always drops gps and asks for permission and just loops that...When you go back to maps from navigation it picks up gps strait away, but as soon as you start nav it drops. Right now i'm trying a different version of gapps see what happens, back to step 1.

Share this post


Link to post
Share on other sites
2 hours ago, buzniak said:

So everything works except Navigation (tethered GPS) Maps works then when you start your navigation it always drops gps and asks for permission and just loops that...When you go back to maps from navigation it picks up gps strait away, but as soon as you start nav it drops. Right now i'm trying a different version of gapps see what happens, back to step 1.

This device doesn't have GPS hardware so that doesn't work of course. Google network location works fine if you've installed gapps. You need to enable wifi and 'high accuracy' location mode to get a position.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.