Jump to content
nontha

CAN SOMEONE HELP ME ?

Recommended Posts

The zip file was originally made for people to roll back from ICS to GB and that is why it is named like that, yes both files are the same.

Share this post


Link to post
Share on other sites
14 hours ago, wbrambley said:

The zip file was originally made for people to roll back from ICS to GB and that is why it is named like that, yes both files are the same.

I installed fastboot using android sdk . And then connected the phone during fastboot mode . The device is detected when i enter 'fastboot devices' . It shows  "47782 fastboot" . Even fastboot reboot and fastboot reboot-bootloader works .

But when i type fastboot oem device-info OR fastboot oem get-bootinfo , I get no response . I only see these dots -> "..." as though it signifies waiting , and I have to stop this waiting by typing Ctrl+C if I want to get back to prompt . 

However , instead of typing fastboot devices , if i type fastboot device i.e. without the letter "s" , I get "<waiting for any device>" response .

a.JPG

Edit : I guess this is normal since I am using stock GB bootloader , according to (1st page Tcpaulh's comment) in this : -

Shall i proceed with the flashing then ?

Edited by nontha

Share this post


Link to post
Share on other sites

Yes. Flash the recovery. Worst case scenario we can find/extract a stock GB recovery if things go pear shaped.

Share this post


Link to post
Share on other sites
On 11/6/2016 at 5:59 AM, wbrambley said:

Yes. Flash the recovery. Worst case scenario we can find/extract a stock GB recovery if things go pear shaped.


Thanks a LOT. :) I had recovered my memo data yesterday .

I am writing my Full results (as much as I remember) so that if someone needs , they could benefit from reading it.

I had recovered my data , specifically my notepad (memo) data from my phone . However , it was not by using adb pull . Before trying the adb pull command , I had backed-up my entire phone using cwm recovery's nandroid feature . In the resulting backup.ab file - i extracted it , and got all the /data and /system partitions as a ".tar" archive . I extracted the data.tar and opened the notepad-info file which was inside the com folder .

I might have recovered the data this way , because i wasnt able to adb pull anything from /data . 

The reason for this was two-fold .

1.)My device was not detected as adb while i was using the OS . My device was detected as adb device only in the recovery menu . I think from what i have read , the reason for this is either usb debugging should be somehow disabled in the service menu which could be accessed by typing  *#*#2846579#*#*  in dialer , but since i cant use the touchscreen i cant access this service menu to enable usb debugging .

OR There are two adb drivers - one which works in recovery and one which works while phone is in OS & the adb drivers needed to be installed separately again while the phone is in the OS.However , i used device manager to update adb drivers and also installed the adb drivers already kept by Huawei in the stock rom; but still my device wasnt detected as adb while phone is in OS. 

I had also used a different USB wire and connected to different USB ports to check whether the issue is broken cable or lack of voltage ; but to no avail .

I might have been able to pull /data if adb worked when phone was in OS mode .

2.) I realized only LATER (after extracting my data from nandroid backup) that /data and other partitions like /system were blocked - that is we cant view the important files for e.g. build.prop or even edit it . I could only see unimportant files using "ls" command in adb shell . Then i realised if i was in recovery mode , I needed to mount these partitions using "mounts and storage" in cwm recovery menu if I needed to access or edit the files in these partitions . After doing so , i was able to see and edit files inside these restricted partitions .

I guess this need for mounting only is there when i am in the recovery menu . I guess if i had adb in the OS , i might have been able to easily access these partitions .

Also before mounting using cwm recovery menu , I had used adb root for super-access & also used mount command in adb to access the /system parition as readable/writable memory ; but still i couldnt access the partitions fully.

3.) i might need to add .dll files to usb drivers folder or enter the signature keys of my laptop in android_usb.inf file (so as to have my phone detect my lap) -> and many other such methods I read in many forums ; so as to enable usb debugging and have adb while the phone is in the OS .

 

 

Right now , I want to be able to enable usb debugging while the phone is in the OS . I think being able to access adb is a sure sign of usb debugging being enabled , isnt it ? Since i cant use adb when phone is in OS , I must not have usb debugging . What could be the problem in my phone ?

Right now , I am attempting a last ditch effort to control my phone from my PC using android control or Chrome's vysor, but since adb is not detected and usb debugging seems to be not enabled WHILE the phone is in the OS, i cant use android control . But I can use android control when my phone is in recovery mode (cause in the recovery mode, adb is working) and i can see the recovery menu in my computer screen while using this program in my computer .

I want to control my phone using adb or android control while is in OS . I adb pulled the build.prop file and default.prop file . I made changes by adding the "persist.enable.usb" & other such commands in both these files and adb pushed it back into the phone ; so as to enable usb debugging. However , the default.prop returns to normal values when the phone is rebooted . I dont think those commands are to be edited into the build.prop either, it might have to be edited in the default.prop itself . Also even after editing the build.prop and rebooting the phone , nothing seems to have changed . 

Is rooting the phone or full-level root access necessary for editing the default.prop permanently ?

What could be the problem ? - me not being able to use adb or have usb debugging when in OS .

Also ,  wbrambley , Thanks for everything . I cant express my gratitude enough . Yesterday , when i extracted the backup & recovered the data , I felt no euphoria at all . Maybe it was because i was more confident that I would succeed in some way, compared to a week before when i knew nothing about android and was depressed & had no hope that I would ever recover my data OR maybe because I had a greater resolve in improving myself or learning more about all this stuff rather than worrying about retrieving my data . I was hooked into tweaking android. Since your first reply in this post , I have learned a lot , and I can honestly say that the effort & enjoyment in experimenting is far greater than the result . Thanks for showing me the ropes .

Edited by nontha

Share this post


Link to post
Share on other sites

Glad you finally sorted it. Did that recovery use the hardware buttons?



If so have a good look in the sub menus for mounting options.

Share this post


Link to post
Share on other sites
1 hour ago, wbrambley said:

Glad you finally sorted it. Did that recovery use the hardware buttons?

 


If so have a good look in the sub menus for mounting options.

 

Yes . I had already mounted using "Mount and storage" menu in cwm recovery mode menu , and thus I could easily access all partitions ; which I had learned only later & I had mentioned this in 2nd point of previous comment . 

The problem I have now is I can't use adb while I am in the OS i.e. when the phone is running android 2.3.6 . I can easily use adb when the phone is in recovery mode . Also , i think usb debugging is not enabled when the phone is in OS . The reason I say this is I connected my phone to PC and ran "android control" (or chrome's Vysor or android screencast) software on my PC . The phone is not detected by the software while its in android OS and also "adb devices" command shows no responses while the phone is in OS . 

Edited by nontha

Share this post


Link to post
Share on other sites

If you can mount partitions on recovery, why not

A) pull the build.prop file, mod it then push it back. Just remember to set the permissions

Or

B) push persist.sys.*can't remember* with a value of 1 file to /data/property folder.

(Create a file with the appropriate name on your PC with 1)

Google should be some help with different adb options here

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.