Jump to content
paulm94

Hudl 2 stuck in erase screen

Recommended Posts

Got this hudl free from someone at work as its not working and i was going to use it for spares for my sons. But me been me wanted to see if i can get it working .

When it boots it goes straight to a black screen with the andriod bot with erasing under the bot and basically stays there and switches off. Tried the power on with volume + key but wont go into boot menu it just goes back to above screen 

Tried connecting to pc but nothing happans so is this tablet dead or is there anyhthing else i can do ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.