Jump to content
weeandykidd

[Guide] Smart Ultra 6 in 2019

Recommended Posts

Hello,

I recently dug out my Smart Ultra 6 and wanted to remove CM and switch to Lineage with Magisk. However I found a lot of dead links and issues trying to do so.

The main issue I had was a bootloop on LineageOS 14, which the recommended fix for was to install a rooted 6.0.1 ROM first - however all links were dead.

Therefore I've compiled some links and basic steps which could be useful to anyone else who stumbles across this forum looking for help 🙂

Directory Link Here

0. (optional - if you are using a custom ROM) Getting back to stock
	- Use your current recovery to flash (Smart_Ultra_5.1.1_recovery [STOCK].zip)
	- Reboot into recovery to run (Smart_Ultra_5.1.1_update [STOCK].zip)
	- Reboot to system and update OTA to latest marshmallow 6.0.1

1. TWRP on Marshmallow
	- Extract 'Smart_Ultra_TWRP_recovery[3.0.2.0] (qfil)' to C:\TWRP
	- Install MiFlash (Ignore QFIL/qualcomm flash image loader)
	- Load in the C:\TWRP directory
	- Plug your phone in via USB and hold power and volume down to boot into Qualcomm flash mode
	- Keep hitting refresh until your device shows up, then never touch it again
	- hit flash, it'll probably fail
	- keep rebooting your phone (holding power and volume down) and hitting flash, eventually it'll take

2. Backup
	- Reboot back into recovery (now TWRP)
	- Take a NAND backup

You can now proceed to install lineageOS/gapps/magisk via TWRP.

 

Regards

Andrew

Share this post


Link to post
Share on other sites

hey, thanks for this how to. 
i had to modify the process in order to reach 'Qualcomm flash mode'
volume down and power leads to some other flash mode FT
correct one for me was switch phone completely off, then hit vol up and down without power and then connect usb to pc. then in device manager some qualcom device is shown. also then qfil tool (not in your list) recognizes it as qualcom device, and then i had to remove some driver that i had installed previously, in the device manager and reconnect it again, and then also your miflash recognized it, and then i was able to flash it there

 

just for people stuck in the future on the same issue 🙂

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.