Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 06/17/2018 in all areas

  1. 5 points
    Just a quick update! I have finally managed to get Oreo booting, but at the moment not much is working. As I don't have much free time please don't ask for an ETA, I will upload a beta for testing when I've ironed out the major bugs.
  2. 3 points
    Note: due to Tesco making the change on their server today 21st March it appears these instructions are no longer required. Right with many thanks to ChrisEvilGenius and Sarkie and others. These were written for a Hudl1 I don't know if a variant may work for Hudl2s abandoned by Tesco but it might well. First install the Fiddler software on another machine (probably Windows though it looks like it could be Mac or Linux) https://www.telerik.com/download/fiddler In Fiddler Tools - Options - Connections Tick Allow remote computers to connect. Also under HTTPS tab tick Decrypt HTTPS traffic. You will get a popup about Windows trusting this certificate, click No (You don't need it locally as you aren't interested in traffic from the machine fiddler is installed on.) Now go and hover over the Online in the top right of the Fiddler window and take note of the IP address given there (there will probably be an IPV6 address with letters in and below the IPV4 you want, looks something like 192.168.1.76 though almost certainly different numbers) Now to the Hudl, holding volume up and power on gets you to a menu for a fresh reset. Restart the Hudl. On the Hello screen click start. On Select Wi-Fi, do not connect. Tap Other network then on the keyboard hold the microphone to get to settings. Tap Google Keyboard Settings. Scroll to the bottom to About Google Keyboard, Tap Open-source licences. Press and hold to select some text, then from the top menu that appears, tap Web Search. Now in the search start typing Settings and you should be given a Settings result. Tap it (not Google Settings)to open the Hudl settings. Scroll down to Users and then Add User (top right). Ok to add new user. Then Set up now. Drag the padlock to unlock. At Hello click the grey triangle to continue Unset the google & location settings and continue No, thanks to set up google No to a Tesco account Skip Register with Tesco Now at Problem Connecting tap check Wi-Fi This time connect to your Wi-Fi (Whilst writing these notes I went round the last couple of steps twice but then it jumped to Updating Apps as it had previously, keep tapping Check Wi-Fi and it should get there). At Updating apps tap Not now All Done, tap finish No thanks to Child advice OK to a couple of demo screens You now have a working user BUT don't stop here! Turn the Hudl off and back on When at the lock screen tap the Owner coloured blob (it might already be selected) and unlock Tap Start at the Hello screen At the Wi-Fi settings tap your connection and Forget Connect again BUT this time after entering your pass key do not tap Connect but Show Advanced Options (you might need to scroll down to see it) and set Proxy settings: Manual Proxy hostname: the ip address from fiddler Proxy port: 8888 then Connect. (Traffic should now probably start to appear in Fiddler, nothing of interest yet) The install will proceed but fail with a Check Wi-Fi prompt, OK Now Tap Other Network Hold Microphone as before and Google Keyboard Settings, scroll down to About Google Keyboard but this time tap Privacy Policy. Chrome will load and ask you to sign in, tap No,thanks There may be web errors showing, ignore them and type ipv4.fiddler:8888 into the address. (If the network has disconnected, it did once for me, drag down from the top right to get to the settings and reconnect) You should get a Fiddler Echo Service page, at the bottom tap on the download the FiddlerRoot Certificate link Give the certificate a name, you'll be removing it later, then tap OK. Tap OK to the warning about a lock screen PIN, again you can remove it later if required. Set a lock screen PIN/Pattern/Password (pattern is easiest) Now back in Chrome you'll have an app select softbutton at the bottom right, swipe to close all the apps. Back in google settings press the back soft button will get you back to the beginning. Now in Wi-Fi setup tap your connection and forget then tap and connect again but without the proxy settings, just your pass key. (I'm not entirely sure which bit objects to being tunnelled through Fiddler and given we can work round it didn't bother digging too hard to find out). Continue accepting the terms and conditions Untick the Google & Location options and tap the grey triangle to continue. No thanks to set up Google No to Tesco Account Skip (bottom left) to Register with Tesco Now you are at the Couldn't Check for Updates that you are likely familiar with and couldn't get out of, only this time you can swipe down from the top right and get at the Wi-Fi settings. Now tap your connection and Forget Connect again BUT this time after entering your pass key do not tap Connect but Show Advanced Options (you might need to scroll down to see it) and set the proxy again Proxy settings: Manual Proxy hostname: the ip address from fiddler Proxy port: 8888 then Connect. Tap back and Hudl will be checking for updates again and failing but this time you'll have a line appeared in Fiddler to the host device.mobile.tesco.com with a URL similar to /ota/20140424... Now the clever bit In Fiddler go to the menu Rules - Automatic Breakpoints and set After Responses (or Alt+F11) Tap try again on Hudl. Now the new line will be the same as before but with a red icon next to it Select the new entry and go to Inspectors on the right hand side, select Raw in the bottom half of the screen and delete much of the last line of the response there editing it from {"status":"OK","update":{"currentAndroidVersion............. to {"status":"OK","update":null} Click the green Run to completion button Now go and right click on that entry in the listing and select Save - Response - Entire Response Save it somewhere! Now click on Autoresponder on the right hand side again Click Add Rule then right at the very bottom Click the drop down "Local file to return or Action to execute" Select find a file and find the file you saved just before. Ensure Enable Rules and Unmatched requests passthrough are ticked. Lastly go to Rules - Automatic Breakpoints and set it to Disabled. Now tap Try again on Hudl.... Magic.... At Updating apps tap Not now All Done as the Hudl says Tap through the intro and then tidy up. In Wifi settings forget the settings for your network and put them in again without the proxy. In Settings - Security - Clear Credentials (or go to Trusted credentials and remove the Fiddler certificate only but then you have to keep the lock). Then you can remove the screen lock at the top of the security settings. In User tap the dustbin next to the New user you created and Delete, One working Hudl. You can now uninstall Fiddler from whichever machine you were using to proxy unless you have a taste for it!
  3. 2 points
    I've emailed Tesco yesterday to suggest the minor change they need to make to their server to make my instructions redundant and ask the reason why they aren't doing it! I've had a response from the front line staff to say it has been passed to the support team so you never know... It all hinges around that one response from the Tesco server that the rest of the instructions are simply enabling us to intercept and change, if we can persuade them to change it at their end then all is well. Back up the thread on the 8th Feb @chrisevilgenius had success for the Hudl 2 using essentially the same method (different implementation) so I think if we can persuade Tesco to make the change to their webserver Then all will be well, Tesco will actually be in their stated position that they are no longer supplying updates but now in the position that their server is effectively saying "no updates available" rather than replying with something that causes older Hudls to get confused and stop. Whether that null is really handled in the software or just causes the code to continue is really neither here nor there just as long as the code continues and lets the setup complete! Will let you know if I get a real reply from Tesco.
  4. 2 points
    I sent an e-mail to ComputerActive magazine who have a very good readers help page. I have heard back from them and I believe they will be contacting Tesco. It seems very odd that Tesco are now saying there is nothing they can do after their initial reply advising how to solve this problem .I am wondering if it is because there is no longer anyone at Tesco with the necessary technical knowledge.!They are after all only grocers.! Seriously though , it is a very poor response from such a large organisation to dismiss this by saying the tablets have reached the end of their life The whole point is that these tablets were very much alive and working until a Factory reset was attempted.Presumably, the Factory reset procedure has previously been working and so the recent failures are surely the responsibility of Tesco. Perhaps the increasing adverse publicity will jolt them into action.
  5. 2 points
    New Build up lineage-14.1-20180620-UNOFFICIAL-p839v55.zip Lineage sources updated Low mic volume while recording improved Updated audio drivers
  6. 1 point
    I am not sure that 5.1 branch will boot. So mixed with 4.4 for more liked.
  7. 1 point
    TBH I don't remember much from that day I used this phone. So I don't have any idea. I just used latest CM with default kernel and latest Gapps package. No complicated mods. I like keep it simple.
  8. 1 point
    Here you go: https://drive.google.com/file/d/1el1Ud7MbD7QxZkqrMHu995Jt52nB3-Ii/view?usp=drivesdk
  9. 1 point
    UbetTC49-Legacy has not back button order no phisycal and neither in "navigation bar " ---------------------------------------------- the next combination works very well SlimKat-u8951-port.build.9.1-legacy + SlimKat91L-kernel-mixed + SK91Leg-FMRadio ----------------- i use pa_gapps-modular-pico-4.4.4-20150410-signed and also change dpi to 240
  10. 1 point
    Huawei's low to mid range device, the P Smart, is currently only £169.99 at Amazon in either black or gold. That's a bit of a bargain. That price gets you a single SIM device with a Kirin 659 octa-core processor, 32GB storage, a trendy 5.65" 18:9 screen, Android Oreo with EMUI 8 and dual rear cameras. You don't get 5GHz Wi-Fi, Bluetooth 5.0 or USB-C, but they aren't terrible compromises at the price. Performance is good thanks to that processor and 3GB RAM, battery life is great too thanks to the 3000mAh battery and NFC is included for Google Pay. The device itself shares its internals with the Honor 9 Lite, but has a more subtle body that is less slippery in the hand. Interested? Head on over to Amazon to pick one up. View full item
  11. 1 point
  12. 1 point
    Well well well… I've just sat down at my computer for the first time today and checked my emails. First I came across a reply to my email to Consumer Champions at The Guardian last week, and they say as follows: "Hi - I asked Tesco about your case and this is what they have said.... A Tesco spokesperson said: "We’re aware of a technical issue affecting a number of Hudl users and apologize to customers for any inconvenience caused. We have already fixed the issue for the majority of those who have contacted us and are urgently working on resolving any outstanding queries." Background A number of Hudl devices are experiencing difficulties connecting to the Hudl server. Tesco have not switched off the Hudl servers, this was not the cause of the issue. This can be fixed for newer versions of Hudl 2 devices. Customers wanting more information on how to resolve the issue can visit our dedicated customer support website www.tesco.com/productsupporttesco or contact us directly. We are working hard to resolve the issue for older versions of Hudl devices as quickly as possible." My first reaction was frustration, since we know that most of us do NOT have working hudls, so Tesco's above claim sounded like an outright lie. Then I read the email notification of Aislingeanbeag's post here on the forum and I decided to fire up a bunch of hudl2s that were previously stuck on the "Couldn't check for updates" and, lo and behold, they all went past that screen now! Doesn't seem to matter whether you say Update Now or Not Now, both options take you through to the home screen! However, on all of them I have trouble getting Google Play store to work, on a couple of them I did get the app updates to start downloading after a few attempts of only getting a blank Play store screen, but on the other two I'm still struggling. Don't know what I did differently on the first two so I will still have to do some more investigating to figure out a sure-fire way of getting the Play store to work. But looks like Tesco may have paid heed to (sorry I forget your handle)'s post detailing the exact response the server should be giving and that they didn't lie to The Guardian! Please let us know how the rest of you get on with your hudls!
  13. 1 point
    After much wailing and gnashing of teeth and a long period of inactivity I today tried again HUDL HT753 android 4.2.2 has let me in and appears to be operational I replaced the screen just after New Year and did the reset and hit the barrier. Tesco help gave the usual we are working but never heard any more Yesterday I found this thread and today I thought lets try the solution Fired up and it accepted the previously entered wifi network and proceeded to update apps So now Everything appears to work and I have a home screen with live wallpaper I now need to know what I should be testing to verify it is fully working
  14. 1 point
    Thanks Anna65. I'll email TechSupport (in the morning) with details of the problem. If I don't get a satisfactory response then I'll email Dave Lewis/Lewis Gorrie reminding them of their obligations under the Sale of Goods Act for what it's worth.
  15. 1 point
    1. Switch off the hudl. 2. Press and hold down the volume up button (keep holding!). 3. Press and hold down the power button (you're now holding down both buttons). 4. Eventually the 'powered by Android' screen will appear briefly, followed by the Android System Recovery menu (and you can let go of the buttons) . 5. Follow the instructions (if you make a mistake you can just start again). Shout if you get stuck.
  16. 1 point
    Tesco have implemented the HUDL range in a terrible way making them reliant on other services they can just switch off. I have older, much cheaper, Chinese branded tablets that still boot up & are usable & allow me to reset them. They're great at being home-automation terminals around the house running light-weight UIs. Many industrial Android touch screen terminal solutions still run Android 4. Ideally Tesco will release an app that can be executed to remove the rogue server checks to release us all from condemning the tablets to landfill. If anyone has a step-by-step procedure to "almost" get the HUDL1 working I'd appreciate it.
  17. 1 point
    @chrisevilgenius can you do an image that's passed the WiFi with no user installed maybe please? Then it'll be easier for users to have a clean image and all they have to do is add a Google Account. Thanks
  18. 1 point
    Okay I have a solution (no rooting required) for the hudl 2 that started as my attempt on the hudl 1 (can get the CA installed). I'm not going to be able to write all the steps up here, but the general concept is a "Man in the Middle" attack. Requirements BIND 9 (DNS server for you network with RPZ https://en.wikipedia.org/wiki/Response_policy_zone) lighttpd (or any other web server) openssl and SD card First create a root CA https://aboutssl.org/how-to-create-and-import-self-signed-certificate-to-android-device/ Next create a web cert signed with the CA pem and key file above (skip creating the CA) https://gist.github.com/fntlnz/cf14feb5a46b2eda428e000157447309 The important bit is the CN but have fun "C=GB/ST=Hertfordshire/L=Cheshunt/O=Tesco PLC/OU=Tesco.com/CN=device.mobile.tesco.com" Put the CA created int he first step onto the SD card and put the SD card into the device. Use the wifi keyboard trick to get into setting can go into security. Change the screen lock setting to a PIN, Pattern, etc (Required to install the cert only) Then still in security Install form SD card (VPN and app) Sorry I can real document this bit I'll just have to assume you can manage your network at this level. Add a CNAME to the RPZ zone for device.mobile.tesco.com to the server you are going to use for the web server. Configure the webserver to return the json below for any request to https://device.mobile.tesco.com/ota/ or below i.e. https://device.mobile.tesco.com/ota/rel.android-build.20150917.142239 {"status":"OK", "update": null} Now setup you hudl 2 it will call home to your server and you're in. device.mobile.tesco.com - [07/Feb/2019:23:07:07 +0000] "GET /ota/rel.android-build.20150917.142239 HTTP/1.1" 404 341 "-" "Dalvik/1.6.0 (Linux; U; Android 5.1; Hudl 2 HTF8A4 Build/LMY47I)" device.mobile.tesco.com - [07/Feb/2019:23:07:07 +0000] "GET /config/ota-client/ HTTP/1.1" 404 341 "-" "Dalvik/1.6.0 (Linux; U; Android 5.1; Hudl 2 HTF8A4 Build/LMY47I)" P.S. no idea what the config request is for but it doesn't seam to stop the setup. Now I need to solve it on the hudl 1, for an autistic child who is an attachment to the hudl 1, but theirs broke, the parent got a second hand one found it would not setup. We offered ours for free not knowing about the issue I reset it as well.
  19. 1 point
  20. 1 point
  21. 1 point
    Hi all, just read all the comments above and now adding my tuppence worth... No solution though, sorry, just some other observations that I've made during my own investigations into the issue: - This problem only happens with hudls running Android 4.4.2 KitKat. - The problem didn't start on 1/1/19, I was still updating hudl2s from Kitkat to 5.1 Lollipop (which is the first thing you must do when you start up a factory reset hudl2 that still runs KitKat) on Thursday 10/1 but then when I came to do it on Friday 11/1 it was no longer possible - this internet connection error comes up. - As some of you have also found out, I too tried using a non-factory reset hudl2 and it accesses the internet just fine, e.g. google, chrome etc, but if you try to download Lollipop (Settings, About hudl) you get the error, and also if you click on any of the Tesco services under About hudl, so yes the problem will have something to do with Tesco servers. - All factory reset hudl1s are bricked due to this since they all run KitKat and have never had the option to update to a later version. - All hudl2s that have been updated to 5.1 Lollipop are fine, even after a factory reset since it doesn't roll back the operating system, just the data. I too raised a case with Tesco a couple of weeks ago when I found this out, and sent them lots of photographic evidence which they asked for. They have been in touch via email and assure me that they're working on it. Hopefully they can re-enable services, surely they did not INTEND to brick ALL hudl1s and a third of hudl2s?! I fix hudls in my spare time and at any one time I have about a couple of hundred hudls2 here with broken screens (my supply of working motherboards) and the general proportion of Lollipop to Kitkat is about 2:1. But even though that's a majority of hudls that are fine, this problem still means that I'm sitting on an awful lot of bricked hudls, which I've paid good money for... So like all of you I'm putting pressure on them to get this sorted asap!
  22. 1 point
    Does Honor 7 update to android 9.1 Google pixel?
  23. 1 point
    how would those numbers and you cover the shipping be?
  24. 1 point
    i was slightly more looking to the voucher prices as im thinknig about getting an xz3 (i clearly have a phone buying problem), that negotiable with you?
  25. 1 point
  26. 1 point
  27. 1 point
    Thanks you so much Adeii for your great work on ROMs for y300, I don't have anymore my y300 too. It was very fun to test your ROMs for that old phone, I have learned many things about the world of Android.
  28. 1 point
    I have finally downgraded, rooted and installed TWRP along with a custom ROM on my device which is now running MIUI 7. I have made a tutorial on XDA, so please visit it over there. Unfortunately the stock ROM that you have mentioned did not work upon the side loading method. It came up with status 7 saying that this is for a different model of the phone. But I did find a Romanian ROM which worked perfectly and that allowed me to root my phone once again. Link to guide: https://forum.xda-developers.com/android/development/easy-guide-how-to-downgrade-root-t3849525 I hope i helped all of you.
  29. 1 point
    @tcpaulh I am the person that talked to you on the stock roms and recoveries forum. I have finally downgraded, rooted and installed TWRP along with a custom recovery on my device which is now running MIUI 7. I have made a tutorial on XDA, so please visit it over there. Link to guide: https://forum.xda-developers.com/android/development/easy-guide-how-to-downgrade-root-t3849525 I hope i helped all of you.
  30. 1 point
    2015072214222958.zip is at ... not sure if the same result can be achieved with this?
  31. 1 point
    Enable xz compression in kernel defconfig and save some extra mb ;)
  32. 1 point
    Well, all camera apps should turn on Max.brightess is there is a option. Snap Camera for CM-13 has it coded: https://github.com/CM13-Y300/android_device_huawei_msm7x27a-common/blob/cm-13.0/overlay/packages/apps/Snap/res/values/cm_strings.xml
  33. 1 point
    Thanks for solution, Trapezio. Those are missing lines from build.prop. No need for repacking and flashing boot.img! Camera2 or Snapdragon Camera is dark?
  34. 1 point
    I don't have any issues but I felt like replying anyway to thank you for making this ROM! I'm using it right now and it works great. Many thanks!
  35. 1 point
    Another tip: to got bootable nougat/oreo kernel, toolchain had to be downgraded to 4.8! https://github.com/sonyxperiadev/device-sony-rhine/pull/210/commits/b5468ff42e505cf14487bc5b2d6e98a561e180d8
  36. 1 point
    So, to bring back some life to this device, decided to build Resurrection Remix (nougat) (available here). I just built using the exact same device tree, vendor blobs and kernel source from KonstaT's github without touching it. Replaced the telephony-common used in LinOS 14, copied libboringssl-compat.so (to make the camera work). Applied the hack mentioned here and made a u23 patch by just replacing the boot.img from the last patch for LinOS 14 (using the defconfig for u23). I didn't make any change regarding to SELinux. The roms seems similar to LinOS 14 regarding stability I recently saw this post: In the Resurrection Remix build, it's set as Enforcing. So the last thing I'm missing is to set it to Permissive to be as stable as LinOS 14? Probably I won't make many builds because my computer dies building android nougat, so I want to upload a stable build so I can delete the source code.
  37. 1 point
    Top spec Surface Book 2 i7 / GTX 1050 / 16GB RAM / 512GB SSD, mint, boxed with stylus and in warranty. £1750 inc. Awesome machine, selling to fund different gadgets as I have a new work laptop!
  38. 1 point
  39. 1 point
    For Sale - OnePlus 5, 128GB. Black, very good condition. I used this as my work phone so it hasn't seen to much hard use and has been looked after. Dash charge is very efficient. Unlocked, sim free. Complete with all original packaging, box etc. £300 or decent offer including RMSD Payment by bank transfer.
  40. 1 point
  41. 1 point
    Cool! Thanks so much for all the support. I managed to do it with !tested not working! method, and it worked. :)
  42. 1 point
    No customs risk. It'll ship from the UK if they happen to be holding stock else China to UK warehouse then on, no customs risk.
  43. 1 point
    Like many things in life, phone contracts are frustrating because as an existing customer, you can't get access to the same deals as new customers. I suspect that at some point in the coming years this may be outlawed, but until then, if you want a new customer deal without losing your number, you need to switch network. Or do you? We recently assisted a reader who was currently on 3 but wanted to get a great deal offered only to new 3 customers. The solution? Surprisingly straightforward. Cancel the current contract, requesting a PAC code (porting authorisation code) Pick up a PAYG SIM from another network (most networks will send them out for free via a form on their website) Port your number to the PAYG account Sign up with your previous provider again, taking advantage of the new customer deal Request a PAC code from the PAYG provider Port the number back off PAYG to your new account Simple!
  44. 1 point
    Hi, send me a message with the name you would like to use, I can change it for you.
  45. 1 point
    I have a copy of the ROM and compatible GAPPS . I have uploaded them to filefactory for you. Here are the links. https://www.filefactory.com/file/3zczdz32ct1l/cm-11-20140915-UNOFFICIAL-skate.zip https://www.filefactory.com/file/1v4ln5o7a5l9/Gapps-mini-4.4.4-20140817-stripped.zip
  46. 1 point
    Hi there! I had the adoptable storage working on my S7 Edge until I got it back from repair. Now, I am not able to set the adoptable storage by following Paul O'Brien's howto: I simply get this: hero2lte:/ $ sm list-disks disk:179,0 hero2lte:/ $ sm set-force-adoptable true hero2lte:/ $ sm partition disk:179,0 private hero2lte:/ $ sm list-volumes private mounted null public:179,1 unmounted 6F61-FE60 emulated mounted null hero2lte:/ $ sm has-adoptable false I have tried everything, from wiping the SD card on my linux laptop to formatting it with my laptop, with the phone and through adb. No luck. Any suggestions are highly appreciated! :)
  47. 1 point
    Yeah, all kinds of cool stuff you can do with rope. :o
  48. 1 point

    Version 1.0.0

    138 downloads

    CamGAG is an advanced fake webcam system that display a person into a video but you can control the model from the video to do different things and it looks so real that your webcam partner thinks they're talking to a real person. We have models that can perform 200 commands, from wave, touch nose, cover eyes until to a complete adult nude show. We have many models to chose from at www.camgag.com

    Free

  49. 1 point
    hey here is my stuf that i was collecting ower the year that may be handy for u.... http://www.4shared.com/folder/OjfDEJaF/zte-skate.html there is all the roms and other packages u can find there... that is that all stuf i can find... u can send me something if i forgot to put and i will be upload...
  50. 1 point
    ">" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344">I like my Shift. It has some obvious failings (such as the pretty horrible battery life) and also the 'crippled' Snapvue, which is really a locked down Windows Mobile 6 with bits removed. Wouldn't it be great if you could Liberate SnapVue by making it full WinMo 6, and then installing as normal? Wouldn't it be great if this was made really easy? Wouldn't it be great perhaps if the process was demo'd on video? Wouldn't it be great if the software you really wanted was bundled up into easy to use 'packs'? /me takes a bow :( Introducing... SHIFTpack.Liberate and SHIFTpacks! Let me explain :D SHIFTpack.Liberate is the first step on the road to liberating your Shift. It's super easy to use, very small, and demonstrated in the video below. It restores your Start Menu, restores CAB assocations to let you install stuff, lets you soft reset without needing Vista and gives you a utility that lets you hook up the WinMo side to the Vista (WMDC) side of your Shift. You'll see the full process in the video and detailed below, but it goes like this...Ensure you have access to an email account on Snapvue Enter your e-mail address in the form below, to send the all important SHIFTpack.Liberate files to your device Save files in the relevant locations (some trickery here) Click the Liberate icon in Settings Click the Soft Reset icon in Settings Enjoy WinMo 6 goodness Once this is done, you can then use our SHIFTpacks either in CAB form on the WinMo side or (even better) in EXE form from Vista (as demo'd in the video) to restore missing functionality. We will be adding a whole bunch of SHIFTpacks over the next few days, so keep checking back! At this point, watch the video above! So you like what you see and you want to get started? Excellent! There are TWO posts below (News page readers, click 'View Topic'). The first is dedicated to using SHIFTpack.Liberate to liberate your device, the second contains additional SHIFTpacks for extra functionality (such as Pocket IE in the video) and will be continually updated as we create new packs. Read on!
  • Newsletter

    Want to keep up to date with all our latest news and information?
    Sign Up
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.