Jump to content
  • Sign in to follow this  

    How to speed up window animations on Android


    PaulOBrien

    It might not be generally recommended to start messing around in the developer settings on your device, but there is a little setting in there that can be used to slightly, but perceptibly, speed up general use of your device. The little known 'animation speeds' settings sit with the equally useful DPI settings.

    First up, you need to enable 'Developer Mode' on your device. This is easy - in the settings app, go to the about screen and find the 'build number'. Got it? Tap this 5 times in quick succession and you'll see 'You are now a developer!' on screen (if you are on Oreo you may also need to enter your PIN). Now that's done, when you go back a level you'll see a new menu for 'Developer Options'.

    In this menu, in the drawing section, you'll find 'Window animation scale', 'Transition animation scale' and 'Animator duration scale'. The first thing I always do on a device? Drop these down to 0.5x from the default 1x. The next thing I always do? Set DPI to 411 on the option below - this one is useful if you want more granularity than the standard Display menu gives you.

    Give it a go and see how you find it, you can easily change it back!

    Screenshot_20180612-173421.jpg Screenshot_20180612-173434.jpg

    Edited by PaulOBrien

    Sign in to follow this  


    User Feedback

    Recommended Comments

    There are no comments to display.



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Social

  • Topics

  • Posts

    • Selling a pixel 3a black. Unlocked and boxed   Has a tiny ding right on the front bottom but with the screen protector on can't even tell.   Comes with case.   £200 delivered
    • can you please tell me how you signed the zip file because with zipsigner it doesnt work 😕 says footer error in recovery Greetings
    • Hello. I've been using this smartphone since 2016, I went through the official upgrade to Android 5.1.1 and then to 6.0.1. Long story short I'm now with TWRP 3.2.3-0 and Lineage 14.1 (Android 7.1.2). I found some interesting bugs: one is that if you have low battery, about to self power off, and you switch on the torch, it stays on even after the phones is powered off, and you can't turn it off whatsoever, except plugging in the charger and switch on the phone again I guess, but I didn't try it. The matter is that if you let the torch on to let the battery discharge completely, and the light goes off, when you charge it again and switch on the phone you can't switch on the torch anymore, even tho the system claims is on, it doesn't beam any light from the flash led. The only way to "reset" this status is to open the phone, removing the back cover, unscrew 3 screws that hold a tiny bar and manually disconnect the battery (most rightside connector) and then reconnect it. Not even holding the power button helps. Another bug is that if you turn on the phone, and then, without putting it on stand-by, check with some kind of cpu monitoring app the cpu cores activity, the less powerful cores of the A53 are awake and running. If you put the phone in stand by and then re-awake it up, they are always on sleep or "disconnected" or similar status. Even tho it seems that this doesn't affect performance, so it seems that they doesn't show correct running status but still works. Last but the most important: the phone THROTTLES at room temperature!!! If you try a cpu intensive app, the cores throttles at 800 MHz or less, and if it heats more it goes down even to 200 MHz stuttering everything! I don't know if it gots bad thermal spread design or is it a thermal sensor bug, since in system monitor apps it shows temperature above 49~50 in idle while room temp is 20 to 23 °C and over 67-68 while running full calculations! Can anybody confirm or else suggest me some solutions to these issues? Thanks.
    • It worked well on my liquid a1 (running custom rogers rom). Should work on any acer based 2.2 roms I think. But I cant guarantee 😉 use at own risk.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.