Jump to content

Scanno

MoDaCo Silver
  • Content Count

    438
  • Joined

  • Last visited

Everything posted by Scanno

  1. @Ejtagle... Was working on CM10.2 (Android 4.3). Sadly kernel is not booting. I am getting a bootloop (but now splash yet) and also no adb access. Any suggestions where to look at ? I could upload my build result if that helps for you. Any way to see what could be causing this? The kernel is used as is. The init.rc is patched with the new init.rc from android 4.3 (with the old init.rc also no boot).
  2. Eduardo, In have not had much time to experiment with BT.. Did you have any luck getting BT working on 4.2.2?
  3. What are you trying to do? That RIL is already included in the vegabean and cm10.1 ROMs ???
  4. I have build it and i had the same problem. I have not had time to investigate the issue. But thanks a lot for the signal and the solution.
  5. OK i will remove all the old stuff and implement lbbt-vendor and put the files you posted in /etc/bluetooth Lets see how far we can get. Do not know when i have time for this hopefully i can get some stuff done tonight.
  6. Great I will have a go at this. The old Bluetooth stuff is that still needed or can in remove that? I mean the hciattach. Is that now included?
  7. Sadly the new hwcomposer did not solve the SOD problem
  8. Thanks, I am building a new version of CM10.1 with the new hwc. I will post it as alpha13 (lucky number hopefully).
  9. @All, I have not been updating this thread over here. But on tabletroms, i have posted newer versions (RC versions) with an overclocked kernel.
  10. Minimal Requirements: Quad core processor 2 GiB memory. So sadly a no go for the vega
  11. Eduardo, I asked in the google android forum about support for other bt chipsets. I got the answer below: ===================================== Bluedroid does support other chipsets. Nexus 4 uses Qualcomm Bluetooth controller. You can take it as an example. Multi-channel transport is supported. Please see: external/bluetooth/bluedroid/hci/src/hci_mct.c All the source codes are provided. ==================================== I am sure you haad a look thus, but just in case....
  12. Eduardo, I have added the SIO scheduler to the kernel and it seems to speed things up. I have also added the new governor and that seems to work also but I have not tested it very well yet. I am not able to set it as the default governor. If I do I an not able to boot. The over clock I have not tested added yet.
  13. @EJTagle, Thanks for the updates on the kernel. I am building a new version of CM10.1 that includes the kernel with the SIO schedular added and set as default schedular. As soon as it is ready i will post it as an experimental version so people can try it out. Did not add the other two additions yet.
  14. In CM10.1 i am getting the following error when compiling the huawei ril: In file included from device/nvidia/shuttle/huawei-generic/requestdatahandler.c:105:0: hardware/ril/libril/ril_commands.h:65:59: error: 'responseStringsNetworks' undeclared here (not in a function) hardware/ril/libril/ril_commands.h:65:5: warning: missing initializer [-Wmissing-field-initializers] hardware/ril/libril/ril_commands.h:65:5: warning: (near initialization for 's_commandInfo[48].responseFunction') [-Wmissing-field-initializers] make: *** [/home/x/cm10.1/out/target/product/shuttle/obj/SHARED_LIBRARIES/libhuaweigeneric-ril_intermediates/requestdatahandler.o] Error 1 make: *** Waiting for unfinished jobs.... make[1]: Leaving directory `/home/x/cm10.1/kernel/nvidia/shuttle' device/nvidia/shuttle/huawei-generic/huaweigeneric-ril.c: In function 'print_simansw': device/nvidia/shuttle/huawei-generic/huaweigeneric-ril.c:3038:15: warning: comparison between signed and unsigned integer expressions [-Wsign-compare] device/nvidia/shuttle/huawei-generic/huaweigeneric-ril.c: In function 'decodeUSSD': device/nvidia/shuttle/huawei-generic/huaweigeneric-ril.c:6116:2: warning: pointer targets in return differ in signedness [-Wpointer-sign] [/code] EDIT: Seem to have resolved the compile error by adding: #define responseStringsNetworks dummyResponse to requestdatahandler.c
  15. That would be nice. I had a chat whith shane francis a while back. he is the cm maintainter for the vega and he gave me this link regarding bt. https://github.com/AndroidRoot/android_kernel_asus_tf201/commit/1429d84dae30b52eb95bb03e638ffb6f596f35c3 perhaps you can do something with this?
  16. Thanks i will give it a try Edit: it seems to be working
  17. Eduardo, With this new audio_hw.c, i am not getting any sound out of my tablet. Putting back the original audo_hw.c and i got sound back. Doing a diff between the files, shows that there are many many differences. This is the audio_hw,c that i am using and is working fine (except for the big crackle when th card gets initialized the first time): audio_hw.c.zip But offcourse the microphone is not working.
  18. I am having some strange sound problems with 4.2.1. When using the volume buttons, I can see the volume indicator moving, but the sound level stays the same. When I restart an app, the app uses the new volume level, but changing the level while the app is active does not change the actual volume until I restart the app again.... Anyone else seeing the same problem? It seems like when an audio stream is opened, volume changes are not applied to the current open audio stream... Cold that be possible?
  19. So basically you have the same problem i have.. You can leave rootfs as rw by commenting the remount in init.rc i think. But somehow i do not think it would solve the problem.
  20. I do not know what i am doing wrong. I am trying to get the multi-user stuff working. Overlay is correct and the multi-user is added. I just cannot get the sdcard to mount correctly. I have used the values from the init.grouper.rc (EXTERNAL-STORAGE, EMULATED-STORAGE-SOURCE and EMULATED-STORAGE-TARGET). I also experimented with the values and with vold.fstab to mount the sdcard on several directories, but the /0/ directories are not added to the sdcard. I have been trying for a few days but no luck so far. The grouper has the internal sdcard as virtual sdcard. In the init.grouper.rc the virtual sdcard is mounted to /mnt/shell/... If i set vold.fstab to mount the sdcard to that directory it does not get mounted. I am lost. Anyone have ideas?
  21. Eduardo, I am just very happy that you want to try getting BT working on our devices. If i understand correctly, you want to interface the Bluedroid API with the kernel bluetooth subsystem? I think it could be the best solution, using the parts that we know work.
  22. Like a wrote in a pm.. The 7 inch POV mobii is a completely different tablet then the 10 inch POV mobii tegra. You cannot flash this ROM in your tablet. And please do not try because you might brick it.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.