Jump to content

Problem with ActiveSync and C550


Recommended Posts

Guest ferret

About 50% of the time when I copy files (mp3s) to the SD card via Activesync, the connection will drop out. I disconnect the phone then reconnect. ActiveSync will then stick on Connecting... while the phone will say "ERROR: Cannot connect to PC due to unexpected error in Winsock services. Please try again. If the problem persists, reset your device".

Numerous reconnects does not fix the problem. Have to hard reset to fix. Anybody got a solution, it's really getting on my nerves having to hard reset every time I want to copy a few mp3s over.

Latest version of ActiveSync. Whatever ROM ships with c550.

Thanks.

Edited by ferret
Link to post
Share on other sites
Guest Confucious

Haven't seen Winsock errors for a long time! What OS are you using on your PC? When you say latest version of Activsync do you mean 3.8 or 4?

What was the exact wording of the erro message?

Link to post
Share on other sites
Guest ferret

Hi Confucious,

I'm using ActiveSync 3.8, which I thought was the latest version (that's the version M$ give me when I visit their site to download). I wasn't aware of a version 4 for ActiveSync. PC OS is XP Pro SP2, fully updated. There's no error messages on the PC, it just sticks on connecting ..... phone says "ERROR: Cannot connect to PC due to unexpected error in Winsock services. Please try again. If the problem persists, reset your device".

I've had a e200 synced to the same PC for about a year with no such errors ever.

It did it again last night, but I discovered instead of hard resetting phone you could remove activesync, reboot pc, reboot phone, reinstall activesync, sync. Slightly better than hard resetting the phone but you still lose CallerID picture associations and custom ringtones.

Link to post
Share on other sites
Guest SilentlyScreaming

In case no one else has suggestions, I'd try defaulting WinSock back to original status, (netsh winsock reset catalog from a command line) see here and maybe resetting TCP/IP stack (see here). [edit] Though TCP/IP probably isn't relevant here, see next line for why I needed that as well, does USB syncing involve the TCP/IP protocol?

As mentioned in the 2nd link, do check which LSPs are currently residing in your system, as an example, I had to re-install NetLimiter when I ran this command. (I had similair issues to you on a previous install of XP, but with WiFi syncing on a PPC)

With both procedures, please make sure you're confident of what you are doing, and more importantly, how to recover if things go wrong.

If you do try the above, hope it solves problems.

Edited by SilentlyScreaming
Link to post
Share on other sites
  • 2 years later...
In case no one else has suggestions, I'd try defaulting WinSock back to original status, (netsh winsock reset catalog from a command line) see here and maybe resetting TCP/IP stack (see here). [edit] Though TCP/IP probably isn't relevant here, see next line for why I needed that as well, does USB syncing involve the TCP/IP protocol?

As mentioned in the 2nd link, do check which LSPs are currently residing in your system, as an example, I had to re-install NetLimiter when I ran this command. (I had similair issues to you on a previous install of XP, but with WiFi syncing on a PPC)

With both procedures, please make sure you're confident of what you are doing, and more importantly, how to recover if things go wrong.

If you do try the above, hope it solves problems.

THe winsock error is of course in my ORANGE SPV C550 and not in the windows computer of course. So how to re-pare the win sock services ? I am a macbook user with OSX 10.5 and windows mobile phone orange spv c550 ( in case somebody is asking)

ivokik

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.