Jump to content

Activesync via bluetooth on Cingular 2125


Recommended Posts

Guest ieubts

I'd love to hear from anyone who has successfully synced outlook contacts & calendar via Bluetooth on the 2125. I'm using (trying to use) Activesync 4.2 and I believe the problem lies with Activesync (and my lack of experience with it), because I've successfully created a bluetooth connection with my PC for a Personal Area Network.....so bluetooth is working fine from the 2125 for "dial-up" through the PC. I Won't go into a lot of detail on what I've tried yet as I haven't been able to find anyone yet who has experience with Bluetooth/Activesync on the 2125 or equiv. Bottom line is, can't get activesync to "connect" at all via Bluetooth. USB sync works great. Hope this makes sense.

thanks in advance.

Link to post
Share on other sites
Guest pavankp
I'd love to hear from anyone who has successfully synced outlook contacts & calendar via Bluetooth on the 2125. I'm using (trying to use) Activesync 4.2 and I believe the problem lies with Activesync (and my lack of experience with it), because I've successfully created a bluetooth connection with my PC for a Personal Area Network.....so bluetooth is working fine from the 2125 for "dial-up" through the PC. I Won't go into a lot of detail on what I've tried yet as I haven't been able to find anyone yet who has experience with Bluetooth/Activesync on the 2125 or equiv. Bottom line is, can't get activesync to "connect" at all via Bluetooth. USB sync works great. Hope this makes sense.

thanks in advance.

It is a long process, but it is not difficult to get right.

First of all you need to set up a bluetooth serial port on your computer. You then need to go to ActiveSync on the PC and in the Connection Settings, enable "Allow connections to one of the following:" and select that same port number.

After this, from your device, go to Settings->Connections->Bluetooth and in Menu, go to Devices. If your phone and computer are already paired, you should see your computer's name here. You can click the action button on the computer's name (or Menu->Edit), click Next and it should show you ActiveSync as one of the available services. Once you check that ActiveSync checkbox, your set up is complete.

Now you can go to ActiveSync on your phone, and do Menu->Connect via Bluetooth.

Good luck!

Pavan

Link to post
Share on other sites
Guest ieubts

Yes....thanks. I've gone throught the process you describe several times with no joy....

Using Widcomm drivers

-On the PC...Bluetooth serial port com8

-Connection settings in Activesync on PC...."allow connection to....com8"

-devices are paired

-On the 2125...Settings/connections/bluetooth/menu/devices/menu/edit/next........the only services that show up are "serial port" and "hands free".

Activesync doesn't show up as a service. I try menu/refresh and still no Activesync. I've deleted the device on the handheld.....rebooted.....turned the phone on/off.....re-paired.....tried port 6 and 7 without any luck. Very frustrating......

Further thoughts?

Link to post
Share on other sites
Guest pavankp
Yes....thanks. I've gone throught the process you describe several times with no joy....

Using Widcomm drivers

-On the PC...Bluetooth serial port com8

-Connection settings in Activesync on PC...."allow connection to....com8"

-devices are paired

-On the 2125...Settings/connections/bluetooth/menu/devices/menu/edit/next........the only services that show up are "serial port" and "hands free".

Activesync doesn't show up as a service. I try menu/refresh and still no Activesync. I've deleted the device on the handheld.....rebooted.....turned the phone on/off.....re-paired.....tried port 6 and 7 without any luck. Very frustrating......

Further thoughts?

The ports COM6 and COM7 on the phone side have nothing to do with the port number that you have to give ActiveSync on the PC. In your PC, when you created a Bluetooth Serial Port, did you check what the port number was? You have to use that number in the PC's ActiveSync connection settings.

As far as I can tell, the order of COM6 and COM7 on the phone (for incoming and outgoing) makes no difference.

Does your PC's Bluetooth software notify you when a device tries to connect? If so, do you get any notifications, when you try to connect with ActiveSync from the phone?

Pavan

Link to post
Share on other sites
The ports COM6 and COM7 on the phone side have nothing to do with the port number that you have to give ActiveSync on the PC. In your PC, when you created a Bluetooth Serial Port, did you check what the port number was? You have to use that number in the PC's ActiveSync connection settings.

As far as I can tell, the order of COM6 and COM7 on the phone (for incoming and outgoing) makes no difference.

Does your PC's Bluetooth software notify you when a device tries to connect? If so, do you get any notifications, when you try to connect with ActiveSync from the phone?

Yes, I've matched up the logical bluetooth com8 on the PC with Activesync connections on the PC (allow com8). You asked if the PC Bluetooth notifies me if the device tries to connect. I think maybe this is where the problem is because the answer is no. I do have the PC set to "discoverable". when i look for devices from the phone, the phone does prompt that the PC is trying to connect....do you want to, etc... Yes....enter passkey (on phone)....and then and error pops up (on the phone) saying the pc can't connect.

If I delete the pairing on the PC, and re-pair...it finds the phone...enter passkey from PC....phone prompts for passkey...I enter it (on the phone) and then the pairing appears to be set. 2 way green arrows on the phone icon (on the PC). I don't know what else to test. Bottom line is I never get the activesync service listed on the phone....just serial and hands free.

Link to post
Share on other sites
  • 1 year later...
Guest mjsmith75

Ok..I know this is late but it should still help someone. I finally got my 2125 to connect via bluetooth to activesynce after many frustrating attempts. It has to be noted that I am using the Widcomm stack that came with my Thinkpad T60P, that might be the source of much frustration, anyway....

I think the main issue was that the widcomm stack identified the activesync service as the com5 port and you can't change it....and...it seems that you can't select com 5 as the serial port on your phone, only choices are 6 through 7. So, delete the activesync service in the widcomm configuration page. Delete your pairing with your computer from the phone.

I then went into the widcomm bluetooth pairing setup and selected "add bluetooth device". The phone didn't connect but a popup stated that it created a new activesync service with com port 8 (don't know why it chose 8) so I was encouraged. It didn't actually create any icons or anything so I then initiated a pairing from the phone and things started to work. It mad the connection then then asked me what service I wanted to use, it had serial port (**THIS DOES NOT WORK***) and handsfree as the options. I was looking for activesync (***THIS IS THE KEY***) so I selected the menu in the bottom right hand corner and hit refresh and then lookee there, activesync showed up. I selected activesync and and it connected. I went on to initiate the activsync via bluetooth option from the phone and everything worked smoothly.

A couple notes:

1) I did make sure that in the activesync connection options, it shows com 8 as the port

2) The strange thing is that when I look on my phones com ports...it shows com7 as the one connected to the computer. I don't know if this is coincidence but com port 7 shows up as the serial port on the "Client applications " tab of the widcomm bluetooth options/configuration. Bluetooth on these phone make no sense to me...

3) I retried deleting the pairing, then setting things back up again and it still worked thus convincing me that the main issue was the com port (5) assigned in the default widcomm stack...delete this, force it to create a new one when you pair your phone (don't create your own) and then things should work.

4) I also tried deleting all pairings and the widcomm activesync service to recreate what I had done...man...what a pain in the butt. It wouldn't work the same way so this is a warning... The pairing would startup, the popup came up stating that activesync was connected to com 8 BUT when I wanted to select the service, it only had serial port and handsfree *@#[email protected]#@$#@#$. I hit refresh and nothing @#$#@#@$#@. I did this multiple times and it I finally got the activesync service to show up again...** I don't really know why or how ** HAVE I SAID I HATE ACTIVESYNC AND BLUETOOTH TOGETHER

****What I think worked in getting the activesync service to showup as an option was.....I initiated a pairing from the computer and selected the activesync service, I then went into edit the pairing through the phone, when it came to select the service again, for some reason activesync was there, I selected and everything works again. I AM NOT TOUCHING THESE SETTINGS AGAIN. You will just have to fiddle with multiple options, probably took me 20-25 minutes until it finally worked.

Good luck to all and I hope this helps someone.

Link to post
Share on other sites
Guest Snooginsguy

It's actually really easy, but it requires a trick. First, the phone needs to be unpaired from the computer, so delete the computer from the Bluetooth Devices on the phone. Next, go to The Accessories > USBSwitch function, and change the setting in there. Bear with me, I have upgraded to WM6 on my 2125 (and as such no longer have this USBSwitch function) and I don't remember which is default and which it needs to be set to, but as i recall it needs to be changed to Serial for the Bluetooth activesync to work. If one way doesn't work, try the other one. Then, re-pair the phone with the computer, and this time Activesync should be an available option.

Link to post
Share on other sites
  • 2 months later...
Guest swooshno5
****What I think worked in getting the activesync service to showup as an option was.....I initiated a pairing from the computer and selected the activesync service, I then went into edit the pairing through the phone, when it came to select the service again, for some reason activesync was there, I selected and everything works again.

Thanks for the tip. Those steps above definitely work also for my C600 with Widcomm. Got it to work in the first attempt!

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.