Jump to content

T-Mobile SDA - Official ROM??

Recommended Posts

Guest Phynesse

I guess something went wrong putting the phone (U.S. T-Mobile SDA, the one with da hump) in SuperCID. I flashed it with NiTroGen WM6 ROM and now it is stuck on bootloader RGB screen. :(

Usually I would go back to some official AKU2, but I cannot for the love of it find one. I ve tried most of the 8300 / SP5m etc out there, but the flash utility keeps rejecting them (Invalid vendor id).

Can anyone tell me how I can get this phone back to life?

thanks :D

Link to post
Share on other sites
Guest Phynesse

i actually managed to revive it last night.

Problem was, the SDA was never properly in SuperCID, so it refused to flash any standard ROM. obvious solution is to flash it with original ROM (which there seems to be none) or to patch some compatible ROM with TyphoonNBFtools. but it simply wouldnt work...

here is why it took so long:

i think TyphoonNBFtools 0.4 has a bug where the header data changes wont stick, even after you save them. so no matter what ROM i tried or what I put the header to, the phone wouldnt flash it.

It only worked after I saved it under a different file name (then renamed back manually to nk.nbf), and then flashed it using ROMUpdateUtility.exe v2.00.2 (the one that was provided with NiTroGen WM6 SP1).

heres what I put the header to. not sure if that was even significant in the end:







those changes finally showed up when running ROMUpdateUtility ("Verify that you want to update the ROM version From .... to ...").

All downhill from there. flashed I-mate ROM, unlocked & SuperCID it (confirmed SuperCID with mtty1.42.exe 'info 2') and flashed WM6. phew

One final issue was that I couldnt get GPRS to work at all. found out that we needed to update Radio seperately. did that, and after like 8 hours the friggin SDA finally played nice.

Famous last words:

"WM6 is awesome, dude. bring your phone tonight, it ll take like 20 min."


Link to post
Share on other sites
  • 4 weeks later...
Guest flashhsalf

do you mind listing what exactly you downloaded to get your phone working...i'm in the same s*** and i get the same invalid vendor id.

I'd really appreaciate if you can help me with this. Its my only phone and i just want to get it working.



ok so i figured it out with more searching, but now i get the 'upgrade only' error when flasing.

Which Option ROM did you use? I also have the Tmobile SDA.

Edited by flashhsalf
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.