Jump to content

Fault since 'Cupcake' 1.5 OTA update


Guest Double-K
 Share

Recommended Posts

Me and my gf both have a G1 on T-Mobile, her G1 received the 'Cupcake' 1.5 update OTA last week, since then her screen intermittently displays white lines and will not come back on until removing the battery for a few mins before powering it back up.

My G1 still hadn't received the update OTA, so I downloaded it and installed via my sd card - I have had no problems.

So I tried to run the update again on my gf's G1 via SD card but it errors, i tried the 'wipe data/factory reset' option too, but now when it boots it just goes to the update screen, rendering it useless.

Does any1 know how to do a real factory reset, or roll-back from the OTA update?

Kind Regards

Double-K

Edited by Double-K
Link to comment
Share on other sites

What error do you get when you try and run it via SD?

P

Paul Posted Today, 09:44

Is the device rooted or stock?

P

It's stock, and sorry for forgetting to include the error.

I'm at work now so will reply with the error when I get home.

Thanks in advance

Double-K

Link to comment
Share on other sites

You say you tried a ALT-L/ALT-W factory reset?

P

Yeah it says that it is done, then tells me to reboot, and it just goes back to the 'triangle' screen.

GF is not happy :-(

Double-K

Link to comment
Share on other sites

Right,

I got some help on the T-Mobile forum (Click Here) in putting the old firmware back on (RC7 for UK) to aty least get the phone in working order, which worked fine.

But - when trying to update it onto cupcake, as I did on my G1 (the problem device belongs to my gf, remember :-p) it errored;

Installing from sdcard...

Finding update package...

Opening package...

Verifying package...

Installing update...

E:Failure at line 1: assert file_contains("SYSTEM:build.prop", "ro.build,fingerprint=tmeu/kila_eu/dream/trout:1.1/TMI-RC9/128600:user/ota-rel-keys,release-keys") == "true" || file_contains("SYSTEM:build:prop", "ro.build.fingerprint=tmeu/kila_eu/dream/trouInstallation aborted.

Press Home+Back to reboot

Any ideas on this error?

Also, do you know if T-mobile will push out the OTA update again, or do they mark the account as already having it?

Thanks for your advice so far :-)

Double-K

Edited by Double-K
Link to comment
Share on other sites

Thinking about it, the os it's running is exactly how it was when we got the handset, there was an update between then and the cupcake.

Do the updates need to be done in order?, as i'd need to update to that version before updating to cupcake.

Any idea what that update was?

Double-K

Link to comment
Share on other sites

Well cupcake was pushed OTA to the handset approx 2 hours after putting RC7 back on, have had no further issues, so thanks for all your help.

Double-K

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.