Jump to content

Have a Huawei U8160 need some help please

Guest tytechguy

Recommended Posts

 Hello to all. I am new to this forum. So please bear with me. I have been visiting and reading up but just joined today. First of all you guys are great. I have learned a lot here, so thanks in advance. Now on to my questions. I have 3 Huawei 8160's that I want to root and install new roms on. I also have 2 HTC Inspires that I have already rooted and installed CM7 on and love it! Now I have installed CWM on the first 8160 and also rooted the phone with Superoneclick. The install went fine and it will boot into recovery but there seems to be a big difference between the version on my Inspire and this one. There are menu options that seem to be missing. Namely the "install .zip from SD card" option. The only option to install anything is install update and doesn't give me the option to search for the zip I want. As soon as I page down to "apply sdcard: update.zip"  it tries to find the file and comes back with an error that it couldn't validate the update. I have the rom in the root of my SD card. I have wiped all data and cleared all cache still to no avail. The other thing that bothers me is the fact that this CWM doesn't run a backup of my current rom. I can go into the rom manager and select backup current rom and then reboot and all it does is boot into recovery and never starts a backup. Now when I choose this option on my HTC it boots into recovery and backs up everything just fine. I cant figure out why if the CWM is the same version on both phones, why are the menu options in recovery different? I hope someone can shed some light on this for me. I am kinda new to the android scene, but not new to computers and as far as I can see, they share the same attributes. I have read somewhere that the radio has to be downgraded before a new rom can be installed. Is this true? If so what is the procedure for this? Is it the same as flashing a new rom? Any and all help is much appreciated. 

Link to comment
Share on other sites

  • 9 months later...

I've just come across the same problem. After having used Legdroid custom rom for some time I decided to revert back to one of Voda's official roms because the reduced battery life and camera problems were bugging me.


I got them from here: http://johnnyparanoi.....<br /><br />I have tried three of them:

U8160 V100R001C02B617 (GB Vodafone)


U8160 V100R001C02B650 (UK Vodafone)(05010PTW)


U8160 V100R001C02B617 (Ireland Vodafone)

I can't remember anymore what the original rom supplied with my phone on retail purchase looked like, but it seems similar, although the Play store now looks very different in the phone.

Following the original instructions I used to root and custom rom flash my phone I get the same issue. When I press and hold the power button to reboot, there is no reboot option. Only 3x options of which one is "turn off". I've tried installing screenshot software and get no option in that long power press to screenshot (although that may have been in a custom rom admittedly)

When I reboot, it goes to a black screen with large blue lettering. No "install zip from sdcard" option available.

I'm wondering if Voda changed their roms to eliminate users custom rom flashing the phones at some point? I am going to try searching further for older roms to flash the phone, install rom manager and clockwork recovery and then attempt to reflash a custom rom again. Whilst I have better battery power and my camera back, I can't overclock the phone on the kernel past 600mhz, there is no multi touch, and I like to put mine to 650-670 to behave itself nicely, as well as removing the Voda bloatware.

EDIT: I just tried to backup my current rom with Rom Manager and it booted into recovery where there are no options to backup anything!

Edited by G-razer
Link to comment
Share on other sites

Fixed! The new Vodafone firmware update disabled Rom Manager flashing recovery. You have to do it manually (Thanks to kgs from xda-developers over IRC for this)


Download Fastboot and the recovery image (put on desktop) from there and follow simple instructions to manually flash on a Windoze pc:

Cable and battery out of phone.

Battery in

Down volume and Power to hanging hourglass

Connect usb cable

Rename the recovery image to "recovery" for ease of use

Hold shift and Right click desktop, choose "open command window here"

Type in the command box "fastboot flash recovery recovery.img"

Let it quickly flash the image then type: "fastboot reboot"

Detach cable and you can then boot into full Clockwork Recovery v5.0.2.8 like before and all options are there.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.