Jump to content

Old Pulse - dead?

Guest superquake

Recommended Posts

Hi, I bought a PAYG Pulse here in the UK when they were first released, and after a year or so it was replaced and kept in a drawer. I've decided to take it out of retirement, but can't get it to work. This is what is happening:

Plug it into the mains and the screen stays off, but the buttons flash once every few seconds. Eventually it vibrates for a second and the T-Mobile logo appears. It then seems to stop charging, as it goes no further but after a while goes off and the cycle starts again (flashing buttons, then logo, rinse and repeat).

I can't get recovery to work.

Blue screen boot mode works, and has the following info:

USB FastBoot 0.5

Machine ID 1007000 v0

Build Date: April 19, 2010

Is there any hope? I have tried this with the battery in and out, connected to mains and USB.


Link to comment
Share on other sites

  • 2 weeks later...

i was having exactly the same problem,tried a new battery but nothing,did the 2.1 upgrade and it update completes then does nothing but stay on that screen [restarting],taken batt out+used mains power then it boots to t mobile logo and does nothing again.....?,

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.