Jump to content

No service on iPhone 5s clone - Alps MT6575

Guest nasty000

Recommended Posts

I purchased a iPhone 5s clone from China a month ago. Out-of-the box i could make and receive calls, but i didn't get the mobile internet working.

Anyway, I tried rooting the device using MTK Droid Root & Tools, but the program told me it couldn't do it and linked me to this guide: hxxp://forum.china-iphone.ru/viewtopic.php?p=502084#p502084 (It's in russian, but Google Translate does a good job).

I followed the guide and successfully installed CWM and rooted, but when I booted up the phone I got nothing but "No service", and when I tried to register the phone on any mobile network it always said "Unable to connect to this network at this time".

Now this sounds like an IMEI issue to me, and stupid as I am, i didn't check the IMEI of the phone before I started the root process. If I now enter *#06# in the dialer, it displays what looks like a correct IMEI. Since it is a clone there is no physical IMEI on the device. There is one on the box and I tried changing to that but still got "No service". Again, since it's a clone, the one on the box might no be correct.

Is the problem I'm experiencing an IMEI issue, and if so, is there anything I can do?

Device information:
Hardware: Alps Mediatek MT6575
Display size: 480x800
Model: sanstar15_s006_p5_gb2
Android version: Gingerbread (It says 4.1.2, but I can tell it's Gingerbread)

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.