Jump to content

Help to extract stock rom

Guest handcoded

Recommended Posts



I picked up a refurbed hudl for my grandson who is just about to turn 5 and have filled it up with movies, games, pictures to colour in and audio books.

When I first powered up the device and setup the wifi it performed an ota update to version 1.3.1

Not wanting the Tesco button or apps I rooted the device and downloaded a root uninstaller app from the Play store. It took multiple attempts to remove the apps and in my haste I think I have removed some of the system apps.


I've tried every tutorial I could find in order to try and extract the stock 1.3.1 rom found on this forum so that I can grab the system apps and load them back in but I cannot open it.


I can get into the recovery mode but not the boot loader. I'd prefer not to flash the hudl as it took me hours to load all the apps and stuff into it. I've tried various reboot apps to try and get into it and adb reboot bootloader but the device just switches off.


I found a list of default apps on this forum and have highlighted the ones I am missing. In the attached file my system is on the left.




If someone can post the files I am missing I'd be very grateful.


The other problem is that the hudl is freezing and the left side of the screen when using the keyboard is not working. I've read that this is a known bug and that 1.3.1 and the new button in the display settings fixes this however I do not have the new button.


I don't want to have to explain to a 5 year old why his present does not work as it should.


I'm in desperate need of some help.

Edited by handcoded
Link to comment
Share on other sites

Here you go:-



Please let me know if I have missed any APK's that you need as my PDF reader is strangely cropping and cutting off the right side of your PDF.


Let me know when youve downloaded the zip so I can remove from Dropbox.




Have you thought about backing up all your apps/settings with Titanium Backup Root, Flashing the stock rom, then restore the titanium backup?

Edited by sirius-c
Link to comment
Share on other sites

Dude you're a life saver. I've loaded in all the files but the screen fix button has not appeared. I don't know which file or files to overwrite in order to get the button. I did try the keyboard and it behaved itself but will keep testing it out and will watch out for any random freezes. I could have flashed the stock rom but I spent so long filling up the 16gb with as many games and videos etc that the thought of doing it again would have really pi$$ed me off.


Out of interest if you know how to bust open an Android Rom so that the goodies can be extracted I'd love to know how to do it.

Edited by handcoded
Link to comment
Share on other sites

The ROM files are in ext2 format, so mounting/opening them really depends on your computer's operating system - if you could let us know what you're running then we can probably find you the right tool for the job.

As for the screen freezing - is the hudl definitely updated to 1.3.1?



EDIT: since I'm actually at my computer now and can find my notes:


- Windows - OSFMount


- Mac OS X - Fuse for OS X with fuse-ext2 added


- Linux - no software needed from memory, can be done in terminal (sudo mount /path/to/system.img /mnt/)

Edited by flurry
Link to comment
Share on other sites

Android version 4.2.2

Kernel 3.0.36+

Thu Apr 24


Build JDQ39.20140424.153851


Now I know that the files are ext2 I can go exploring. Thanks

Edited by handcoded
Link to comment
Share on other sites

All sorted now.


The apk for the screen fix and the odex file were missing from my Hudl so I copied them over and restarted and now the option appears. I've had a bit of a manic time trying to sort this out as I will see my grand son tomorrow. Just so relieved that it is finally 100% perfect.


Thanks for the excellent assistance on this forum. If it wasn't for the tools, roms and advice on this forum I doubt I would have been able to fix this problem.

Link to comment
Share on other sites

  • 2 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.