Jump to content

Neutering "T" and more...


Guest smidoid
 Share

Recommended Posts

I can't root the ****ing thing (sorry, ladies present) because I've got a recent machine which got a spanking new OTA update before I could even do a damn thing.

However, for those too scared (or otherwise disinclined) to root, there is a poor man's alternative.

Disable it!

Rather than removing the bloat - you can drag to uninstall all the Tesco (and pretty much all of the Google bloat) - uninstall updates, clear memory and then disable them. You'll get a warning about screwing up other functions but (so far) I've killed ALL the Tesco crud - and most of the Google spyware and the machine is working just fine.  The "T" is still there but it's non-functional.

The amount of stuff Google collects via Android is pretty scary though - so I'm looking forward to a time when the politicians make it a legal requirement that users can actually do what they want with the hardware we paid for - rather than being held to privacy ransom by Google (and Tesco in this case).

If I wasn't so penniless, I'd have bought a machine that was capable of Cyanogenmod (Hudl isn't yet,sadly) but that's my problem.

Google is playing this very cleverly - supporting open source with one hand - and then turning it against us with another. 

Don't be evil my (foil) hat!

Link to comment
Share on other sites

I can't root the ****ing thing (sorry, ladies present) because I've got a recent machine which got a spanking new OTA update before I could even do a damn thing.

 

.... any version of the hudl firmware can be rooted via software tools (that includes a couple of simple 'point+click' standalone / web based programs) found on the internet and mentioned in this and other hudl forums - that is in my experience anyway   :ninja:

 

Rooting isn't for everyone as you say and there are alternatives - but for some specifics you just have to root  :wacko:

Edited by Guest
Link to comment
Share on other sites

I'm sure you're right that rooting a Hudl is still possible - I have the May 2014 firmware so it might be possible (for instance) to back port the 2013 release to the machine; but that *might* also brick it so it's not a risk I can afford to take. I'm 99% sure it wouldn't - but until someone who can afford the £100 is willing to take the risk I'm going to sit on my hands. 
 

Google has done a similar thing with Chromecast making it increasingly difficult to root the machine - which is making the company seem more like Apple all the time.

I can see *some* logic in this; but I want to be able to choose what I put into my device - in much the same way as I can choose what sort of washing power I put in my washing machine.
 

I have several linux boxes here - five at last count but they're all fairly old. One runs Slitaz and another is on "#!" so I'm not scared of taking control so much as making a mistake which invalidates the warranty. We seem to be entering very odd territory here; reminiscent of the browser wars.

Microsoft made Windows (allegedly) require Internet Explorer - and much the same is happening with Google. Every time you merely disable a Google app - there's a dire warning that you might stop the system from working or little green men will jump out and rape your cat.

For the ordinary users (and obviously, we're not "ordinary" users Cap'n) this is enough to scare the crap out of them and have them leave well alone.

Which means Google can continue to use them.

Frankly, I'm becoming tired of being used in this way and I even tried to insert a bridge into my network to see what the Hudl was sending, where and when. It refused to talk to it - which means I've got to do something even more fiddly - hopefully "hubbing out" will work but I just tossed my last hub out a few weeks back in a fit of "I'll never need that old crap again"

This will, eventually, apply to the Hudl; but I resent being told that Android is an open source operating system when a huge amount of it clearly isn't.

Oh for a truly open tablet that didn't cost an arm and a leg...

Something like this: https://zareason.com/shop/zatab.html - for £99 would do me.

Edited by smidoid
Link to comment
Share on other sites

I've got some rooting software that exploits *that* weakness in Android that's supposed to have been patched so I'll give it a go. Being told that "This is compatible with your device" on the Play store and then find that it actually isn't (because root access is required) has finally pushed me over the edge.

I did manage to snoop on what the Hudl was sending back home - and just deleting the YouTube app was enough for it to start sending encrypted information back to home base. There's no way to tell what it was sending because I could only tap into the pipe and see the TLS handshake - but that was enough to prove that it was up to something: something that it has no business doing.

I've got Kingoroot on the Windows box so I'll give that a go. I'd like a poke around in there to see what the deal is anyway.

Intriguing (but not surprising) that, once again, my review of Hudl has been rejected by the Google partner, BazaarVoice. Seems clear to me that they don't want any informed reviews explaining to people what Google are doing with their privacy; hopefully the ICO and others will put some teeth into them and force them to let people do what they want without fear of repercussion.

UPDATE: Well (and given what I read, probably just as well) Kingroot was a failure.

So I gave "trueriver's" script a go and that worked first time. Boom: not quite as easy as the Kingroot system (well, slower anyway) but yeah, worked a charm.

At least it feels more like I own the hardware - next step is to remove or block the Google spyware.

 

Edited by smidoid
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.