Jump to content

Reverting back to original G510-0100 Software.

Guest tonyt1967

Recommended Posts

Hi guys,


I've posted a couple of questions on here for problems to do with rooting my original Vodafone G510-0100 UK version.


Now I managed to root this a few weeks ago, installed Cyanogenmod 11 and Nightly roms.


Now this is what I currently have, from the about screen : -


Cyanogenmod version - 11-20140804-Nightly-u8951


Android Version - 4.4.4


Baseband Version - 2030


Build Number - CM_u8951-userdebug 4.4.4 KTU84Q 06a7abae38 test-keys


I also have latest TWRP and SuperSU Installed


I'm just sick of constant reboots, apps not working, freezing , stuttering audio, unreliable Bluetooth, Camera freezing and so on.


So, what I want to know, if someone can help, is, how do I go back to the original Huawei software as supplied by Vodafone. I have tried several bits of info battared about on here and on internet, but I cannot install the Huawei software. What do I need to do?


I've messed with something I don't understand and I wish I hadn't.


If you can help - I would be a very appreciative, happy person and may try doing cartwheels and may be spend a night in hospital LOL. -


Oh, you have to put any description in Idiot fashion please.



Many thanks in advance.

Edited by tonyt1967
Link to comment
Share on other sites



I've already tried doing this several times - Putting the update.app in the dload folder on the sd card. It never works and barely gets passed first stage then fails.


Do I need to do anything else? Do I need to unroot it? This is driving me nuts. It's embarassing, especially when someone asks me what phone I have and is it any good.



Link to comment
Share on other sites

  • 2 weeks later...

I wonder if it's because I have TWRP installed. I have tried every permutation I can think of. Normally in my case, where there's a will, there's a way, but not this time.


I installed a zipped rom and managed to do that in TWRP, but if I leave the update.app as a zip file, it won't install and says failed.


People have added links to http://camorrahgpl.com/user/huawei/Rom/ - But this domain doesn't exist now. May be someone could lead the way as to where it has gone.


If you have any more ideas, i'd most appreciated



Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.