• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

spvDuke3d [v0.4c]...with Sound/Music now!

619 posts in this topic

Posted

have you tried turning gapi on and off? and are you using a working version of duke nuke? have you tried the full version or demo?

Using shareware version 1.3. I've turned GAPI off too. Alas, no success.

0

Share this post


Link to post
Share on other sites

Posted

My problem is that I cannot discover which are my "Special key" codes...

If I press these:

Camera

Record

Contact

Calendar

it always gives me the same line:

Special key pressed. Num=0

screen01nc0.jpg

I can only use:

Left, Right, Up, Down

VolumeUp, VolumeDown

Enter

Call, endcall

Wich are plenty, I agree... But this game requires more to be fully playable...

So, can anyone give me the S100/S110 codes for these buttons:

- Camera

- Record

- Contact

- Calendar

One more thing, in my tests I tried to place the Calendar button as the Escape and, as a result, all the buttons that usually dont work, started working, but all as Escape. So that appears to me that all the buttons have the same code "zero".

:S

0

Share this post


Link to post
Share on other sites

Posted

Using shareware version 1.3. I've turned GAPI off too. Alas, no success.

sorry i dont know what to tell you..have you used my .cfg file? make a backup of yours and try mine and see if it works. and is your directory the root of the storage card and the folder is spvduke3d?

DUKE3D.zip

0

Share this post


Link to post
Share on other sites

Posted

I just loaded this in my HTC Kaiser/Tilt and there is only one more step.

I need a Duke3d.grp file... it says not found.

thanks.

0

Share this post


Link to post
Share on other sites

Posted

I just loaded this in my HTC Kaiser/Tilt and there is only one more step.

I need a Duke3d.grp file... it says not found.

thanks.

Uhmmmm.. are you sure you have at least the Shareware Version of DukeNukem? ;-)

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hello all. I realize this is supposed to be Smartphone related, but the game port has transcended that label and works on PPC as well, so...

I have Duke3D working on a Samsung i730 with WM5. It works amazingly well. Many thanks to Roozbeh for resurrecting this classic!

For any others with this phone, here are the relevant config settings:

Change the Escape key to something other than 't'. The letter 't' is needed when typing in Cheat Codes :D. I selected 'm', as in - 'menu'. You will have to remove 'm' from the AIM_UP variable.

[Engine Setup]

Alt_EscapeKey = "m"

For Sound, increase the capabilities:

[sound Setup]

NumVoices = 8

NumChannels = 2

NumBits = 16

MixRate = 22000

The touch screen fires the primary weapon with the default config. Change the touchscreen to OPEN (allows you to open doors, panels, light switches by touching the screen):

[Controls]

MouseButton0 = "Open"

Landscape 2 mode puts the controls on the right (for right handed control). Some buttons are 'Special' buttons and have to be mapped using the 'Scan Code Mapping' feature. More on mapping later.

For reference: sc_74 = 'Launcher Key', sc_14 = 'Context Menu Key', Enter = 'Action Key', VolumeUp = 'Back Key'

[scan Code Mapping]

sc_74 = "Softkey1"

sc_14 = "Softkey2"

[KeyDefinitions_Landscape2]

Move_Forward = "w" "RIGHT"

Move_Backward = "s" "LEFT"

Turn_Left = "j" "UP"

Turn_Right = "l" "DOWN"

Fire = "k" "ENTER"

Jump = "SPACE" "VolumeUp"

Aim_Up = "" "SOFTKEY1"

Aim_Down = "" "SOFTKEY2"

Could Use Some Help Here

I have not been successful in mapping any other softkeys (Calendar, Contacts, Call, EndCall). The in-game key preview feature (ShowKeyCodes) only shows "Special Key Num=0" for the Calendar and Contacts keys. The Call and EndCall keys show as normal keys. However, putting Call or EndCall in the Duke3d.cfg file doesn't work.

If I put...

Aim_Up = "m" "EndCall"

....and press the EndCall button in the game, nothing happens. I downloaded a program called 'Keycode.exe' that shows what the code is for the softkeys. It shows:

EndCall (Short Press) = Key 0x73 (115) xmacro=k115

EndCall (Long Press) = Key 0x10 (16) xmaro=x16

Call (Short and Long Press) = Key 0x72 (114) xmacro=k114

Calendar (Short Press) = Key 0x5B (91) xmacro=k91 (immediately changes to: Key 0xC2 (194) xmacro=194)

Calendar (Long Press) = Key 0x5B (91) xmacro=k91 (immediately changes to: Key 0xC8 (200) xmacro=k200)

Contacts (Short Press) = Key 0x5B (91) xmacro=k91 (immediately changes to: Key 0xC2 (195) xmacro=195)

Contacts (Long Press) = Key 0x5B (91) xmacro=k91 (immediately changes to: Key 0xC8 (201) xmacro=k201)

None of the Key numbers or names work with Scan Code Mapping so the buttons are not usuable. If anyone figures out the correct values, please post.

Samsung i730:

sam-i730.jpg

Edited by FUBARX1
0

Share this post


Link to post
Share on other sites

Posted

i loaded all this up on my bj2 and got the duke3d.gpr i put it all in a folder on my storage card. it loads up but then the screen stays black but i can hear all sounds anyone know how to fix it

0

Share this post


Link to post
Share on other sites

Posted

can someone please help. - i have a blackjack 1. - i am using 0.4f version of duke3d

when i attempt to go to the cfg file and try to change certain keys in the cfg file the game will instantly crash every time when i open the game since i edited the cfg file.....for example i cannot change the inventory right key which is "M" if i do the game will crash and even if i attemt to correct this error and put the "M" back in and redo everything over. the game will still crash. and even if i put a brand new cfg file the game will still crash.....so i have to delete the whole duke 3d file.

sometime this will happen even if i dont change anything at all.....

so i have to make 5 backup copys of the whole duke3d file on my storage card

can someone please tell my why this is happening? this is wierd to me ive never seen this before if a game crashes you can restore the cfg file to original setting. or if the game crashes you just restart. but this is wierd. i dont understand this.

0

Share this post


Link to post
Share on other sites

Posted

hey, i can play duke nukem on my TyTn II, however only the 1st level (L.A meltdown) works fine

when i start a new game on the 3 other levels, it crash and thats what i get:

- when i load "lunar apocalypse" it says: Map E2L1.map not found!

- when i load "shrapnel city" it says: Map E3L1.map not found!

- when i load "birth" it says: Map E4L1.map not found!

where can i find those maps?

ive read somewhere how to fix the time delay but i cant find it anymore.

the problem i have is that when i shot, i get the shooting sound like 1 second after.

also when i play on landscape mode, a small picture of the keyboard is displayed in the middle of the bottom of the screen.

how can i get rid of it?

thanks

0

Share this post


Link to post
Share on other sites

Posted

I have answered this in the other topic, look there :D

0

Share this post


Link to post
Share on other sites

Posted

MOTO Q8 DUKE 3D WORKS A OK GREAT JOB!!!

0

Share this post


Link to post
Share on other sites

Posted

hey, i can play duke nukem on my TyTn II, however only the 1st level (L.A meltdown) works fine

when i start a new game on the 3 other levels, it crash and thats what i get:

- when i load "lunar apocalypse" it says: Map E2L1.map not found!

- when i load "shrapnel city" it says: Map E3L1.map not found!

- when i load "birth" it says: Map E4L1.map not found!

where can i find those maps?

ive read somewhere how to fix the time delay but i cant find it anymore.

the problem i have is that when i shot, i get the shooting sound like 1 second after.

also when i play on landscape mode, a small picture of the keyboard is displayed in the middle of the bottom of the screen.

how can i get rid of it?

thanks

DOWNLOAD THE FULL VERSION AND LOAD THE GRP FILE FROM THAT WHICH IS 40MB IF U WANT I CAN SEND THE FILE PM ME

0

Share this post


Link to post
Share on other sites

Posted

Hello,

i can't bind the special key's in the duke3d.cfg file....

i run the prog. keycode.exe from the forum and get this result:

calender 0xc1 (193)

contacts 0xc2 (194)

camera 0xc3 (195)

record 0xc4 (196)

I set ScanCodeMapping = 1 and put this entry in the cfg-file:

sc_193="PPCKey1"

sc_194="PPCKey2"

bla...bla....

It does not work...

It only work when i put sc_F1="PPCKey1" to the cfg-file, but now all key's (calender, contacts, camera and record) are the same...

Can you help me please?

I use a MDA Compact....

Bye Mommel

0

Share this post


Link to post
Share on other sites

Posted (edited)

please we need a DUKE3D.cfg for samsung omnia

who can help me?

i tried many options but no result

Mousebutton0 doesn't work for touchscreen why?

Edited by Persia
0

Share this post


Link to post
Share on other sites

Posted

hi guys! i am new here!

i downloaded this game!

it runs great on my htc s620!

but i am not able to shoot or jump or crouch!

i tried to do a search in this topic but it returned me to the start!

can anyone help me please?

thanks

0

Share this post


Link to post
Share on other sites

Posted

guys duke 3d is workin on xperia x1 at full screen wvga 800x480 it is very fast and playable . The problem is that it crashes on landscape mode (works perfectly on portrait). If someone has a config file or a trick to fix that it will be beautyful. Also check this thread on xda http://forum.xda-developers.com/showthread...935#post4252935

0

Share this post


Link to post
Share on other sites

Posted

It would be helpful if somone took all the .cfg files and tacked them all into one post. This way we don't have to search thru 31 pages just to try and find a cfg that works on our device. Only thing i'm looking for is a cfg file for a Motorola Q - Q9C or O9M. I recall reading about settings for this device but god knows what pages that was on. It was scattered all about as a I recall. If someone could post up a .cfg file for one of these devices, it would be appreciated. thanks peeps :)

0

Share this post


Link to post
Share on other sites

Posted

guys duke 3d is workin on xperia x1 at full screen wvga 800x480 it is very fast and playable . The problem is that it crashes on landscape mode (works perfectly on portrait). If someone has a config file or a trick to fix that it will be beautyful. Also check this thread on xda http://forum.xda-developers.com/showthread...935#post4252935

I've noticed, the thing about landscape is you need to play around with the resolutions. For example, on my Tilt it would crash on landscape. Bear in mind my Tilt's landscape resolution is 320x240. I found I was actually able to run it at 319x240 and it run perfect. Odd, yes?

So when playing with the config file try playing around with the numbers, subtract 1 pixel from your device's actual resolution and see if it fixes the problem.

0

Share this post


Link to post
Share on other sites

Posted

Not working properly managing your finger in landscape mode!!!

Are you fix it? : '(

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.