Jump to content
Sign in to follow this  

Mio 8390

Recommended Posts

:D ;) :D

My phone died and it's just happened today. I found my phone dead this morning and thinking it needs to be charged. I replaced the battery with my spare and tried to turn it on but no luck. The time at front seems to be working but not the accurate time. I could switch the time from analog type to digital but still not booting up. Im in desperate need, please help!!!

#-o #-o #-o

Share this post

Link to post
Share on other sites
this has happend to my mates 8390 and he said he had to take it to the manufactures and they said it was left in the heat to long


Sadly, this is becoming a common problem, it seems. In the past few days I've read over a dozen messages on various boards from people who's 8390 just died for no real reason. Unfortunately, I think you answered your own question. Try to get ahold of someone at mitac and ship it to China for repair. Someone here did that and it ended up costing more for shipping and repair then it would to get another phone so that's what I did.

And what kind of answer is "it was left in the heat too long"? The only thing left in the heat too long is mitac. What jackasses.

Edited by markgamber

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this