• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Mitac 8380 won't start

4 posts in this topic

Posted · Report post

I've just got a brilliant Mitac 8380 from a friend, who attempted to upgrade its ROM, and according to him it didn't work, so he just unplugged the phone from the PC.

The phone won't boot now, it shows a black screen, and it won't switch off unless the battery is removed.

When i hold down the recording button and power it on, nothing happens. (Is this buttons combination the correct to enter the bootloader?).

But even if the phone is powered off, when i plug it on the USB cable Windows detect a new device, and ask for a driver. But i don't know what kind of driver it's looking for. I downloaded the 8380's driver from Mitac, and it's not that the one it's looking for.

0

Share this post


Link to post
Share on other sites

Posted · Report post

To enter the Bootloader hold down the asterisk and both softkeys when you turn on the phone.

0

Share this post


Link to post
Share on other sites

Posted · Report post

To enter the Bootloader hold down the asterisk and both softkeys when you turn on the phone.

<{POST_SNAPBACK}>

Thank you for ur help. Although it doesn't seem to work :D

When the left softkey is held down, the phone won't power on.

I tried different combinations to press the 3 buttons right after the phone is turned on, but still nothing :D

Any ideas suggestions? I e-mailed Mitac Europe, hoping they can help me by sending them the phone for service or something, but still no reply yet.

Don't know what else to do

0

Share this post


Link to post
Share on other sites

Posted · Report post

Also I've jut noticed that when i start the phone using combination of buttons, some times it gives on the external display a number which increaments every time i statt the phone

0:1 0:2 0:3 0:4 etc

Any ideas what these are?

Phone's nonsense? some error codes?

Arg, this situation is killing me. I can find nowhere any helpful info on Mitacs

:shock:

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.