• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

GBA emulator for wince - GBACE 0.1

149 posts in this topic

Posted (edited) · Report post

First test version, using dynamic translation, good speed for some games.

Landscape and other display modes are not supported yet.

tgetfile.dll is needed.

More optimizations are about to add, especially for memory handling.

Games reported unable to run:

Double Dragon Advance

Robotech

Star Wars Episode 3

GBACE0.1.rar

Edited by masterall
0

Share this post


Link to post
Share on other sites

Posted · Report post

just one word GREAT!

very good job as always.....

TEST it !

and messieurs "chapeau bas"

AvAlon5 :rolleyes:

0

Share this post


Link to post
Share on other sites

Posted · Report post

Will this work on a Q?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Very nice, for a test version :rolleyes:

With my Ipaq o/c at 530, and the frameskip at 3, the few games that I tried (mostly 2D games), ran very well.

Sound, wasn't too bad either, at 22khz.

Not quite up there with PocketGBA, but as this is just a test, it's damn good.

Any plans for xscale support ? or GAPI support ?

cheers,

0

Share this post


Link to post
Share on other sites

Posted · Report post

Right off the bat - a major bug is that landscape right or left doesn't work. Regardless, the view comes out portrait and 100% size, regardless of "smooth stretch".

I played Baldurs Gate for a bit and the speed was good - but the sound was terrible. Painful to the ears. I tried Double Dragon Advance - and couldn't even start it. Star Wars Jedi Power Battles wouldn't load. Neither would Final Fight One.

Really, Baldurs Gate was the only game I could get going. I'm running an HTC Apache (Verizon XV6700) overclocked at 624 MHZ. Nice attempt, but this program is not ready for primetime.

0

Share this post


Link to post
Share on other sites

Posted · Report post

great!

i see no bugs so far, and with sound off im getting about 90% of the full speed (overclocked to 252mhz on an OMAP)

0

Share this post


Link to post
Share on other sites

Posted · Report post

every time i try to load a rom it quits out, think this might be the same lanscape phone problem that most of the other emus had.

i am using a samsung i320

0

Share this post


Link to post
Share on other sites

Posted · Report post

hey masterall

for the next version

i am just wondering if it is possible to make the emulator able to portrait on the other side (the display)

bcos the only display tat works now is right portrait or left don't really know how to tell, and it is really hard to press the keys. It would be much better if the emulator is able to display both ways

thankyou

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I take some of my comments back - I was able to load several more games. For some reason, I had to delete all the files created in the same folder as the exe and start over. I recommend this if the program automatically drops out after selecting a game.

However, I still can't change the screen orientation - it always shows portrait so I'm only using half my screen. Literally. Speed on games like Final Fight One is great - I'm going too fast at a frame skip of 1. Jedi Power Battles is also running really fast. Altered Beast - which played poorly on morphgear works fine here.

A couple games that didn't play on sunbug.net's emulator - and only worked on morphgear, completely freeze up my PPC after the opening sequences. I actually have to reset my phone! So far, they're Double Dragon Advance and Robotech. Star Wars Episode 3 just crashes out after the opening sequences which is preferable to a reset. :-)

I'm not ready to try using this regularly at least until the screen orientation can be settled. Has anyone been able to change screen orientation at all? By the way - I think people need to be more specific about what works and doesn't work for this thread to be useful.

Edited by PolloLoco
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

wow i'm gonna test it on wizard...

upd:

still slow on 264 mhz OMAP :rolleyes: , but i can see potential, GREAT WORK, master.

upd: whoops, landscape is not working on wizard...

Edited by nothin
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

well i found 1 bug that can be rather annoying. it only does it when i least supect it. infact right now its not happening when i want it to.

what happens is i will play the game and it works fine, then i exit the emulator. when i go back into the emulator and try to play the same game again, it just goes back to the main window. the only way ive been able to fix this is by deleting the .cfg file for the game controls. once i delete the .cfg file i re configure my controls and try the game again and now it loads.

Edited by mikeeey
0

Share this post


Link to post
Share on other sites

Posted · Report post

Are the Roms needed in a special folder? When i select "Load Rom" nothing happens? :rolleyes:

0

Share this post


Link to post
Share on other sites

Posted · Report post

Are the Roms needed in a special folder? When i select "Load Rom" nothing happens? :rolleyes:

you have tgetfile.dll right?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Wonders of modern technology... I thought i had it, and it was also show in the list of my installed programs. But i had to reinstall it to make it work... WEIRD! :rolleyes:

But now it works, thanks alot!

0

Share this post


Link to post
Share on other sites

Posted · Report post

wow, i have tryed avatar, and it worked grat on my mpx220 on 264 mhz OMAP.

thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

I will check the problem of .cfg file later

for the flip portrait mode, any body has a better name for the four mode? or just call them ROT0, ROT90, ROT180, ROT270?

I will add more display mode soon.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I will check the problem of .cfg file later

for the flip portrait mode, any body has a better name for the four mode? or just call them ROT0, ROT90, ROT180, ROT270?

I will add more display mode soon.

well on all of your emulators you have always just called it landscape left and landscape right. so i think just staying with the tradation is fine =)

0

Share this post


Link to post
Share on other sites

Posted · Report post

I tried it on my Pocket PCs and it works great on my Yakumo, on my T-Mobile Mail it refuses to work, maybe because of the fixed landscape screen and on a VGA Device i got a TIIIIINYYYYY screen... :rolleyes:

Baldurs Gate worked good without sound (crappy sound)

Castlevania HoD worked great with good sound

Defender of the Crown even ran a tad bit to fast...

May Payne and Castlevania CotM froze the emu for me.

0

Share this post


Link to post
Share on other sites

Posted · Report post

does not work on htc s310 just exits the emulator, or hangs up...

0

Share this post


Link to post
Share on other sites

Posted · Report post

First test version, using dynamic translation, good speed for some games.

Landscape and other display modes are not supported yet.

tgetfile.dll is needed.

More optimizations are about to add, especially for memory handling.

Games reported unable to run:

Double Dragon Advance

Robotech

Star Wars Episode 3

hi i have aproblem with the gba i cant get it to load roms on my spv c550 i go to load roms and it does nothing could you help please

0

Share this post


Link to post
Share on other sites

Posted · Report post

hi i have aproblem with the gba i cant get it to load roms on my spv c550 i go to load roms and it does nothing could you help please

Just read the full thread... ;-)

I asked the same a few posts ago...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Did it work on MPx200?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Did it work on MPx200?

Dunno, but if you have one: Try and tell us ! :rolleyes:

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dunno, but if you have one: Try and tell us ! :rolleyes:

It worked, but emulator closes after few seconds of game.

0

Share this post


Link to post
Share on other sites

Posted · Report post

great, but I can't do landscape on eten m700, sega cd emu ?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.