• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Unlocked AT&T i607 unable to use Orange UK sim

10 posts in this topic

Posted (edited)

Hello,

strange one I need help with here - I've got a US wm6 i607 unlocked with a code from at&t. When I use my orange UK USIM it can read the contacts from my sim but can't start the radio stage ( no service, no IMEI displayed - *#06# says 'Failed', cannot alter settings in the service menus ) and I've tried a few ornage UK sims, but when I insert a t-mob UK sim it works fine. T-mob UK and Orange UK use the same GSM frequency. I can only think orange having dedicated 3G USIMS have something setup differently. Although my T-mob sim works on 3G it's a pre 3G older simcard.

Seems a bit odd though. Any explanation / way around it? There must be something as orange supplied the i600 in the UK with a 3G sim. My AT&T sim still works fine roaming. Onto Orange....

M.S

edit - incidently, with the wm6 upgrade, bubble breaker on megashift, first game, all blue bubbles just like the s620. Hello, new highscore!!!

Edited by Mysterious Stranger
0

Share this post


Link to post
Share on other sites

Posted

Hello,

strange one I need help with here - I've got a US wm6 i607 unlocked with a code from at&t. When I use my orange UK USIM it can read the contacts from my sim but can't start the radio stage ( no service, no IMEI displayed - *#06# says 'Failed', cannot alter settings in the service menus ) and I've tried a few ornage UK sims, but when I insert a t-mob UK sim it works fine. T-mob UK and Orange UK use the same GSM frequency. I can only think orange having dedicated 3G USIMS have something setup differently. Although my T-mob sim works on 3G it's a pre 3G older simcard.

Seems a bit odd though. Any explanation / way around it? There must be something as orange supplied the i600 in the UK with a 3G sim. My AT&T sim still works fine roaming. Onto Orange....

M.S

edit - incidently, with the wm6 upgrade, bubble breaker on megashift, first game, all blue bubbles just like the s620. Hello, new highscore!!!

I would also like to know as I'm in the same boat as you. I won a competition over on CoolSmartPhone and received a nice shiney SIM-free BlackJack, loaded the WM6 and now my Orange SIM card wont work :D

0

Share this post


Link to post
Share on other sites

Posted

I would also like to know as I'm in the same boat as you. I won a competition over on CoolSmartPhone and received a nice shiney SIM-free BlackJack, loaded the WM6 and now my Orange SIM card wont work :D

Did it work previously on wm5? The wm5 rom is out there somewhere as an official release to sort radio issues etc.

There is *no* fix for this problem as Samsung refered me to AT&T for 'warranty' reasons when I asked, and as this most likely only affects me and thee with US carrier supplied sim unlocked handsets on a european network ( and how many people are going to have those?) I doubt they'll stop all other rom development and rush to fix it....

I know of no other european network that handles their sim provisioning this way either, just Orange UK. Boo Hiss orange UK.

(The was something similar with the iPaq hw6915 and Orange in Israel where a rom update stopped the phone connecting to the Orange network but at least there was a route to back out of that and as it affected more than just 2 people HP did something!)

Probably not a great deal of help but Orange UK 2.5G sims work fine.

You could try reverting to wm5, asking orange for a non '3G' sim or porting to a different network.

Or flogging it on Fleabay and getting a BJ II - they work just fine on Orange UK 3G and you get GPS too.

M.S

0

Share this post


Link to post
Share on other sites

Posted

I would also like to know as I'm in the same boat as you. I won a competition over on CoolSmartPhone and received a nice shiney SIM-free BlackJack, loaded the WM6 and now my Orange SIM card wont work :D

With a bit of creative use of the wayback machine the wm5 rom update *is* still on samsung's servers despite any links trying to force you to wm6... :D

p.m me if you need the link.

M.S

0

Share this post


Link to post
Share on other sites

Posted

With a bit of creative use of the wayback machine the wm5 rom update *is* still on samsung's servers despite any links trying to force you to wm6... :D

p.m me if you need the link.

M.S

You have a PM! :D It worked fine on all networks before I upgraded to the WM6. Have tried Voda and O2. Voda was a no go. :angry:

0

Share this post


Link to post
Share on other sites

Posted

You have a PM! :D It worked fine on all networks before I upgraded to the WM6. Have tried Voda and O2. Voda was a no go. :D

I've used a Voda sim with a wm6 BJ no problem. Didn't specifically have 3G enabled on it but it gave the 3G icon on screen. Could be the provisioning of your Voda sim?

I've sent you the link to the WM5 rom. As it's an official rom on samsung's server I'll post it here too as no-one should mind ;-)

http://www.samsungwireless.com/techtrain/t...ack_Upgrade.zip

M.S

0

Share this post


Link to post
Share on other sites

Posted

I've used a Voda sim with a wm6 BJ no problem. Didn't specifically have 3G enabled on it but it gave the 3G icon on screen. Could be the provisioning of your Voda sim?

I've sent you the link to the WM5 rom. As it's an official rom on samsung's server I'll post it here too as no-one should mind ;-)

http://www.samsungwireless.com/techtrain/t...ack_Upgrade.zip

M.S

Thanks for the link MS, will have to try it after the weekend due to relationship commitments :D Will try and post results back as soon as I have downgraded.

0

Share this post


Link to post
Share on other sites

Posted

Is it worth trying just the Radio ROM from WM5?

0

Share this post


Link to post
Share on other sites

Posted

Is it worth trying just the Radio ROM from WM5?

Tricky to extract methinks, they don't follow the standard HTC RUU type methods. I'm sure it's been hacked elsewhere though.

IIRC the radio is last to flash, you could downgrade to WM5 then upgrade to WM6 but interupt it before radio flashing. I had this happen to me (communication timeout) and the phone booted fine and flashed OK the second time.

YMMV.

M.S

0

Share this post


Link to post
Share on other sites

Posted (edited)

It worked! By the Beard of Zeus! It took some time trying to get the phone into bootloader AND recognised by the installer :D . Ended up having to reinstall the Samsung Modem drivers once I had read the instructions properly :wacko: . After everything had installed I tried my Orange SIM and it worked! :( ;)

Sorry for the delay in posting results, we got there in the end! ;)

EDIT - So after rolling back to WM5, it now seems Ive lost all the mobile goodiness of Excel and Word. I wouldnt be bothered if i didnt use them but seeing as I do I guess its trade off between a phone I cant use or not working out of office...meh?

You have been warned!

Edited by FORCEFOXFIVE
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.