• Announcements

    • PaulOBrien

      Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • PaulOBrien

      Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
sector

SRS WOW HD 1.5.1.0

207 posts in this topic

Thanks for your appreciation!

They only overwrite defaults, not important... So if you have only default values -6 -2 when device loads, you have these reg. in wrong folder - you have it in WOWHD, but they must be in WOWXT. That was exactly my explanation in #131.

That depends of the way driver initialises in the device - your exactly. But... read my post again if you want to fine tune that outputs, and experiment if you want.

If they dont work, the defaults -6 -2 will be loaded.

Here'w what I've found:

The only key necessary is the WOWHD branch. The WOWXT branch can be deleted (WOWXT is a seperate, different but similar DSP from SRS Labs; the SRS DSP we're installing here is WOW HD). So, for the cabmakers (sector?) you can go back to the original cab and take this spec out of the registry changes in the installer. I'd recommend it, since the presence of the WOWXT branch has been confusing to people.

To get bootup initialization of the OutputGain and InputGain parameters for all audio output devices, the two name/value pairs that Vbox describes in post #131 need to be created in both WOWHD/BtA2dpSnd and in WOWHD/WaveDev. If you only put them in the BtA2dpSnd key, the driver will be initialized at the default values of -2dB, -6dB respectively, and will operate at those levels through the built-in speaker (sounding rather quiet). The initialization values put in the registry under BtA2dpSnd will only activate when you connect a Bluetooth stereo headset.

Putting the gain name/value parms in WOWHD/WaveDev also will cause the driver to be initialized to those values on bootup as well.

Recommendation to cabguys: Add these parameters to the two keys above for the installer cab, and set them to InputGain=dword:2 and OutputGain=dword:0. People will then get the volume boost with initial install that everyone's talking about, without having to set these values.

0

Share this post


Link to post
Share on other sites
Here'w what I've found:

The only key necessary is the WOWHD branch. The WOWXT branch can be deleted (WOWXT is a seperate, different but similar DSP from SRS Labs; the SRS DSP we're installing here is WOW HD). So, for the cabmakers (sector?) you can go back to the original cab and take this spec out of the registry changes in the installer. I'd recommend it, since the presence of the WOWXT branch has been confusing to people.

To get bootup initialization of the OutputGain and InputGain parameters for all audio output devices, the two name/value pairs that Vbox describes in post #131 need to be created in both WOWHD/BtA2dpSnd and in WOWHD/WaveDev. If you only put them in the BtA2dpSnd key, the driver will be initialized at the default values of -2dB, -6dB respectively, and will operate at those levels through the built-in speaker (sounding rather quiet). The initialization values put in the registry under BtA2dpSnd will only activate when you connect a Bluetooth stereo headset.

Putting the gain name/value parms in WOWHD/WaveDev also will cause the driver to be initialized to those values on bootup as well.

Recommendation to cabguys: Add these parameters to the two keys above for the installer cab, and set them to InputGain=dword:2 and OutputGain=dword:0. People will then get the volume boost with initial install that everyone's talking about, without having to set these values.

Thank you dwallersv. Can you please send me a PM the original cab?

I have to talk with VBox and test some things on this then :)

0

Share this post


Link to post
Share on other sites

Hey guys, Awsome work you have made here !

I totally love it, it is working very well for now !

0

Share this post


Link to post
Share on other sites
Here'w what I've found:

The only key necessary is the WOWHD branch. The WOWXT branch can be deleted (WOWXT is a seperate, different but similar DSP from SRS Labs; the SRS DSP we're installing here is WOW HD). So, for the cabmakers (sector?) you can go back to the original cab and take this spec out of the registry changes in the installer. I'd recommend it, since the presence of the WOWXT branch has been confusing to people.

On some i900 driver can selfinitialise as WOWXT, I've see that around in peoples posts. That means the driver (WOWXT and WOWHD are together here) is combined and for now i have no way to realise what makes it to SELFinitialise as WOWHD on some and as WOWXT on other, because i have only one Omnia and on my it initialises as WOWHD. Theese outputs are not impoprtant and if they dont exist, defaults will be loaded: -6 -2.

We have combined driver here - the driver is 1.5.1 and the control panel is 1.2.10, because in the newest 1.5.1 control panel the InputGain and OutputGain sliders don't exist. So - we have the best choise.

need to be created in both WOWHD/BtA2dpSnd and in WOWHD/WaveDev

So, they alredy are writen in the Sector's cabs in both these WOWHD/BtA2dpSnd and in WOWHD/WaveDev, but if the driver runs as WOWXT on some devices, theese outputs will not be read from where they must be and will not be applyed, only defaults will be loaded.

and set them to InputGain=dword:2 and OutputGain=dword:0

I don't realy agree with this. I know there is many and different people and they already boosted up their volumes and we don't want to be blamed for someone's blown speaker. So the given outputs are -4 -2 for the WaveDev.

So if someone have very loud sound and it is distorted somehow from the speaker, he can low volumes with Sound Tester program.

As Sector already say and I can say that, there will be no 100% satisfaction, but we have 100% confirmation in all up posts the driver works on all devices without causing big problems, and this is more important. And so far, so good, that satisfaction is far enough.

I think most interesting thing here is the profiles Headphones and Internal (Stereo). These are only available profiles in our phones. There are many more profiles in the driver, but it decides which can be used for the concrete device. But why Internal (Stereo)? - Because there is Internal (mono) profile too, but driver decides himself to use that profile for integrated speaker and "Headphones" profile for Headsets.

The driver have to change them automatically, but here is the confusion with naming in our device. Samsung have decided to name "Handsfree" instead of "Headset" in the registry, as it in almost all other WinMo devices. That's why the driver cannot change profile from Internal (means "Speaker") to Headphones when you plug in your handsfree.

They both are stereo. I've read around (on Russian site too) because "Headphones" profile is mono, but i will not try to persuade anybody... They get confused because the other profile (called "Stereo") and that "Headphones" must to be a "mono". But this is funny... I definitely can hear in Deep Purple's song guitar coming from right and Jon Lord's organ coming from left in both profiles. ;)

So, the driver has to change profiles himself - when you use your phone without handsfree "Internal" profile must be used and when you plug in your handsfree profile must be changed to "Headphones". But it cannot because of explained confusion.

The profiles are created to be used in different outputs. That's why "Internal" profile has less dynamics and bass (to not blow out your speaker) and the other "Headphones" is with more of them. That explains why after installation in some programs (i didn't know that) we have headphones plugged as icon when they are not plugged. I only wanted to to give you the best from the driver with more good (by my opinion) profile selected when your device loads.

But if someone get confused with that, he definitely can delete that "confusing" key "Headset" from HKLM\System\State\Hardware\ and will get no profile selected when device loads.

But why get people bored with all this technical stuff. Most important already is done and we have here sound driver, that works on all devices.

So far, so good :)

so with this updated cab, in theory you dont need s2u2 anymore because of no freezing. is this statement correct ?

Correct. You can get back your default power settings from Settings, System, Power without problems.

0

Share this post


Link to post
Share on other sites

couldnt say it better. cheers vbox :)

0

Share this post


Link to post
Share on other sites

so far so good, i will report back after i get an sms or a phone call my phone used to freeze all the time after either one of those happened under the old .cab files.

but none the less, great job guys i really appreciate it.

0

Share this post


Link to post
Share on other sites

report back, i got an sms today and it wouldnt wake up after receieving the sms. what comes next

0

Share this post


Link to post
Share on other sites

After 3 days working fine for me, using an i910 w/ Adryn's CF03 base ROM.

0

Share this post


Link to post
Share on other sites
On some i900 driver can selfinitialise as WOWXT, I've see that around in peoples posts. That means the driver (WOWXT and WOWHD are together here) is combined and for now i have no way to realise what makes it to SELFinitialise as WOWHD on some and as WOWXT on other, because i have only one Omnia and on my it initialises as WOWHD. Theese outputs are not impoprtant and if they dont exist, defaults will be loaded: -6 -2.

We have combined driver here - the driver is 1.5.1 and the control panel is 1.2.10, because in the newest 1.5.1 control panel the InputGain and OutputGain sliders don't exist. So - we have the best choise.

So, they alredy are writen in the Sector's cabs in both these WOWHD/BtA2dpSnd and in WOWHD/WaveDev, but if the driver runs as WOWXT on some devices, theese outputs will not be read from where they must be and will not be applyed, only defaults will be loaded.

I think we (the community) need to do a more thorough investigation of this. Since WOWHD and WOWXT are seperate, distinct products, and we are running WOWHD, I'm suspicious that these anecdotal accounts of the WOWXT reg branch being active are thre result of confusion rather than actual function.

One thing for people to try is to simply back up the WOWXT branch and delete it, then see if there is any impact on the operation of WOWHD. Also, go back and check to see if the driver or cpl has recreated the WOWXT branch. In my case on a Verizon 910 running the official CF03 rom, WOWXT has not come back since I deleted it from the registry.

This really is no big deal -- more of academic interest, I suppose. I do think it is unnecessarily confusing, though, if indeed the WOWXT branch is not needed.

Edited by dwallersv
0

Share this post


Link to post
Share on other sites

I know it's redundant, but I just gotta throw more kudos and thanks at Vbox for figuring this out.

There's no question in my mind it's fixed. I've been running for almost a week, doing everything I usually do with the device, and no crashes at all.

Vbox -- can't find that you answered the question, if you know: What is the flags parameter for that fixes this if deleted? Or did you figure that out by trial and error? I'm dying to know!

0

Share this post


Link to post
Share on other sites

working great so far on shokka's latest version !!

thanks.

just one questions, did I get a different version? mine says 1.2.10.0

post-209926-1248998289_thumb.png

0

Share this post


Link to post
Share on other sites

after 2 days, my report in my i900L with DXID1FRL rom from Franlov

- after installation, bluetooh is missing (bluetooth icon from control panel and bluetooh option from wireless manager), a soft reset fix it.

- battery levels are normal

- in ms3, i put a widget to quick access wowhdsettings.. and it works perfect!

- omg! the sound is amazing!!!! coreplayer rocks!!

Thanks for your precious efforts from Chile

0

Share this post


Link to post
Share on other sites

just installed.

will report back if anything happen.

Thanks. ;)

But how come the version is 1.2.10? :)

Edited by 6gate
0

Share this post


Link to post
Share on other sites

Thanks Sector and team!! this will def be in my next rom!!!!!!

0

Share this post


Link to post
Share on other sites

I am using it for two days. working fine. Thanks for your hard work.

0

Share this post


Link to post
Share on other sites

hello :)

For me its working well too. and the sound is amazing (headphone and handset)

But when my phone rings it roars.

sorry for the english *g*

0

Share this post


Link to post
Share on other sites

I'm probably opening up a can of worms here....

After installing WOW Hd 1.5.1.0 the improvements are excellent on my i910 with BW MS3 1.2.

So my question whats everyone using for a music player ??

I currently use Kimona, sort of a all in one program that has some features I like but kind of a hog.

I tried Nitrogen but I could't get the "play all songs" shuffle effect going. WM player is what it is even more boring no features.

I appreciate any input :)

0

Share this post


Link to post
Share on other sites

This doesnt work very well cooked in!! locks up the phone when ever it goes to sleep!!

0

Share this post


Link to post
Share on other sites
This doesnt work very well cooked in!! locks up the phone when ever it goes to sleep!!

most probably cause u need to apply also the security xml settings

0

Share this post


Link to post
Share on other sites
most probably cause u need to apply also the security xml settings

hmm let me try that! think i can just add it to the OEM?

*edit that worked!!!! no black screen of death for an hour so far when cooked in!!!!! Thanks Sector!!!

Edited by bga7x
0

Share this post


Link to post
Share on other sites

I just want to chime in and say thanks for working on this. I've always wanted to try it out, and now that I see a lot of positive feedback, I went ahead and installed it per the directions in the first thread. All I can say is...WOW. The increase in sound quality, even at default settings, is absolutely amazing. I've always been considering buying Kinoma (which I still may), mainly because the EQ is disabled in the free version, but after installing this and putting it on "Metal" (and tweaking the bass a bit), it sounds better than my iPod ever did, also there's quite a significant increase in volume as well, I'd say around 15% or so. (Volume in my car at 16 sounds like it did at around 20 before).

0

Share this post


Link to post
Share on other sites

sorry for being a noob but what exactly does this do?

0

Share this post


Link to post
Share on other sites
sorry for being a noob but what exactly does this do?

Nothing. Move along.

-OR-

Read the thread. There's more than enough here to answer your question.

0

Share this post


Link to post
Share on other sites
report back, i got an sms today and it wouldnt wake up after receieving the sms. what comes next

AFAIK, you're the only one that has had this happen.

I've recieved tons of SMS, MMS, and emails since I installed it well over a week ago, and I've had not a single crash.

I'm guessing you did something wrong in the install, or have some other problem with your phone.

0

Share this post


Link to post
Share on other sites
I just want to chime in and say thanks for working on this. I've always wanted to try it out, and now that I see a lot of positive feedback, I went ahead and installed it per the directions in the first thread. All I can say is...WOW. The increase in sound quality, even at default settings, is absolutely amazing. I've always been considering buying Kinoma (which I still may), mainly because the EQ is disabled in the free version, but after installing this and putting it on "Metal" (and tweaking the bass a bit), it sounds better than my iPod ever did, also there's quite a significant increase in volume as well, I'd say around 15% or so. (Volume in my car at 16 sounds like it did at around 20 before).

I bought Kimona and like I said its sort of a all in one program and a bit of a hog but does have a LOT of add-on features. Some I like, some to me are a waste.Thats why its all in one.

I couldn't agree with you more about the sound volume improvement.I trashed my first Omnia messing around with the sound tester deal.

Edited by kdkinc
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.