• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

[FIX] 1.3 Wifi workaround

4 posts in this topic

Posted · Report post

Copy and pasted from my XDA developers post...thought it was worth mentioning here:

Hello, a quick fix for MoDaCos 1.3 patch if you can't get wifi working:

It's not actually the wifi that doesnt work its getting an IP from DHCP...

If you assign a static IP to your Hero it will connect just fine.

So, from your LAN connected computer open a command prompt

(in Windows XP/2000/Vista/Seven hit windows key + r and type cmd)

Now type ipconfig

You should get...

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::2537:f86e:d816:589c%11

IPv4 Address. . . . . . . . . . . : 192.168.1.101

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.1.1

Or something similar...

Now on your Hero go to

Settings -> Wireless Controls -> Wi-Fi settings

Hit the menu key and then Advanced

Scroll down to IP settings and tick the "Use static IP" box.

Enter IP adress...

In my case as my PC's IP address is 192.168.1.101 I must use the range 192.168.1.* so enter a random number to replace * ie:

192.168.1.123

Now set the gateway IP to whatever your "default gateway" appears in your command prompt. In my case 192.168.1.1

Now set Netmask to the same as the "subnet mask" in the command prompt,

in my case: 255.255.255.0

Now with DNS 1 and DNS 2 you have 2 options:

1) Use your routers DHCP settings (not sure if this works I haven't tried)

so set the DNS server to the same IP as the gateway (in my case 192.168.1.1)

2) KNOWN TO WORK! Set the DNS servers to a company like opendns.com:

DNS1: 208.67.222.222

DNS2: 208.67.220.220

Et Voila....You now have working wifi!

Cheers.

0

Share this post


Link to post
Share on other sites

Posted · Report post

This is a CONFIRMED fix for the wifi issue... run 'adb shell' then:

mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system
cd /etc
chmod 755 dhcpcd
cd dhcpcd
chmod 755 dhcpcd-hooks
chmod 755 dhcpcd.conf
chmod 755 dhcpcd-run-hooks
chmod 755 dhcpcd-hooks/95-configured
chmod 755 dhcpcd-hooks/20-dns.conf
chmod 755 dhcpcd-hooks/01-test
mount -o remount,ro -t yaffs2 /dev/block/mtdblock3 /system[/code]

Just ran through this on MSN with scopes64 and it's all good! :)

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

This is a CONFIRMED fix for the wifi issue... run 'adb shell' then:

mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system

 cd /etc

 chmod 755 dhcpcd

 cd dhcpcd

 chmod 755 dhcpcd-hooks

 chmod 755 dhcpcd.conf

 chmod 755 dhcpcd-run-hooks

 chmod 755 dhcpcd-hooks/95-configured

 chmod 755 dhcpcd-hooks/20-dns.conf

 chmod 755 dhcpcd-hooks/01-test

 mount -o remount,ro -t yaffs2 /dev/block/mtdblock3 /system

Just ran through this on MSN with scopes64 and it's all good! :D

P

Brilliant Paul, sorry was just sorting out something basic until you and your overly sized brain fixed it :angry:

0

Share this post


Link to post
Share on other sites

Posted · Report post

I was having the same problem. Turns out that phone's DHCP Daemon was requesting an ip on my network that was already occupied (i did not have a static ip set in the phone).

set up a packet monitor on my access point, and watched the endless loop of DHCP-REQUEST, DHCP-NACK, and realized that my phone didnt get the hint that it couldnt have the IP it wanted..... sooo

this works for me:

login with ADB shell

access root (su)

navigate to /data/misc/dhcp

rm dhcp_list

will remove dhcp preferences

This is a CONFIRMED fix for the wifi issue... run 'adb shell' then:

mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system

cd /etc

chmod 755 dhcpcd

cd dhcpcd

chmod 755 dhcpcd-hooks

chmod 755 dhcpcd.conf

chmod 755 dhcpcd-run-hooks

chmod 755 dhcpcd-hooks/95-configured

chmod 755 dhcpcd-hooks/20-dns.conf

chmod 755 dhcpcd-hooks/01-test

mount -o remount,ro -t yaffs2 /dev/block/mtdblock3 /system

Just ran through this on MSN with scopes64 and it's all good! :)

P

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.