• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

06/Jan - Installing the patched recovery image on your device

157 posts in this topic

Posted

hi, im getting stuck at the fastboot command (im using a mac).

it says downloading boot.img failed.

so i tried recovery flash, which starts with a website on the textarea, i pressed backup, changed it to /sdcard/cmg-hero-recovery.img then it says failed.

help please

You sure you made it as a root user ?

0

Share this post


Link to post
Share on other sites

Posted

You sure you made it as a root user ?

I'm having exactly the same problem as the user you replied to, but I'm not sure what you mean by "made it as a root user"?

Could you please elaborate?

0

Share this post


Link to post
Share on other sites

Posted

Question! I installed the cynagon recovery mod when I first got my Hero, so I could update to the modaco rom (then 2.0 I think, maybe sooner). I've been updating the Modaco rom ever since, great! Should I also update the recovery image, is there any benefit? And is it just a case of overwriting the old one by repeating the steps? Thanks.

i would also like to know this. anyone?

0

Share this post


Link to post
Share on other sites

Posted

i would also like to know this. anyone?

Don't know excactly if it is useful, but that's what I did. from scratch. Now, I run the RA-1.3.2 image. You get the new menus and it's worth the try. :D

0

Share this post


Link to post
Share on other sites

Posted (edited)

Don't know excactly if it is useful, but that's what I did. from scratch. Now, I run the RA-1.3.2 image. You get the new menus and it's worth the try. :D

and where do you get the latest? at the beginning of his thread or somewhere else?

also, did you have any kind of troubles after this? applying new modaco roms or anything?

Edited by toxic-hero
0

Share this post


Link to post
Share on other sites

Posted

and where do you get the latest? at the beginning of his thread or somewhere else?

also, did you have any kind of troubles after this? applying new modaco roms or anything?

Look at this forum topic: Amon Ra recovery image 1.5.1 out

I installed it without any problems - the menu system looks a lot tidier than in v1.2.3 that is in the attachment at the beginning of this thread. Not really noticed any other differences yet, but I haven't really played with it yet!

Iain

0

Share this post


Link to post
Share on other sites

Posted

This doesn't work for me. After I type:

fastboot-windows boot recovery-RA-hero-v1.2.3.img

I get this error: FAILED (remote: not allow)

What can i do?!

Thx

0

Share this post


Link to post
Share on other sites

Posted (edited)

I tried running this on my G2 and can't get it to load when pressing the home + power buttons. Instead I get an image like this (shown on a G1) http://bero.freqvibez.net/public/g1/7.jpg

The first time I ran the first line I got "adb server is out of date. killing... * daemon started sucessfully *". From there I ran the second line and it worked as expected. The recovery screen loaded, I ran Nandroid backup. I also managed to install the latest radio. It seems the only way I'm able to get to the patched recovery is running these commands while my Hero is connected via USB.

Any pointers as to how to get the home + power combination working? Thank you.

Edited by mr_tim
0

Share this post


Link to post
Share on other sites

Posted (edited)

This doesn't work for me. After I type:

fastboot-windows boot recovery-RA-hero-v1.2.3.img

I get this error: FAILED (remote: not allow)

try this. it worked for me.

adb kill-server

sudo adb start-server
than retry
fastboot-windows boot recovery-RA-hero-v1.2.3.img

Edited by toxic-hero
0

Share this post


Link to post
Share on other sites

Posted

You have a protected bootloader, you need to use InstantRoot.apk to root then flash the recovery image that way!

P

0

Share this post


Link to post
Share on other sites

Posted

hi,paul

great work!

i am a chinese and i am using sprint CDMA hero200

there are a problem bothering me very much

when i send text messages in chinese letters ,the receiver would receive the wrong-code message that cannot be read.

Would u be so kind to take some measures that making sprint hero support PDU(Protocol Data Unit) just like Dream\Magic\Hero in China.These GSM cell phones can Send/receive chinese SMS and they all run on android 1.5.

Any chance to support chinese SMS in near future?

thanks anyway

0

Share this post


Link to post
Share on other sites

Posted

I found this video on youtube from theunlockr on how to install the recovery on your phone with a terminal emulator...

I followed it and upgraded my hero with the new 1.5.2.. works like a charm

(if its not allowed to post links, I apologize)

0

Share this post


Link to post
Share on other sites

Posted

I found this video on youtube from theunlockr on how to install the recovery on your phone with a terminal emulator...

I followed it and upgraded my hero with the new 1.5.2.. works like a charm

(if its not allowed to post links, I apologize)

Shame that 'better terminal' costs.

0

Share this post


Link to post
Share on other sites

Posted

Shame that 'better terminal' costs.

Little bit, but I don't mind give a few $ for it ;) I think it's a fast easy way to do the update ;)

0

Share this post


Link to post
Share on other sites

Posted

Newbie here on flashing...

Im running Win7 w/ HTC Sync, the adb lists devices fine and such and Im able to run commands. I tried running the windows shell and keep getting ./ invalid command, so I redid the commands to be line by line and that seems to go through ok, until I get to

SUCCESS: Enjoy the shell.

#

Nothing seems to happen after that and I cant type anything in. If I run the adb shell /dala/local/asroot2 /system/bin/sh manually I get the same message and cant type anything in the #.

I figured this process would take about 1-2 mins but nothing has happened after several mintes, so Im not sure if Im missing something when I redid the .bat file or because its not all on one line?

I have an HTC HERO from SPRINT in the US.

Just an FYI: Im assuming I need to do this to 1. run the nandroid backup and 2. when I put the update.zip on and goto flash I keep getting these 'verification failed' messages. I tried the modaco rom and the 2.1 1.7 rom from htc-developers forum.

thanks in advance!

0

Share this post


Link to post
Share on other sites

Posted

No luck here with scripts completing on Win7 or Mac 10.5 - stopped at "enjoy the shell" right after it SUs the adb shell. Executed the script by hand instead; <3 TextEdit on one side, Terminal on the other.

I was trying the same thing after going through this but I get stuck at the shell mount -o remount command. I get an error that adb is not found, because its executing from the # prompt. I try it w/o the adb shell by just typing mount -o remount ... and that gives an error too. Running the commands manually yields the ability to type up to the command that calls the /system/bin/sh where you just sit at a shell prompt.

0

Share this post


Link to post
Share on other sites

Posted

hi guys

quick qst for GSM HTC Hero.....Basically I didnt use any coding or typing in dos commands...i used flashrec.apk file and then a cyanogen img to flash the patched recovery on my device....booted into recovery mode...and then made a nandroid backup of my phone (which was on the official unrooted 2.73.405.5 ROM).....

after doing nandroid backup, I proceeded to root/load modaco custom ROM 2.8.......then I decided to revert back to original HTC hero rom due to some problems (my SMS messages started coming to the phone late...upto 4-5 hours after the SMS were sent to my phone....this didnt happpen on official 2.73.405.5 ROM)...anyone have this problem? anyway...so basically I done nandroid restore.....but now i have the flashed patched recovery image (cyanogen) that I put on using flashrec.apk..........how do i return the original recovery console so that if the phone goes back to HTC for warranty they cant tell i been flashing images/roms to the phone.

Thanks all in advance!

0

Share this post


Link to post
Share on other sites

Posted (edited)

I found this video on youtube from theunlockr on how to install the recovery on your phone with a terminal emulator...

I followed it and upgraded my hero with the new 1.5.2.. works like a charm

(if its not allowed to post links, I apologize)

Followed to a T and now I can't boot into recovery, thankfully the Hero boots normally. Would it be worthwhile finding an previous version of the recovery image and just flashing again?

EDIT: Ignore that. Obviously had a corrupted .img file

Edited by scuj1
0

Share this post


Link to post
Share on other sites

Posted

Updated to 1.5.2 images.

P

0

Share this post


Link to post
Share on other sites

Posted

The link it's down :) can you fix it?

0

Share this post


Link to post
Share on other sites

Posted

Fixed!

P

0

Share this post


Link to post
Share on other sites

Posted

Fixed!

P

Thks:)

0

Share this post


Link to post
Share on other sites

Posted

Hi guys,

Is it true?

By flashing to the official 2.73 ROM, the Fastboot method no longer works. I used Flashrec to flash my recovery image.

http://androidforums.com/htc-hero/19660-gu...custom-rom.html

I have an official 2.73 ROM. I need to use flashrec instead of this fastboot?

This topic is outdated?

Thanks

0

Share this post


Link to post
Share on other sites

Posted

Yeah, I need to update it. Use InstantRoot.apk or flashrec.

P

0

Share this post


Link to post
Share on other sites

Posted

I have a GSM Hero on Windows, and I am on the final step, and it is just sitting there. How long is it meant to take?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.