• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

[Fail] Can't turn on my OMNIA anymore. :(

2 posts in this topic

Posted (edited)

I was triing to install the official ROM i found from the samsung webby via GrandPRIX but suddenly it gave an error counting down saying it cannot create a port.

I tried hard resetting i pressed some random key and samsung animation appear but than phone shut down again and i never could start it again. :(

I checked web and they said that the phone boot area is damaged because of failed flashing,

Can someone help me please? I'm so messed up and i need my phone to get back to life fast :)

Add: I left it away on charge for some time and i press power a phone with an exclamation mark on it appeared and i tried to hard reset but the samsung animation came, phone shut down and now power button doesn't work again?

Edited by Tuzki

Share this post

Link to post
Share on other sites


Problem is you probably did not install samsung cmda drivers. These drivers ar needed to switch to phone when upgrading your rom.

You can still try to repair your phone though it is normally said you have bricked it.

Install Active sync agian.

Install cmda drivers which can be found at samsungs download site.

Disconnected from the internet.

Stop your virusscanner.

Connect your phone to the computer.

Start the updater.

Check the box to format internal memory.

Try to start your phone again and again till it starts.

When phone is recognized by the updater, start updater.

Everything works best when you're running windows XP.

If this doesn't work try searching modaco. Someone has mentioned he send his phone to hungary and it came back in one week and was repaired. I believe this was done through e-bay but I'm not sure.

Good luck.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.